parent
dd5e8efa7d
commit
870205ac73
@ -1 +1 @@
|
|||||||
/libappindicator-12.10.0.tar.gz
|
SOURCES/libappindicator_12.10.1+20.10.20200706.1.orig.tar.gz
|
||||||
|
@ -0,0 +1 @@
|
|||||||
|
8709a62b688e542ac27df766e7230d0b0d9588d4 SOURCES/libappindicator_12.10.1+20.10.20200706.1.orig.tar.gz
|
@ -1,12 +0,0 @@
|
|||||||
diff -up libappindicator-12.10.0/src/app-indicator.c.build_fix libappindicator-12.10.0/src/app-indicator.c
|
|
||||||
--- libappindicator-12.10.0/src/app-indicator.c.build_fix 2018-04-10 14:43:57.134400594 +0200
|
|
||||||
+++ libappindicator-12.10.0/src/app-indicator.c 2018-04-10 14:45:34.655448722 +0200
|
|
||||||
@@ -2196,7 +2196,7 @@ app_indicator_set_secondary_activate_tar
|
|
||||||
|
|
||||||
g_return_if_fail (GTK_IS_WIDGET (menuitem));
|
|
||||||
|
|
||||||
- priv->sec_activate_target = g_object_ref(G_OBJECT(menuitem));
|
|
||||||
+ priv->sec_activate_target = g_object_ref(menuitem);
|
|
||||||
priv->sec_activate_enabled = widget_is_menu_child(self, menuitem);
|
|
||||||
g_signal_connect(menuitem, "parent-set", G_CALLBACK(sec_activate_target_parent_changed), self);
|
|
||||||
}
|
|
@ -1,59 +0,0 @@
|
|||||||
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
|
|
||||||
index d1f6d73..dccca6c 100644
|
|
||||||
--- a/bindings/Makefile.am
|
|
||||||
+++ b/bindings/Makefile.am
|
|
||||||
@@ -3,7 +3,6 @@ SUBDIRS = \
|
|
||||||
vala
|
|
||||||
else
|
|
||||||
SUBDIRS = \
|
|
||||||
- python \
|
|
||||||
vala
|
|
||||||
endif
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index ee03390..4713b22 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -181,33 +181,6 @@ AM_CONDITIONAL(BUILD_MONO_TEST, test x${have_nunit} = xyes)
|
|
||||||
with_localinstall="no"
|
|
||||||
AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all of the files localy instead of system directories (for distcheck)]), with_localinstall=$enableval, with_localinstall=no)
|
|
||||||
|
|
||||||
-###########################
|
|
||||||
-# Python
|
|
||||||
-###########################
|
|
||||||
-
|
|
||||||
-PYGTK_REQUIRED=2.14.0
|
|
||||||
-PYGOBJECT_REQUIRED=0.22
|
|
||||||
-
|
|
||||||
-AM_PATH_PYTHON(2.3.5)
|
|
||||||
-AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
|
|
||||||
-
|
|
||||||
-PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
|
|
||||||
- [
|
|
||||||
- pygtk-2.0 >= $PYGTK_REQUIRED
|
|
||||||
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
|
|
||||||
- pygobject-2.0 >= $PYGOBJECT_REQUIRED
|
|
||||||
- ])
|
|
||||||
-
|
|
||||||
-AC_MSG_CHECKING(for pygtk defs)
|
|
||||||
-PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
|
|
||||||
-AC_SUBST(PYGTK_DEFSDIR)
|
|
||||||
-AC_MSG_RESULT($PYGTK_DEFSDIR)
|
|
||||||
-
|
|
||||||
-AC_MSG_CHECKING(for pygtk codegen)
|
|
||||||
-PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
|
|
||||||
-AC_SUBST(PYGTK_CODEGEN)
|
|
||||||
-AC_MSG_RESULT($PYGTK_CODEGEN)
|
|
||||||
-
|
|
||||||
#########################
|
|
||||||
# Check if build tests
|
|
||||||
#########################
|
|
||||||
@@ -239,8 +212,6 @@ src/Makefile
|
|
||||||
src/appindicator-0.1.pc
|
|
||||||
src/appindicator3-0.1.pc
|
|
||||||
bindings/Makefile
|
|
||||||
-bindings/python/Makefile
|
|
||||||
-bindings/python/appindicator.override
|
|
||||||
bindings/vala/Makefile
|
|
||||||
bindings/vala/examples/Makefile
|
|
||||||
tests/Makefile
|
|
Loading…
Reference in new issue