parent
3a7056add4
commit
8508f7a524
@ -0,0 +1,59 @@
|
||||
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
|
||||
index d1f6d73..dccca6c 100644
|
||||
--- a/bindings/Makefile.am
|
||||
+++ b/bindings/Makefile.am
|
||||
@@ -3,7 +3,6 @@ SUBDIRS = \
|
||||
vala
|
||||
else
|
||||
SUBDIRS = \
|
||||
- python \
|
||||
vala
|
||||
endif
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index ee03390..4713b22 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -181,33 +181,6 @@ AM_CONDITIONAL(BUILD_MONO_TEST, test x${have_nunit} = xyes)
|
||||
with_localinstall="no"
|
||||
AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all of the files localy instead of system directories (for distcheck)]), with_localinstall=$enableval, with_localinstall=no)
|
||||
|
||||
-###########################
|
||||
-# Python
|
||||
-###########################
|
||||
-
|
||||
-PYGTK_REQUIRED=2.14.0
|
||||
-PYGOBJECT_REQUIRED=0.22
|
||||
-
|
||||
-AM_PATH_PYTHON(2.3.5)
|
||||
-AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
|
||||
-
|
||||
-PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
|
||||
- [
|
||||
- pygtk-2.0 >= $PYGTK_REQUIRED
|
||||
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
|
||||
- pygobject-2.0 >= $PYGOBJECT_REQUIRED
|
||||
- ])
|
||||
-
|
||||
-AC_MSG_CHECKING(for pygtk defs)
|
||||
-PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
|
||||
-AC_SUBST(PYGTK_DEFSDIR)
|
||||
-AC_MSG_RESULT($PYGTK_DEFSDIR)
|
||||
-
|
||||
-AC_MSG_CHECKING(for pygtk codegen)
|
||||
-PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
|
||||
-AC_SUBST(PYGTK_CODEGEN)
|
||||
-AC_MSG_RESULT($PYGTK_CODEGEN)
|
||||
-
|
||||
#########################
|
||||
# Check if build tests
|
||||
#########################
|
||||
@@ -239,8 +212,6 @@ src/Makefile
|
||||
src/appindicator-0.1.pc
|
||||
src/appindicator3-0.1.pc
|
||||
bindings/Makefile
|
||||
-bindings/python/Makefile
|
||||
-bindings/python/appindicator.override
|
||||
bindings/vala/Makefile
|
||||
bindings/vala/examples/Makefile
|
||||
tests/Makefile
|
Loading…
Reference in new issue