Subpackage python2-appindicator has been removed

epel9
Miro Hrončok 5 years ago
parent 3a7056add4
commit 8508f7a524

@ -1,6 +1,6 @@
Name: libappindicator Name: libappindicator
Version: 12.10.0 Version: 12.10.0
Release: 25%{?dist} Release: 26%{?dist}
Summary: Application indicators library Summary: Application indicators library
License: LGPLv2 and LGPLv3 License: LGPLv2 and LGPLv3
@ -9,6 +9,7 @@ Source0: https://launchpad.net/libappindicator/12.10/%{version}/+download/%{name
Patch0: 0001_Fix_mono_dir.patch Patch0: 0001_Fix_mono_dir.patch
# https://bazaar.launchpad.net/~indicator-applet-developers/libappindicator/trunk.16.10/revision/285 # https://bazaar.launchpad.net/~indicator-applet-developers/libappindicator/trunk.16.10/revision/285
Patch1: incompatible_pointer_build_fix.patch Patch1: incompatible_pointer_build_fix.patch
Patch2: nopython.patch
BuildRequires: autoconf BuildRequires: autoconf
BuildRequires: automake BuildRequires: automake
@ -23,8 +24,6 @@ BuildRequires: gtk2-devel
BuildRequires: gtk3-devel BuildRequires: gtk3-devel
BuildRequires: libindicator-devel BuildRequires: libindicator-devel
BuildRequires: libindicator-gtk3-devel BuildRequires: libindicator-gtk3-devel
BuildRequires: python2-devel
BuildRequires: pygtk2-devel
%ifarch %{mono_arches} %ifarch %{mono_arches}
BuildRequires: gtk-sharp2-devel BuildRequires: gtk-sharp2-devel
BuildRequires: gtk-sharp2-gapi BuildRequires: gtk-sharp2-gapi
@ -38,16 +37,6 @@ on KSNI it also works in KDE and will fallback to generic Systray support if
none of those are available. none of those are available.
%package -n python2-appindicator
%{?python_provide:%python_provide python2-appindicator}
Summary: Python 2 bindings for %{name}
Requires: %{name} = %{version}-%{release}
%description -n python2-appindicator
This package contains the Python 2 bindings for the appindicator library.
%package devel %package devel
Summary: Development files for %{name} Summary: Development files for %{name}
@ -117,6 +106,8 @@ This package contains the development files for the appindicator-sharp library.
%setup -q %setup -q
%patch0 -p1 -b .monodir %patch0 -p1 -b .monodir
%patch1 -p1 -b .incompatible_pointer_build_fix %patch1 -p1 -b .incompatible_pointer_build_fix
%patch2 -p1 -b .nopython
sed -i "s#gmcs#mcs#g" configure.ac sed -i "s#gmcs#mcs#g" configure.ac
# fix for gtk-doc 1.26 # fix for gtk-doc 1.26
@ -167,16 +158,6 @@ find %{buildroot} -type f -name '*.la' -delete
%{_libdir}/girepository-1.0/AppIndicator-0.1.typelib %{_libdir}/girepository-1.0/AppIndicator-0.1.typelib
%files -n python2-appindicator
%dir %{python2_sitearch}/appindicator/
%{python2_sitearch}/appindicator/__init__.py*
%{python2_sitearch}/appindicator/_appindicator.so
%dir %{_datadir}/pygtk/
%dir %{_datadir}/pygtk/2.0/
%dir %{_datadir}/pygtk/2.0/defs/
%{_datadir}/pygtk/2.0/defs/appindicator.defs
%files devel %files devel
%dir %{_includedir}/libappindicator-0.1/ %dir %{_includedir}/libappindicator-0.1/
%dir %{_includedir}/libappindicator-0.1/libappindicator/ %dir %{_includedir}/libappindicator-0.1/libappindicator/
@ -238,6 +219,10 @@ find %{buildroot} -type f -name '*.la' -delete
%endif %endif
%changelog %changelog
* Wed Sep 04 2019 Miro Hrončok <mhroncok@redhat.com> - 12.10.0-26
- Subpackage python2-appindicator has been removed
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 12.10.0-25 * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 12.10.0-25
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -0,0 +1,59 @@
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
index d1f6d73..dccca6c 100644
--- a/bindings/Makefile.am
+++ b/bindings/Makefile.am
@@ -3,7 +3,6 @@ SUBDIRS = \
vala
else
SUBDIRS = \
- python \
vala
endif
diff --git a/configure.ac b/configure.ac
index ee03390..4713b22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -181,33 +181,6 @@ AM_CONDITIONAL(BUILD_MONO_TEST, test x${have_nunit} = xyes)
with_localinstall="no"
AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all of the files localy instead of system directories (for distcheck)]), with_localinstall=$enableval, with_localinstall=no)
-###########################
-# Python
-###########################
-
-PYGTK_REQUIRED=2.14.0
-PYGOBJECT_REQUIRED=0.22
-
-AM_PATH_PYTHON(2.3.5)
-AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
-
-PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
- [
- pygtk-2.0 >= $PYGTK_REQUIRED
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
- pygobject-2.0 >= $PYGOBJECT_REQUIRED
- ])
-
-AC_MSG_CHECKING(for pygtk defs)
-PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
-AC_SUBST(PYGTK_DEFSDIR)
-AC_MSG_RESULT($PYGTK_DEFSDIR)
-
-AC_MSG_CHECKING(for pygtk codegen)
-PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
-AC_SUBST(PYGTK_CODEGEN)
-AC_MSG_RESULT($PYGTK_CODEGEN)
-
#########################
# Check if build tests
#########################
@@ -239,8 +212,6 @@ src/Makefile
src/appindicator-0.1.pc
src/appindicator3-0.1.pc
bindings/Makefile
-bindings/python/Makefile
-bindings/python/appindicator.override
bindings/vala/Makefile
bindings/vala/examples/Makefile
tests/Makefile
Loading…
Cancel
Save