added gcc as BuildRequires

epel9
Christoph Junghans 7 years ago
parent 2008f034be
commit df55fe3481

@ -0,0 +1,25 @@
From b50ec6181248fa8905e4457474a3f6dde404ae8e Mon Sep 17 00:00:00 2001
From: Christoph Junghans <junghans@votca.org>
Date: Sat, 24 Feb 2018 15:44:50 -0700
Subject: [PATCH] cmake: only enable C (not C++)
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3303f72..cd81f00 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,7 @@ include(TestBigEndian)
include(CheckCSourceCompiles)
include(CheckSymbolExists)
include(cmake/macros.cmake)
-project(libaec)
+project(libaec C)
set(libaec_VERSION_MAJOR 1)
set(libaec_VERSION_MINOR 0)
set(libaec_VERSION_PATCH 2)
--
2.14.3

@ -5,7 +5,9 @@ Summary: Adaptive Entropy Coding library
License: BSD License: BSD
Url: https://gitlab.dkrz.de/k202009/libaec Url: https://gitlab.dkrz.de/k202009/libaec
Source: https://gitlab.dkrz.de/k202009/libaec/repository/archive.tar.gz?ref=v%{version}/%{name}-%{version}.tar.gz Source: https://gitlab.dkrz.de/k202009/libaec/repository/archive.tar.gz?ref=v%{version}/%{name}-%{version}.tar.gz
Patch0: 0001-cmake-only-enable-C-not-C.patch
BuildRequires: gcc
BuildRequires: %{?fedora:cmake >= 3.1}%{?rhel:cmake3 >= 3.1} BuildRequires: %{?fedora:cmake >= 3.1}%{?rhel:cmake3 >= 3.1}
%description %description
@ -33,6 +35,7 @@ Devel files for libaec (Adaptive Entropy Coding library).
%prep %prep
%setup -q -T -a 0 -c %setup -q -T -a 0 -c
mv %{name}-v%{version}-*/* . mv %{name}-v%{version}-*/* .
%patch0 -p1
%build %build
mkdir build mkdir build

Loading…
Cancel
Save