parent
2a16b49e40
commit
c1d624ff0e
@ -0,0 +1 @@
|
|||||||
|
lazarus-0.9.24-0.tar.gz
|
@ -0,0 +1,18 @@
|
|||||||
|
--- lazarus/install/lazarus.desktop 2007-09-11 19:38:17.000000000 +0200
|
||||||
|
+++ lazarus/install/lazarus.desktop.n 2008-02-01 11:28:17.000000000 +0100
|
||||||
|
@@ -5,13 +5,7 @@
|
||||||
|
Exec=startlazarus %f
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
-Icon=lazarus.png
|
||||||
|
-Categories=Application;IDE;Development;Programming;
|
||||||
|
+Icon=lazarus
|
||||||
|
+Categories=Development;IDE;GTK;GUIDesigner;
|
||||||
|
StartupWMClass=Lazarus
|
||||||
|
MimeType=text/x-pascal;text/lazarus-project-source;text/lazarus-project-information;text/lazarus-form;text/lazarus-resource;text/lazarus-package;text/lazarus-package-link;text/lazarus-code-inlay;
|
||||||
|
-Patterns=*.pas;*.pp;*.p;*.inc;*.lpi;*.lpk;*.lpr;*.lfm;*.lrs;*.lpl;*.dci
|
||||||
|
-[Property::X-KDE-NativeExtension]
|
||||||
|
-Type=QString
|
||||||
|
-Value=.pas
|
||||||
|
-X-Ubuntu-Gettext-Domain=desktop_kdelibs
|
||||||
|
-
|
@ -0,0 +1,33 @@
|
|||||||
|
Index: lazarus/Makefile.fpc
|
||||||
|
===================================================================
|
||||||
|
--- lazarus/Makefile.fpc (revision 10352)
|
||||||
|
+++ lazarus/Makefile.fpc (working copy)
|
||||||
|
@@ -21,7 +21,7 @@
|
||||||
|
|
||||||
|
[install]
|
||||||
|
fpcpackage=n
|
||||||
|
-basedir=share/lazarus
|
||||||
|
+basedir=lib/lazarus
|
||||||
|
|
||||||
|
[dist]
|
||||||
|
destdir=$(BASEDIR)/dist
|
||||||
|
@@ -29,7 +29,7 @@
|
||||||
|
[prerules]
|
||||||
|
RCPP?=$(strip $(firstword cpp$(SRCEXEEXT)))
|
||||||
|
#
|
||||||
|
-LAZARUS_INSTALL_DIR=$(INSTALL_PREFIX)/share/lazarus
|
||||||
|
+LAZARUS_INSTALL_DIR=$(INSTALL_PREFIX)/$(_LIB)/lazarus
|
||||||
|
INSTALL_MAN_DIR=$(INSTALL_PREFIX)/share/man
|
||||||
|
ifneq ($(findstring $(OS_TARGET),win32 win64),)
|
||||||
|
LAZARUS_INSTALL_DIR=C:\lazarus
|
||||||
|
@@ -104,8 +104,8 @@
|
||||||
|
ifeq ($(OS_TARGET),win32)
|
||||||
|
|
||||||
|
else
|
||||||
|
- $(MKDIR) $(INSTALL_PREFIX)/share
|
||||||
|
- $(MKDIR) $(INSTALL_PREFIX)/share/lazarus
|
||||||
|
+ $(MKDIR) $(INSTALL_PREFIX)/$(_LIB)
|
||||||
|
+ $(MKDIR) $(INSTALL_PREFIX)/$(_LIB)/lazarus
|
||||||
|
$(MKDIR) $(INSTALL_BINDIR)
|
||||||
|
$(MKDIR) $(INSTALL_MAN_DIR)
|
||||||
|
endif
|
@ -0,0 +1 @@
|
|||||||
|
lazarus-0_9_24-4_fc10:HEAD:lazarus-0.9.24-4.fc10.src.rpm:1213894282
|
@ -0,0 +1,137 @@
|
|||||||
|
Name: lazarus
|
||||||
|
Version: 0.9.24
|
||||||
|
Release: 4%{?dist}
|
||||||
|
Summary: Lazarus Component Library and IDE for Freepascal
|
||||||
|
|
||||||
|
Group: Development/Languages
|
||||||
|
# GNU Classpath style exception, see COPYING.modifiedLGPL
|
||||||
|
License: GPLv2+ and MPLv1.1 and LGPLv2+ with exceptions
|
||||||
|
URL: http://www.lazarus.freepascal.org/
|
||||||
|
Source0: http://download.sourceforge.net/%{name}/%{name}-%{version}-0.tar.gz
|
||||||
|
patch0: Makefile_patch.diff
|
||||||
|
patch1: Desktop_patch.diff
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
BuildRequires: fpc >= 2.2.0, binutils, gdk-pixbuf-devel, gtk+-devel, glibc-devel, desktop-file-utils, gtk2-devel, fpc-src >= 2.2.0
|
||||||
|
Requires: fpc-src >= 2.2.0, fpc >= 2.2.0, binutils, gdk-pixbuf-devel, gtk+-devel, glibc-devel, gdb
|
||||||
|
|
||||||
|
%description
|
||||||
|
Lazarus is a free and opensource RAD tool for freepascal using the lazarus
|
||||||
|
component library - LCL, which is also included in this package.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -c -q
|
||||||
|
%patch0 -p0
|
||||||
|
%patch1 -p0
|
||||||
|
|
||||||
|
%build
|
||||||
|
cd lazarus
|
||||||
|
# Remove the files for building debian-repositories
|
||||||
|
rm -rf debian
|
||||||
|
rm -rf tools/install/cross_unix/debian_crosswin32
|
||||||
|
rm tools/install/cross_unix/create_linux_cross_win32_deb.sh
|
||||||
|
rm tools/install/cross_unix/HowToCreate_fpc_crosswin32_deb.txt
|
||||||
|
export FPCDIR=/usr/share/fpcsrc
|
||||||
|
fpcmake -Tall
|
||||||
|
make all OPT='-gl'
|
||||||
|
# Add the ability to create gtk2-applications
|
||||||
|
make -C lcl/interfaces/gtk2/ OPT='-gl'
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
make -C lazarus install INSTALL_PREFIX=%{buildroot}%{_prefix} _LIB=%{_lib}
|
||||||
|
|
||||||
|
install -D -p -m 0644 lazarus/images/ide_icon48x48.png %{buildroot}%{_datadir}/pixmaps/lazarus.png
|
||||||
|
desktop-file-install \
|
||||||
|
--vendor fedora \
|
||||||
|
--dir %{buildroot}%{_datadir}/applications \
|
||||||
|
lazarus/install/%{name}.desktop
|
||||||
|
|
||||||
|
ln -sf ../%{_lib}/%{name}/lazarus %{buildroot}%{_bindir}/lazarus-ide
|
||||||
|
ln -sf ../%{_lib}/%{name}/startlazarus %{buildroot}%{_bindir}/startlazarus
|
||||||
|
ln -sf ../%{_lib}/%{name}/lazbuild %{buildroot}%{_bindir}/lazbuild
|
||||||
|
|
||||||
|
chmod 755 %{buildroot}%{_libdir}/lazarus/components/lazreport/doc/cvs2cl.pl
|
||||||
|
chmod 755 %{buildroot}%{_libdir}/%{name}/components/lazreport/tools/localize.sh
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_libdir}/%{name}
|
||||||
|
%{_bindir}/%{name}-ide
|
||||||
|
%{_bindir}/startlazarus
|
||||||
|
%{_bindir}/lazbuild
|
||||||
|
%{_datadir}/pixmaps/lazarus.png
|
||||||
|
%{_datadir}/applications/fedora-%{name}.desktop
|
||||||
|
%doc lazarus/COPYING*
|
||||||
|
%doc lazarus/README.txt
|
||||||
|
%{_mandir}/*/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Jun 18 2008 Joost van der Sluis <joost@cnoc.nl> 0.9.24-4
|
||||||
|
- removed the trailing slash from the FPCDIR export in the build section
|
||||||
|
|
||||||
|
* Tue Apr 24 2008 Joost van der Sluis <joost@cnoc.nl> 0.9.24-3
|
||||||
|
- Remove executable-bit in install-section, instead of the files section
|
||||||
|
- Enabled debug-package on x86_64
|
||||||
|
|
||||||
|
* Fri Feb 01 2008 Joost van der Sluis <joost@cnoc.nl> 0.9.24-2
|
||||||
|
- Changed license-tag according to the official license tags of Fedora
|
||||||
|
- Removed some more Debian-specific files
|
||||||
|
- Made two scripts executable
|
||||||
|
- Improved fedora-lazarus.desktop
|
||||||
|
|
||||||
|
* Mon Nov 26 2007 Joost van der Sluis <joost@cnoc.nl> 0.9.24-1
|
||||||
|
- Removed files specific for debian
|
||||||
|
- Updated to Lazarus v 0.9.24
|
||||||
|
- Changed desktop-file categories
|
||||||
|
- Disabled the debug-package for x86_64 again, see bug 337051
|
||||||
|
- If the debuginfo-packages is disabled, strip the executables manually
|
||||||
|
- Require fpc version 2.2.0
|
||||||
|
- Added -q to setup-macro
|
||||||
|
- Added OPT='-gl' option in build-section, to make sure that the debuginfo is generated by the compiler
|
||||||
|
- Removed explicit creation of {buildroot}{_mandir}/man1 and {buildroot}{_datadir}/applications
|
||||||
|
- Lazarus executable is renamed to lazarus-ide (changed upstream)
|
||||||
|
|
||||||
|
* Thu Jan 4 2007 Joost van der Sluis <joost@cnoc.nl> 0.9.20-2
|
||||||
|
- Added fpc-src as build-dependency to fix problem with fpcmake
|
||||||
|
|
||||||
|
* Tue Jan 2 2007 Joost van der Sluis <joost@cnoc.nl> 0.9.20-1
|
||||||
|
- Version 0.9.20
|
||||||
|
|
||||||
|
* Wed Oct 4 2006 Joost van der Sluis <joost@cnoc.nl> 0.9.18-2
|
||||||
|
- Use the makefile for installing
|
||||||
|
|
||||||
|
* Wed Sep 20 2006 Joost van der Sluis <joost@cnoc.nl> 0.9.18-1
|
||||||
|
- Updated to version 0.9.18.
|
||||||
|
- Removed obsolete copying of documentation
|
||||||
|
- Removed double requirements
|
||||||
|
- Removed part to remove debuginfo package
|
||||||
|
|
||||||
|
* Thu Jun 1 2006 Joost van der Sluis <joost@cnoc.nl> 0.9.16-1
|
||||||
|
- Updated to version 0.9.16.
|
||||||
|
|
||||||
|
* Thu May 25 2006 Joost van der Sluis <joost@cnoc.nl> 0.9.14-5
|
||||||
|
- Added /usr/bin/startlazarus for packaging
|
||||||
|
- Removed strip in build-section
|
||||||
|
- added gtk2-devel buildrequirement
|
||||||
|
|
||||||
|
* Tue May 23 2006 Joost van der Sluis <joost@cnoc.nl> 0.9.14-4
|
||||||
|
- Only build the basic IDE, to remove dependencies on things which are buggy in fpc 2.0.2
|
||||||
|
|
||||||
|
* Tue May 4 2006 Joost van der Sluis <joost@cnoc.nl> 0.9.14-3
|
||||||
|
- Added the ability to create gtk2-applications
|
||||||
|
|
||||||
|
* Tue May 4 2006 Joost van der Sluis <joost@cnoc.nl> 0.9.14-2
|
||||||
|
- Updated to version 0.9.14-1.
|
||||||
|
- Changed the Source0 download url from prdownloads to
|
||||||
|
downloads.sourceforge.net
|
||||||
|
|
||||||
|
* Tue Apr 10 2006 Joost van der Sluis <joost@cnoc.nl> 0.9.14-1
|
||||||
|
- Updated to version 0.9.14.
|
||||||
|
|
||||||
|
* Tue Mar 28 2006 Joost van der Sluis <joost@cnoc.nl> 0.9.12-1
|
||||||
|
- Initial build.
|
||||||
|
|
Loading…
Reference in new issue