parent
e3d9ea63c9
commit
c0fef87fbc
@ -1,17 +0,0 @@
|
|||||||
--- lazarus/install/lazarus.desktop 2007-11-26 15:34:42.000000000 +0100
|
|
||||||
+++ lazarus/install/lazarus.desktop.n 2008-10-18 11:52:33.000000000 +0200
|
|
||||||
@@ -4,13 +4,9 @@
|
|
||||||
Exec=startlazarus %f
|
|
||||||
Terminal=false
|
|
||||||
Type=Application
|
|
||||||
-Icon=lazarus.png
|
|
||||||
-Categories=Application;IDE;Development;GTK;GUIDesigner;
|
|
||||||
+Icon=lazarus
|
|
||||||
+Categories=IDE;Development;GTK;GUIDesigner;
|
|
||||||
StartupWMClass=Lazarus
|
|
||||||
MimeType=text/x-pascal;text/lazarus-project-source;text/lazarus-project-information;text/lazarus-form;text/lazarus-resource;text/lazarus-package;text/lazarus-package-link;text/lazarus-code-inlay;
|
|
||||||
Keywords=editor;Pascal;IDE;FreePascal;fpc;Design;Designer;
|
|
||||||
-[Property::X-KDE-NativeExtension]
|
|
||||||
-Type=QString
|
|
||||||
-Value=.pas
|
|
||||||
-X-Ubuntu-Gettext-Domain=desktop_kdelibs
|
|
@ -1,51 +0,0 @@
|
|||||||
diff --git lazarus/components/Makefile.fpc lazarus/components/Makefile.fpc
|
|
||||||
index f7578d9..e88fda9 100644
|
|
||||||
--- lazarus/components/Makefile.fpc
|
|
||||||
+++ lazarus/components/Makefile.fpc
|
|
||||||
@@ -70,8 +70,10 @@ bigide:
|
|
||||||
$(MAKE) -C externhelp
|
|
||||||
$(MAKE) -C tdbf
|
|
||||||
$(MAKE) -C sqldb
|
|
||||||
+ifneq ($(CPU_TARGET),powerpc64)
|
|
||||||
$(MAKE) -C PascalScript/Source
|
|
||||||
$(MAKE) -C macroscript
|
|
||||||
+endif
|
|
||||||
|
|
||||||
all: base bigide
|
|
||||||
|
|
||||||
@@ -108,8 +110,10 @@ clean:
|
|
||||||
$(MAKE) -C externhelp clean
|
|
||||||
$(MAKE) -C tdbf clean
|
|
||||||
$(MAKE) -C sqldb clean
|
|
||||||
+ifneq ($(CPU_TARGET),powerpc64)
|
|
||||||
$(MAKE) -C PascalScript/Source clean
|
|
||||||
$(MAKE) -C macroscript clean
|
|
||||||
+endif
|
|
||||||
|
|
||||||
cleanall: clean
|
|
||||||
|
|
||||||
@@ -146,6 +150,8 @@ distclean:
|
|
||||||
$(MAKE) -C externhelp distclean
|
|
||||||
$(MAKE) -C tdbf distclean
|
|
||||||
$(MAKE) -C sqldb distclean
|
|
||||||
+ifneq ($(CPU_TARGET),powerpc64)
|
|
||||||
$(MAKE) -C PascalScript/Source distclean
|
|
||||||
$(MAKE) -C macroscript distclean
|
|
||||||
+endif
|
|
||||||
|
|
||||||
diff --git lazarus/ide/lazarus.pp lazarus/ide/lazarus.pp
|
|
||||||
index b6ea8c7..54ddb1a 100644
|
|
||||||
--- lazarus/ide/lazarus.pp
|
|
||||||
+++ lazarus/ide/lazarus.pp
|
|
||||||
@@ -73,7 +73,10 @@ uses
|
|
||||||
TurboPowerIPro, TurboPowerIProDsgn,
|
|
||||||
jcfidelazarus, chmhelppkg,
|
|
||||||
FPCUnitTestRunner, FPCUnitIDE, ProjTemplates, TAChartLazarusPkg,
|
|
||||||
- TodoListLaz, DateTimeCtrls, SQLDBLaz, DBFLaz, pascalscript, EditorMacroScript,
|
|
||||||
+ TodoListLaz, DateTimeCtrls, SQLDBLaz, DBFLaz,
|
|
||||||
+ {$IFNDEF CPUPOWERPC64}
|
|
||||||
+ pascalscript, EditorMacroScript,
|
|
||||||
+ {$ENDIF}
|
|
||||||
{$ENDIF}
|
|
||||||
MainBase;
|
|
||||||
|
|
@ -1 +1 @@
|
|||||||
SHA512 (lazarus-1.8.4.tar.gz) = 82cdc3c32dddf8e67c0bed9292a9a924227bab50f22ca479f5e98ecccbf60dd66c7f886ecb8e2979d9d8fccc3d25462ee8c55fcab085aa4194b4704660e0b95d
|
SHA512 (lazarus-2.0.0.tar.gz) = bd590a345aac831f00813e0ce306549ad66b78e0c60678f181b6b1dcab2e39a489835a0b05f9fa9040ab97fe685baf23384468b67cc6c3956e8e0b8753764b9b
|
||||||
|
Loading…
Reference in new issue