parent
3255e2c744
commit
71fe63c874
@ -0,0 +1,32 @@
|
||||
--- lazarus-2.2.0--orig/lazarus/components/chmhelp/lhelp/Makefile.fpc 2022-01-02 11:01:23.000000000 +0100
|
||||
+++ lazarus-2.2.0--patched/lazarus/components/chmhelp/lhelp/Makefile.fpc 2022-01-16 14:38:13.725920651 +0100
|
||||
@@ -14,9 +14,9 @@
|
||||
libc=y
|
||||
packages=rtl
|
||||
|
||||
[compiler]
|
||||
-options=-gs -gl -Sghi -O3 -dlcl$(LCL_PLATFORM) $(DBG_OPTIONS)
|
||||
+options=-gw -gl -Sghi -O3 -dlcl$(LCL_PLATFORM) $(DBG_OPTIONS)
|
||||
unittargetdir=lib/$(CPU_TARGET)-$(OS_TARGET)
|
||||
unitdir=. $(LAZDIR)/components/lazutils/lib/$(CPU_TARGET)-$(OS_TARGET) \
|
||||
$(LAZDIR)/packager/units/$(CPU_TARGET)-$(OS_TARGET) \
|
||||
$(LAZDIR)/lcl/units/$(CPU_TARGET)-$(OS_TARGET) \
|
||||
--- lazarus-2.2.0--orig/lazarus/lcl/interfaces/nogui/Makefile.fpc 2022-01-02 11:01:25.000000000 +0100
|
||||
+++ lazarus-2.2.0--patched/lazarus/lcl/interfaces/nogui/Makefile.fpc 2022-01-16 15:00:53.421077087 +0100
|
||||
@@ -7,15 +7,12 @@
|
||||
[target]
|
||||
units=lcl.pas
|
||||
|
||||
[prerules]
|
||||
-DBG_OPTIONS=
|
||||
-ifeq ($(OS_TARGET),darwin)
|
||||
DBG_OPTIONS=-gw
|
||||
-endif
|
||||
|
||||
[compiler]
|
||||
-options=-gl -dnogui $(DBG_OPTIONS)
|
||||
+options=-gw -gl -dnogui $(DBG_OPTIONS)
|
||||
unitdir=../../units/$(CPU_TARGET)-$(OS_TARGET) \
|
||||
../../../packager/units/$(CPU_TARGET)-$(OS_TARGET) \
|
||||
../../../components/lazutils/lib/$(CPU_TARGET)-$(OS_TARGET) \
|
||||
.. .
|
@ -1,36 +0,0 @@
|
||||
Only in lazarus-2.0.6/lazarus/components/chmhelp/lhelp/lhelp.app/Contents/MacOS: lhelp
|
||||
diff -U4 -r lazarus-2.0.6/lazarus/components/Makefile.fpc lazarus-2.0.6--patched/lazarus/components/Makefile.fpc
|
||||
--- lazarus-2.0.6/lazarus/components/Makefile.fpc 2018-11-11 22:09:04.000000000 +0100
|
||||
+++ lazarus-2.0.6--patched/lazarus/components/Makefile.fpc 2020-01-29 12:37:09.583868745 +0100
|
||||
@@ -71,10 +71,12 @@
|
||||
$(MAKE) -C instantfpc
|
||||
$(MAKE) -C externhelp
|
||||
$(MAKE) -C tdbf
|
||||
$(MAKE) -C sqldb
|
||||
+ifneq ($(CPU_TARGET),powerpc64)
|
||||
$(MAKE) -C PascalScript/Source
|
||||
$(MAKE) -C macroscript
|
||||
+endif
|
||||
$(MAKE) -C lclextensions
|
||||
$(MAKE) -C virtualtreeview
|
||||
$(MAKE) -C onlinepackagemanager
|
||||
|
||||
diff -U4 -r lazarus-2.0.6/lazarus/ide/lazarus.pp lazarus-2.0.6--patched/lazarus/ide/lazarus.pp
|
||||
--- lazarus-2.0.6/lazarus/ide/lazarus.pp 2018-11-11 23:48:56.000000000 +0100
|
||||
+++ lazarus-2.0.6--patched/lazarus/ide/lazarus.pp 2020-01-29 12:35:44.192723725 +0100
|
||||
@@ -72,10 +72,13 @@
|
||||
LeakView, MemDSLaz, SDFLaz, InstantFPCLaz, ExternHelp,
|
||||
TurboPowerIPro, TurboPowerIProDsgn,
|
||||
jcfidelazarus, chmhelppkg,
|
||||
FPCUnitTestRunner, FPCUnitIDE, ProjTemplates, TAChartLazarusPkg,
|
||||
- TodoListLaz, DateTimeCtrls, SQLDBLaz, DBFLaz, pascalscript,
|
||||
- EditorMacroScript, RegisterVirtualTreeView, OnlinePackageManager,
|
||||
+ TodoListLaz, DateTimeCtrls, SQLDBLaz, DBFLaz,
|
||||
+ {$IFNDEF CPUPOWERPC64}
|
||||
+ pascalscript, EditorMacroScript,
|
||||
+ {$ENDIF}
|
||||
+ RegisterVirtualTreeView, OnlinePackageManager,
|
||||
LazDebuggerFpLldb,
|
||||
{$ENDIF}
|
||||
MainBase;
|
||||
|
Loading…
Reference in new issue