Update to v2.2.0

f39
Artur Frenszek-Iwicki 3 years ago
parent 3255e2c744
commit 71fe63c874

@ -1,5 +1,5 @@
--- lazarus-2.0.12--orig/lazarus/Makefile.fpc 2020-07-24 18:14:39.000000000 +0200 --- lazarus-2.2.0--orig/lazarus/Makefile.fpc 2022-01-02 11:01:23.000000000 +0100
+++ lazarus-2.0.12--patched/lazarus/Makefile.fpc 2021-04-30 16:51:44.926870797 +0200 +++ lazarus-2.2.0--patched/lazarus/Makefile.fpc 2022-01-06 12:38:15.415350306 +0100
@@ -19,18 +19,18 @@ @@ -19,18 +19,18 @@
files=$(wildcard *$(OEXT)) $(wildcard *$(PPUEXT)) $(wildcard *$(RSTEXT)) $(wildcard *.lfm) files=$(wildcard *$(OEXT)) $(wildcard *$(PPUEXT)) $(wildcard *$(RSTEXT)) $(wildcard *.lfm)
@ -21,7 +21,7 @@
ifneq ($(findstring $(OS_TARGET),win32 win64),) ifneq ($(findstring $(OS_TARGET),win32 win64),)
LAZARUS_INSTALL_DIR=C:\lazarus LAZARUS_INSTALL_DIR=C:\lazarus
endif endif
@@ -270,10 +270,11 @@ @@ -286,10 +286,11 @@
installbase: installbase:
ifneq ($(findstring $(OS_TARGET),win32 win64),) ifneq ($(findstring $(OS_TARGET),win32 win64),)

@ -0,0 +1,32 @@
--- lazarus-2.2.0--orig/lazarus/components/chmhelp/lhelp/Makefile.fpc 2022-01-02 11:01:23.000000000 +0100
+++ lazarus-2.2.0--patched/lazarus/components/chmhelp/lhelp/Makefile.fpc 2022-01-16 14:38:13.725920651 +0100
@@ -14,9 +14,9 @@
libc=y
packages=rtl
[compiler]
-options=-gs -gl -Sghi -O3 -dlcl$(LCL_PLATFORM) $(DBG_OPTIONS)
+options=-gw -gl -Sghi -O3 -dlcl$(LCL_PLATFORM) $(DBG_OPTIONS)
unittargetdir=lib/$(CPU_TARGET)-$(OS_TARGET)
unitdir=. $(LAZDIR)/components/lazutils/lib/$(CPU_TARGET)-$(OS_TARGET) \
$(LAZDIR)/packager/units/$(CPU_TARGET)-$(OS_TARGET) \
$(LAZDIR)/lcl/units/$(CPU_TARGET)-$(OS_TARGET) \
--- lazarus-2.2.0--orig/lazarus/lcl/interfaces/nogui/Makefile.fpc 2022-01-02 11:01:25.000000000 +0100
+++ lazarus-2.2.0--patched/lazarus/lcl/interfaces/nogui/Makefile.fpc 2022-01-16 15:00:53.421077087 +0100
@@ -7,15 +7,12 @@
[target]
units=lcl.pas
[prerules]
-DBG_OPTIONS=
-ifeq ($(OS_TARGET),darwin)
DBG_OPTIONS=-gw
-endif
[compiler]
-options=-gl -dnogui $(DBG_OPTIONS)
+options=-gw -gl -dnogui $(DBG_OPTIONS)
unitdir=../../units/$(CPU_TARGET)-$(OS_TARGET) \
../../../packager/units/$(CPU_TARGET)-$(OS_TARGET) \
../../../components/lazutils/lib/$(CPU_TARGET)-$(OS_TARGET) \
.. .

@ -1,36 +0,0 @@
Only in lazarus-2.0.6/lazarus/components/chmhelp/lhelp/lhelp.app/Contents/MacOS: lhelp
diff -U4 -r lazarus-2.0.6/lazarus/components/Makefile.fpc lazarus-2.0.6--patched/lazarus/components/Makefile.fpc
--- lazarus-2.0.6/lazarus/components/Makefile.fpc 2018-11-11 22:09:04.000000000 +0100
+++ lazarus-2.0.6--patched/lazarus/components/Makefile.fpc 2020-01-29 12:37:09.583868745 +0100
@@ -71,10 +71,12 @@
$(MAKE) -C instantfpc
$(MAKE) -C externhelp
$(MAKE) -C tdbf
$(MAKE) -C sqldb
+ifneq ($(CPU_TARGET),powerpc64)
$(MAKE) -C PascalScript/Source
$(MAKE) -C macroscript
+endif
$(MAKE) -C lclextensions
$(MAKE) -C virtualtreeview
$(MAKE) -C onlinepackagemanager
diff -U4 -r lazarus-2.0.6/lazarus/ide/lazarus.pp lazarus-2.0.6--patched/lazarus/ide/lazarus.pp
--- lazarus-2.0.6/lazarus/ide/lazarus.pp 2018-11-11 23:48:56.000000000 +0100
+++ lazarus-2.0.6--patched/lazarus/ide/lazarus.pp 2020-01-29 12:35:44.192723725 +0100
@@ -72,10 +72,13 @@
LeakView, MemDSLaz, SDFLaz, InstantFPCLaz, ExternHelp,
TurboPowerIPro, TurboPowerIProDsgn,
jcfidelazarus, chmhelppkg,
FPCUnitTestRunner, FPCUnitIDE, ProjTemplates, TAChartLazarusPkg,
- TodoListLaz, DateTimeCtrls, SQLDBLaz, DBFLaz, pascalscript,
- EditorMacroScript, RegisterVirtualTreeView, OnlinePackageManager,
+ TodoListLaz, DateTimeCtrls, SQLDBLaz, DBFLaz,
+ {$IFNDEF CPUPOWERPC64}
+ pascalscript, EditorMacroScript,
+ {$ENDIF}
+ RegisterVirtualTreeView, OnlinePackageManager,
LazDebuggerFpLldb,
{$ENDIF}
MainBase;

@ -1,9 +1,9 @@
Name: lazarus Name: lazarus
Summary: Lazarus Component Library and IDE for Freepascal Summary: Lazarus Component Library and IDE for Freepascal
Version: 2.0.12 Version: 2.2.0
%global baserelease 4 %global baserelease 1
Release: %{baserelease}%{?dist} Release: %{baserelease}%{?dist}
# The qt5pas version is taken from lcl/interfaces/qt5/cbindings/Qt5Pas.pro # The qt5pas version is taken from lcl/interfaces/qt5/cbindings/Qt5Pas.pro
@ -13,12 +13,14 @@ Release: %{baserelease}%{?dist}
# GNU Classpath style exception, see COPYING.modifiedLGPL # GNU Classpath style exception, see COPYING.modifiedLGPL
License: GPLv2+ and MPLv1.1 and LGPLv2+ with exceptions License: GPLv2+ and MPLv1.1 and LGPLv2+ with exceptions
URL: http://www.lazarus-ide.org/ URL: http://www.lazarus-ide.org/
Source0: https://downloads.sourceforge.net/project/%{name}/Lazarus%20Zip%20_%20GZip/Lazarus%20%{version}/%{name}-%{version}.tar.gz Source0: https://downloads.sourceforge.net/project/%{name}/Lazarus%20Zip%20_%20GZip/Lazarus%20%{version}/%{name}-%{version}-0.tar.gz
Source100: lazarus.appdata.xml Source100: lazarus.appdata.xml
Patch0: Makefile_patch.diff # Lazarus wants to put arch-specific stuff in /usr/share - make it go in /usr/lib istead
Patch1: lazarus-2.0.6--disable-PascalScript-on-ppc64le.patch Patch0: 0000-Makefile_patch.diff
# Some config files explicitly use STABS debuginfo - change to DWARF
Patch1: 0001-DWARF-debuginfo-everywhere.patch
BuildRequires: binutils BuildRequires: binutils
BuildRequires: desktop-file-utils BuildRequires: desktop-file-utils
@ -150,7 +152,7 @@ appstream-util validate-relax --nonet %{buildroot}%{_metainfodir}/%{name}.appdat
%{_datadir}/icons/hicolor/48x48/mimetypes/* %{_datadir}/icons/hicolor/48x48/mimetypes/*
%{_metainfodir}/%{name}.appdata.xml %{_metainfodir}/%{name}.appdata.xml
%license lazarus/COPYING* %license lazarus/COPYING*
%doc lazarus/README.txt %doc lazarus/README.md
%dir %{_sysconfdir}/lazarus %dir %{_sysconfdir}/lazarus
%config(noreplace) %{_sysconfdir}/lazarus/environmentoptions.xml %config(noreplace) %{_sysconfdir}/lazarus/environmentoptions.xml
%{_mandir}/*/* %{_mandir}/*/*
@ -165,6 +167,11 @@ appstream-util validate-relax --nonet %{buildroot}%{_metainfodir}/%{name}.appdat
%changelog %changelog
* Mon Feb 07 2022 Artur Frenszek-Iwicki <fedora@svgames.pl> - 2.2.0-1
- Update to v2.2.0
- Drop Patch1 - disable PascalScript on ppc64le (compiles successfully now)
- Add Patch1 - use DWARF debuginfo instead of stabs
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.12-4 * Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.12-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

Loading…
Cancel
Save