Update to v2.2.6

f39
Artur Frenszek-Iwicki 2 years ago
parent ea27e099ec
commit 68b1c5436c

1
.gitignore vendored

@ -25,3 +25,4 @@ lazarus-0.9.28-src.tar.bz2
/lazarus-2.2.0-0.tar.gz /lazarus-2.2.0-0.tar.gz
/lazarus-2.2.2-0.tar.gz /lazarus-2.2.2-0.tar.gz
/lazarus-2.2.4-0.tar.gz /lazarus-2.2.4-0.tar.gz
/lazarus-2.2.6-0.tar.gz

@ -1,5 +1,5 @@
--- lazarus-2.2.0--orig/lazarus/Makefile.fpc 2022-01-02 11:01:23.000000000 +0100 --- lazarus-2.2.6--orig/lazarus/Makefile.fpc 2023-03-04 14:24:23.000000000 +0100
+++ lazarus-2.2.0--patched/lazarus/Makefile.fpc 2022-01-06 12:38:15.415350306 +0100 +++ lazarus-2.2.6--patched/lazarus/Makefile.fpc 2023-03-07 19:25:14.938976319 +0100
@@ -19,18 +19,18 @@ @@ -19,18 +19,18 @@
files=$(wildcard *$(OEXT)) $(wildcard *$(PPUEXT)) $(wildcard *$(RSTEXT)) $(wildcard *.lfm) files=$(wildcard *$(OEXT)) $(wildcard *$(PPUEXT)) $(wildcard *$(RSTEXT)) $(wildcard *.lfm)

@ -1,32 +0,0 @@
--- lazarus-2.2.0--orig/lazarus/components/chmhelp/lhelp/Makefile.fpc 2022-01-02 11:01:23.000000000 +0100
+++ lazarus-2.2.0--patched/lazarus/components/chmhelp/lhelp/Makefile.fpc 2022-01-16 14:38:13.725920651 +0100
@@ -14,9 +14,9 @@
libc=y
packages=rtl
[compiler]
-options=-gs -gl -Sghi -O3 -dlcl$(LCL_PLATFORM) $(DBG_OPTIONS)
+options=-gw -gl -Sghi -O3 -dlcl$(LCL_PLATFORM) $(DBG_OPTIONS)
unittargetdir=lib/$(CPU_TARGET)-$(OS_TARGET)
unitdir=. $(LAZDIR)/components/lazutils/lib/$(CPU_TARGET)-$(OS_TARGET) \
$(LAZDIR)/packager/units/$(CPU_TARGET)-$(OS_TARGET) \
$(LAZDIR)/lcl/units/$(CPU_TARGET)-$(OS_TARGET) \
--- lazarus-2.2.0--orig/lazarus/lcl/interfaces/nogui/Makefile.fpc 2022-01-02 11:01:25.000000000 +0100
+++ lazarus-2.2.0--patched/lazarus/lcl/interfaces/nogui/Makefile.fpc 2022-01-16 15:00:53.421077087 +0100
@@ -7,15 +7,12 @@
[target]
units=lcl.pas
[prerules]
-DBG_OPTIONS=
-ifeq ($(OS_TARGET),darwin)
DBG_OPTIONS=-gw
-endif
[compiler]
-options=-gl -dnogui $(DBG_OPTIONS)
+options=-gw -gl -dnogui $(DBG_OPTIONS)
unitdir=../../units/$(CPU_TARGET)-$(OS_TARGET) \
../../../packager/units/$(CPU_TARGET)-$(OS_TARGET) \
../../../components/lazutils/lib/$(CPU_TARGET)-$(OS_TARGET) \
.. .

@ -0,0 +1,17 @@
--- lazarus-2.2.4--orig/lazarus/lcl/interfaces/gtk3/gtk3boxes.pas 2022-09-25 12:37:18.000000000 +0200
+++ lazarus-2.2.4--patched/lazarus/lcl/interfaces/gtk3/gtk3boxes.pas 2022-12-21 18:46:07.163316917 +0100
@@ -1,11 +1,13 @@
unit gtk3boxes;
+{$MODE OBJFPC} {$LONGSTRINGS ON}
+
interface
uses
// LazUtils
- UITypes,
+ System.UITypes,
// LCL
LCLType, LCLStrConsts,LCLProc, InterfaceBase,
LazGtk3, LazGLib2, LazGObject2, LazGdk3, gtk3objects;

@ -1,9 +1,9 @@
Name: lazarus Name: lazarus
Summary: Lazarus Component Library and IDE for Freepascal Summary: Lazarus Component Library and IDE for Freepascal
Version: 2.2.4 Version: 2.2.6
%global baserelease 2 %global baserelease 1
Release: %{baserelease}%{?dist} Release: %{baserelease}%{?dist}
# The qt5pas version is taken from lcl/interfaces/qt5/cbindings/Qt5Pas.pro # The qt5pas version is taken from lcl/interfaces/qt5/cbindings/Qt5Pas.pro
@ -11,7 +11,7 @@ Release: %{baserelease}%{?dist}
%global qt5pas_release %(relstr="%{version}.%{baserelease}"; relstr=(${relstr//./ }); ((relno=${relstr[0]}*1000000 + ${relstr[1]}*10000 + ${relstr[2]}*100 + ${relstr[3]})); echo "${relno}%{?dist}";) %global qt5pas_release %(relstr="%{version}.%{baserelease}"; relstr=(${relstr//./ }); ((relno=${relstr[0]}*1000000 + ${relstr[1]}*10000 + ${relstr[2]}*100 + ${relstr[3]})); echo "${relno}%{?dist}";)
# GNU Classpath style exception, see COPYING.modifiedLGPL # GNU Classpath style exception, see COPYING.modifiedLGPL
License: GPLv2+ and MPLv1.1 and LGPLv2+ with exceptions License: GPL-2.0-or-later AND LGPL-2.0 WITH Classpath-exception-2.0 AND MPL-1.1
URL: http://www.lazarus-ide.org/ URL: http://www.lazarus-ide.org/
Source0: https://downloads.sourceforge.net/project/%{name}/Lazarus%20Zip%20_%20GZip/Lazarus%20%{version}/%{name}-%{version}-0.tar.gz Source0: https://downloads.sourceforge.net/project/%{name}/Lazarus%20Zip%20_%20GZip/Lazarus%20%{version}/%{name}-%{version}-0.tar.gz
@ -19,8 +19,9 @@ Source100: lazarus.appdata.xml
# Lazarus wants to put arch-specific stuff in /usr/share - make it go in /usr/lib istead # Lazarus wants to put arch-specific stuff in /usr/share - make it go in /usr/lib istead
Patch0: 0000-Makefile_patch.diff Patch0: 0000-Makefile_patch.diff
# Some config files explicitly use STABS debuginfo - change to DWARF
Patch1: 0001-DWARF-debuginfo-everywhere.patch # Fix build errors for GTK3 widgetset
Patch2: 0002-fix-GTK3-build-error.patch
BuildRequires: binutils BuildRequires: binutils
BuildRequires: desktop-file-utils BuildRequires: desktop-file-utils
@ -76,7 +77,7 @@ developing applications that use qt5pas.
%prep %prep
%setup -c -q %setup -c -q
%patch0 -p1 %patch0 -p1
%patch1 -p1 %patch2 -p1
%build %build
@ -140,6 +141,8 @@ appstream-util validate-relax --nonet %{buildroot}%{_metainfodir}/%{name}.appdat
%files %files
%doc lazarus/README.md
%license lazarus/COPYING*
%{_libdir}/%{name} %{_libdir}/%{name}
%{_bindir}/%{name}-ide %{_bindir}/%{name}-ide
%{_bindir}/startlazarus %{_bindir}/startlazarus
@ -152,8 +155,6 @@ appstream-util validate-relax --nonet %{buildroot}%{_metainfodir}/%{name}.appdat
%{_datadir}/mime/packages/lazarus.xml %{_datadir}/mime/packages/lazarus.xml
%{_datadir}/icons/hicolor/48x48/mimetypes/* %{_datadir}/icons/hicolor/48x48/mimetypes/*
%{_metainfodir}/%{name}.appdata.xml %{_metainfodir}/%{name}.appdata.xml
%license lazarus/COPYING*
%doc lazarus/README.md
%dir %{_sysconfdir}/lazarus %dir %{_sysconfdir}/lazarus
%config(noreplace) %{_sysconfdir}/lazarus/environmentoptions.xml %config(noreplace) %{_sysconfdir}/lazarus/environmentoptions.xml
%{_mandir}/*/* %{_mandir}/*/*
@ -168,6 +169,12 @@ appstream-util validate-relax --nonet %{buildroot}%{_metainfodir}/%{name}.appdat
%changelog %changelog
* Wed Mar 08 2023 Artur Frenszek-Iwicki <fedora@svgames.pl> - 2.2.6-1
- Update to v2.2.6
- Add a patch to fix build errors when using the GTK3 widgetset
- Convert License tag to SPDX
- Drop Patch1 (fix components explicitly requesting STABS debuginfo - fixed upstream)
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.4-2 * Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

@ -1 +1 @@
SHA512 (lazarus-2.2.4-0.tar.gz) = 1a2fbc8451f1954df1d0071c586662ebc3cd0e9a7db5d910e0af86a3095252a5796d4c7abcf3861ad723af26974ac416c5bf919cd77ad5f406295ad7cdf47eb1 SHA512 (lazarus-2.2.6-0.tar.gz) = da51cd07febe02987e5dbc32363baacb7fdeb54957d25a235cba4b241caaa09a8e614fec5cbb0aa263477e65c0730a89e3e7bc7285850f9206916ad0094b7bc7

Loading…
Cancel
Save