commit
0f476f5065
@ -0,0 +1,2 @@
|
||||
SOURCES/kpatch-dnf-v0.4.tar.gz
|
||||
SOURCES/v0.9.7.tar.gz
|
@ -0,0 +1,2 @@
|
||||
fa86620559069e8253b5172849797a6d03b509be SOURCES/kpatch-dnf-v0.4.tar.gz
|
||||
da88fa82b005bbafc1719c59bd00847ce2a22a60 SOURCES/v0.9.7.tar.gz
|
@ -0,0 +1,46 @@
|
||||
From f056d60fb309896a52882fd3fc10fb5305f5a47e Mon Sep 17 00:00:00 2001
|
||||
From: Joe Lawrence <joe.lawrence@redhat.com>
|
||||
Date: Thu, 21 Jun 2018 15:40:20 -0400
|
||||
Subject: [PATCH] contrib: disable upstart kpatch.conf install
|
||||
|
||||
Do not install the upstart configuration file to avoid this rhpkg
|
||||
build complaint:
|
||||
|
||||
Checking for unpackaged file(s): /usr/lib/rpm/check-files /builddir/build/BUILDROOT/kpatch-0.6.1-1.el7.noarch
|
||||
error: Installed (but unpackaged) file(s) found:
|
||||
/etc/init/kpatch.conf
|
||||
Installed (but unpackaged) file(s) found:
|
||||
/etc/init/kpatch.conf
|
||||
|
||||
We'll need to think of a better way to do this upstream, but for now,
|
||||
just skip the unneeded file on RHEL.
|
||||
|
||||
Signed-off-by: Joe Lawrence <joe.lawrence@redhat.com>
|
||||
---
|
||||
contrib/Makefile | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/contrib/Makefile b/contrib/Makefile
|
||||
index 0b0eeeb23a56..e873f27d6eae 100644
|
||||
--- a/contrib/Makefile
|
||||
+++ b/contrib/Makefile
|
||||
@@ -6,12 +6,12 @@ install: all
|
||||
$(INSTALL) -d $(SYSTEMDDIR)
|
||||
$(INSTALL) -m 0644 kpatch.service $(SYSTEMDDIR)
|
||||
sed -i 's~PREFIX~$(PREFIX)~' $(SYSTEMDDIR)/kpatch.service
|
||||
- $(INSTALL) -d $(UPSTARTDIR)
|
||||
- $(INSTALL) -m 0644 kpatch.conf $(UPSTARTDIR)
|
||||
- sed -i 's~PREFIX~$(PREFIX)~' $(UPSTARTDIR)/kpatch.conf
|
||||
+# $(INSTALL) -d $(UPSTARTDIR)
|
||||
+# $(INSTALL) -m 0644 kpatch.conf $(UPSTARTDIR)
|
||||
+# sed -i 's~PREFIX~$(PREFIX)~' $(UPSTARTDIR)/kpatch.conf
|
||||
|
||||
uninstall:
|
||||
$(RM) $(SYSTEMDDIR)/kpatch.service
|
||||
- $(RM) $(UPSTARTDIR)/kpatch.conf
|
||||
+# $(RM) $(UPSTARTDIR)/kpatch.conf
|
||||
|
||||
clean:
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -0,0 +1,78 @@
|
||||
kpatch: clarify that "kpatch unload" isn't supported
|
||||
|
||||
Add a user-prompt to the kpatch unload subcommand and make a similiar
|
||||
mention in the manual page.
|
||||
|
||||
Provide an undocumented force option so that QE and dev scripts can
|
||||
still run unload kpatch modules from scripts.
|
||||
|
||||
RHEL-only.
|
||||
|
||||
Signed-off-by: Joe Lawrence <joe.lawrence@redhat.com>
|
||||
diff -Nupr kpatch-0.6.1.old/kpatch/kpatch kpatch-0.6.1/kpatch/kpatch
|
||||
--- kpatch-0.9.2.old/kpatch/kpatch 2019-08-28 10:35:01.191259434 -0400
|
||||
+++ kpatch-0.9.2/kpatch/kpatch 2019-08-28 16:11:13.067926576 -0400
|
||||
@@ -49,8 +49,8 @@ usage () {
|
||||
echo >&2
|
||||
usage_cmd "load --all" "load all installed patch modules into the running kernel"
|
||||
usage_cmd "load <module>" "load patch module into the running kernel"
|
||||
- usage_cmd "unload --all" "unload all patch modules from the running kernel"
|
||||
- usage_cmd "unload <module>" "unload patch module from the running kernel"
|
||||
+ usage_cmd "unload --all (UNSUPPORTED)" "unload all patch modules from the running kernel"
|
||||
+ usage_cmd "unload <module> (UNSUPPORTED)" "unload patch module from the running kernel"
|
||||
echo >&2
|
||||
usage_cmd "info <module>" "show information about a patch module"
|
||||
echo >&2
|
||||
@@ -71,6 +71,16 @@ die() {
|
||||
exit 1
|
||||
}
|
||||
|
||||
+confirm_prompt() {
|
||||
+ local prompt="$1"
|
||||
+ local answer
|
||||
+ while true; do
|
||||
+ read -rp "$prompt [Y/N] " answer
|
||||
+ [[ $answer == 'Y' || $answer == 'y' ]] && return 0
|
||||
+ [[ $answer == 'N' || $answer == 'n' ]] && return 1
|
||||
+ done
|
||||
+}
|
||||
+
|
||||
__find_module () {
|
||||
MODULE="$1"
|
||||
[[ -f "$MODULE" ]] && return
|
||||
@@ -406,6 +416,19 @@ unset MODULE
|
||||
init_sysfs_var
|
||||
|
||||
[[ "$#" -lt 1 ]] && usage
|
||||
+
|
||||
+# RHEL-specific support options
|
||||
+case "$1" in
|
||||
+"force")
|
||||
+ # For scripting purposes, support "kpatch force unload".
|
||||
+ # Shift out the "force" to avoid the user-prompt check below.
|
||||
+ shift
|
||||
+ ;;
|
||||
+"unload")
|
||||
+ confirm_prompt "WARNING: Red Hat doesn't support unloading of kpatches, continue anyway?" || exit 1
|
||||
+ ;;
|
||||
+esac
|
||||
+
|
||||
case "$1" in
|
||||
"load")
|
||||
[[ "$#" -ne 2 ]] && usage
|
||||
diff -Nupr kpatch-0.6.1.old/man/kpatch.1 kpatch-0.6.1/man/kpatch.1
|
||||
--- kpatch-0.9.2.old/man/kpatch.1 2019-08-28 10:35:01.191259434 -0400
|
||||
+++ kpatch-0.9.2/man/kpatch.1 2019-08-28 14:51:23.268198897 -0400
|
||||
@@ -23,10 +23,10 @@ load --all
|
||||
load <module>
|
||||
load patch module into the running kernel
|
||||
|
||||
-unload --all
|
||||
+unload --all (UNSUPPORTED)
|
||||
unload all patch modules from the running kernel
|
||||
|
||||
-unload <module>
|
||||
+unload <module> (UNSUPPORTED)
|
||||
unload patch module from the running kernel
|
||||
|
||||
info <module>
|
@ -0,0 +1,28 @@
|
||||
kpatch: do not rm selinux rpm owned directory
|
||||
|
||||
As part of the kpatch rpm package installation, the /var/lib/kpatch directory
|
||||
gets created and is set to be selinux owned by the kpatch rpm package.
|
||||
|
||||
There is a problem where uninstalling the last kpatch-patch will also remove
|
||||
this directory. When another kpatch-patch installation occurs, the
|
||||
/var/lib/kpatch get recreated but withtout the selinux context which triggers a
|
||||
policy error.
|
||||
|
||||
Since /var/lib/kpatch is now created by the rpm spec file, do not remove it
|
||||
from the uinstall target of the kpatch script. This insures selinux context
|
||||
consistency.
|
||||
|
||||
RHEL-only.
|
||||
|
||||
Signed-off-by: Yannick Cote <ycote@redhat.com>
|
||||
diff -Nupr kpatch-0.9.4.old/kpatch/kpatch kpatch-0.9.4/kpatch/kpatch
|
||||
--- kpatch-0.9.4.old/kpatch/kpatch 2021-08-26 15:31:07.000000000 -0400
|
||||
+++ kpatch-0.9.4/kpatch/kpatch 2022-06-10 12:19:55.791538218 -0400
|
||||
@@ -584,7 +584,6 @@ case "$1" in
|
||||
echo "uninstalling $PATCH ($KVER)"
|
||||
rm -f "$MODULE" || die "failed to uninstall module $PATCH"
|
||||
rmdir --ignore-fail-on-non-empty "$INSTALLDIR/$KVER" || die "failed to remove directory $INSTALLDIR/$KVER"
|
||||
- rmdir --ignore-fail-on-non-empty "$INSTALLDIR" || die "failed to remove directory $INSTALLDIR"
|
||||
|
||||
;;
|
||||
|
@ -0,0 +1,136 @@
|
||||
%define kpatch_dnf_ver 0.4
|
||||
|
||||
Name: kpatch
|
||||
Version: 0.9.7
|
||||
Release: 3%{?dist}
|
||||
Summary: Dynamic kernel patch manager
|
||||
|
||||
Group: System Environment/Kernel
|
||||
License: GPLv2
|
||||
URL: https://github.com/dynup/kpatch
|
||||
Source0: https://github.com/dynup/kpatch/archive/v%{version}.tar.gz
|
||||
Source1: kpatch-dnf-v%{kpatch_dnf_ver}.tar.gz
|
||||
|
||||
# RHEL-only
|
||||
Patch0: 0001-contrib-disable-upstart-kpatch.conf-install.patch
|
||||
Patch1: 0002-kpatch-clarify-unload-unsupport.patch
|
||||
Patch2: 0003-do-not-rm-selinux-rpm-owned-directory.patch
|
||||
|
||||
# Upstream backports (inactive -- for future reference)
|
||||
#Patch100: 0100-xxx.patch
|
||||
|
||||
# kpatch-dnf backports (inactive -- for future reference)
|
||||
#Patch200: 0200-foo-bar-etcetera.patch
|
||||
|
||||
BuildRequires: make
|
||||
|
||||
Requires: bash kmod binutils
|
||||
Recommends: kpatch-dnf
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
|
||||
%description
|
||||
kpatch is a live kernel patch module manager. It allows the user to manage
|
||||
a collection of binary kernel patch modules which can be used to dynamically
|
||||
patch the kernel without rebooting.
|
||||
|
||||
|
||||
%package -n kpatch-dnf
|
||||
Summary: kpatch-patch manager plugin for DNF
|
||||
Version: %{version}_%{kpatch_dnf_ver}
|
||||
BuildRequires: python3-devel python3-dnf
|
||||
Requires: python3-dnf python3-hawkey
|
||||
Provides: kpatch-dnf
|
||||
|
||||
%description -n kpatch-dnf
|
||||
kpatch-dnf is a DNF plugin that manages subscription to kpatch-patch updates.
|
||||
When enabled, kernel packages are automatically subscribed to corresponding
|
||||
kpatch-patch packages updates.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -P 0 -p1
|
||||
%patch -P 1 -p1
|
||||
%patch -P 2 -p1
|
||||
# Use this to apply upstream patches to kpatch
|
||||
#%patch -P 100 -p1
|
||||
|
||||
%setup -D -T -a 1
|
||||
|
||||
# Use this to apply patches to kpatch-dnf (inactive)
|
||||
#cd kpatch-dnf-%{kpatch_dnf_ver}
|
||||
#%patch200 -p1
|
||||
#cd ..
|
||||
|
||||
%build
|
||||
make -C man
|
||||
|
||||
make -C kpatch-dnf-%{kpatch_dnf_ver}
|
||||
|
||||
%install
|
||||
make install PREFIX=/usr DESTDIR=%{buildroot} -C kpatch
|
||||
make install PREFIX=/usr DESTDIR=%{buildroot} -C man
|
||||
make install PREFIX=/usr DESTDIR=%{buildroot} -C contrib
|
||||
mkdir -p %{buildroot}/%{_sharedstatedir}/kpatch
|
||||
rm -f %{buildroot}/usr/share/man/man1/kpatch-build.1.gz
|
||||
|
||||
make install PREFIX=/usr DESTDIR=%{buildroot} PYTHONSITES=%{python3_sitelib} -C kpatch-dnf-%{kpatch_dnf_ver}
|
||||
|
||||
%files
|
||||
%{_sbindir}/kpatch
|
||||
%{_usr}/lib/systemd/system/kpatch.service
|
||||
%{_sharedstatedir}/kpatch
|
||||
%doc %{_mandir}/man1/kpatch.1.gz
|
||||
|
||||
%files -n kpatch-dnf
|
||||
%{python3_sitelib}/dnf-plugins/kpatch.py
|
||||
%{python3_sitelib}/dnf-plugins/__pycache__
|
||||
%config(noreplace) %{_sysconfdir}/dnf/plugins/kpatch.conf
|
||||
%doc %{_mandir}/man8/dnf.kpatch.8.gz
|
||||
|
||||
%post -n kpatch-dnf
|
||||
echo "To enable automatic kpatch-patch subscription, run:"
|
||||
echo -e "\t$ dnf kpatch auto"
|
||||
|
||||
%changelog
|
||||
* Fri May 3 2024 Joe Lawrence <joe.lawrence@redhat.com> 0.9.7-3
|
||||
- Fix cs10 build error on missing `make` command
|
||||
- Fix "warning: %%patchN is deprecated"
|
||||
|
||||
* Wed Nov 16 2022 Yannick Cote <ycote@redhat.com> 0.9.7-2
|
||||
- augment kpatch-dnf package versioning to satisfy build (rhbz#2121212)
|
||||
|
||||
* Wed Nov 09 2022 Yannick Cote <ycote@redhat.com> 0.9.7-1
|
||||
- rebase kpatch user utility code to v0.9.7 (rhbz#2121212)
|
||||
|
||||
* Fri Jun 10 2022 Yannick Cote <ycote@redhat.com> 0.9.4-3
|
||||
- Do not rm selinux rpm owned directory (rhbz#2053413)
|
||||
|
||||
* Thu Jan 27 2022 Yannick Cote <ycote@redhat.com> 0.9.4-2
|
||||
- Add /usr/lib/kpatch to install and files list to appease SELinux (rhbz#2030004)
|
||||
|
||||
* Wed Sep 29 2021 Artem Savkov <asavkov@redhat.com> - 0.9.4-1
|
||||
- Rebase to 0.9.4
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.9.3-3
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Thu Jun 10 2021 Joe Lawrence <joe.lawrence@redhat.com> - 0.9.3-2
|
||||
- Rebase to latest upstream (via backport patch)
|
||||
|
||||
* Tue May 18 2021 Joel Savitz <jsavitz@redhat.com> - 0.9.3-1
|
||||
- Rebase to latest upstream
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 0.9.2-5
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Fri Mar 05 2021 Joe Lawrence <joe.lawrence@redhat.com> 0.9.2-4
|
||||
- Fix kpatch-dnf package description typos (rhbz#1934292)
|
||||
|
||||
* Mon Jan 04 2021 Julien Thierry <jthierry@redhat.com> 0.9.2-2
|
||||
- Remove kpatch-dnf dependency on python3 (rhbz#1912457)
|
||||
|
||||
* Wed Dec 2 2020 Joe Lawrence <joe.lawrence@redhat.com> 0.9.2-1
|
||||
- initial kpatch utility build for rhel-9.0.0 (rhbz#1901593)
|
Loading…
Reference in new issue