enable dns in runroots

- add koji signed repo support
- Run plugin callbacks when image builds finish

Signed-off-by: Dennis Gilmore <dennis@ra.ausil.us>
epel9
Dennis Gilmore 9 years ago
parent ab48e7103c
commit dcd6f55ca9

@ -1,46 +0,0 @@
From 565818a5adc55389d14ed2096f82ebce8c8fc2de Mon Sep 17 00:00:00 2001
From: Dennis Gilmore <dennis@ausil.us>
Date: Thu, 3 Mar 2016 18:03:18 -0600
Subject: [PATCH] install the builder runroot plugin and config
make the builder plugin directory
install the runroot.py plugin there
install the runroot.conf file in /etc/kojid/
Signed-off-by: Dennis Gilmore <dennis@ausil.us>
---
plugins/Makefile | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/plugins/Makefile b/plugins/Makefile
index 0bbf748..2e8b519 100644
--- a/plugins/Makefile
+++ b/plugins/Makefile
@@ -1,8 +1,12 @@
PYTHON=python
PLUGINDIR = /usr/lib/koji-hub-plugins
+BUILDERPLUGINDIR = /usr/lib/koji-builder-plugins
FILES = $(wildcard *.py)
+BUILDERFILES = runroot.py
CONFDIR = /etc/koji-hub/plugins
+BUILDERCONFDIR = /etc/kojid
CONFFILES = $(wildcard *.conf)
+BUILDERCONFFILES = runroot.conf
_default:
@echo "nothing to make. try make install"
@@ -18,7 +22,11 @@ install:
fi
mkdir -p $(DESTDIR)/$(PLUGINDIR)
+ mkdir -p $(DESTDIR)/$(BUILDERPLUGINDIR)
install -p -m 644 $(FILES) $(DESTDIR)/$(PLUGINDIR)
+ install -p -m 644 $(BUILDERFILES) $(DESTDIR)/$(BUILDERPLUGINDIR)
$(PYTHON) -c "import compileall; compileall.compile_dir('$(DESTDIR)/$(PLUGINDIR)', 1, '$(PLUGINDIR)', 1)"
+ $(PYTHON) -c "import compileall; compileall.compile_dir('$(DESTDIR)/$(BUILDERPLUGINDIR)', 1, '$(BUILDERPLUGINDIR)', 1)"
mkdir -p $(DESTDIR)/$(CONFDIR)
install -p -m 644 $(CONFFILES) $(DESTDIR)/$(CONFDIR)
+ install -p -m 644 $(BUILDERCONFFILES) $(DESTDIR)/$(BUILDERCONFDIR)
--
2.5.0

@ -9,14 +9,13 @@
Name: koji
Version: 1.10.1
Release: 4%{?dist}
Release: 5%{?dist}
License: LGPLv2 and GPLv2+
# koji.ssl libs (from plague) are GPLv2+
Summary: Build system tools
Group: Applications/System
URL: https://pagure.io/fork/ausil/koji/branch/fedora-infra
Patch0: fedora-config.patch
Patch1: 0001-install-the-builder-runroot-plugin-and-config.patch
Source: koji-%{version}.tar.bz2
BuildArch: noarch
@ -155,7 +154,6 @@ koji-web is a web UI to the Koji system.
%prep
%setup -q
%patch0 -p1 -b orig
%patch1 -p1 -b runroot
%build
@ -322,8 +320,13 @@ fi
%endif
%changelog
* Wed Apr 06 2016 Dennis Gilmore <dennis@ausil.us> - 1.10.1-5
- enable dns in runroots
- add koji signed repo support
- Run plugin callbacks when image builds finish
* Thu Mar 03 2016 Dennis Gilmore <dennis@ausil.us> - 1.10.1-4
- add a patch to install teh runroot builder plugin in the correct place
- add a patch to install the runroot builder plugin in the correct place
* Tue Mar 01 2016 Dennis Gilmore <dennis@ausil.us> - 1.10.1-3
- update to git e8201aac8294e6125a73504886b0800041b58868

@ -1 +1 @@
ca713835d5465eff1d3ab2e4847a702d koji-1.10.1.tar.bz2
1f29a44987df841df20d4286853c2a92 koji-1.10.1.tar.bz2

Loading…
Cancel
Save