Rebase (unfuzz) the nfs-libtirpc patch

epel9
Kevin Kofler 7 years ago
parent ba9e70239d
commit 9c9160a1a1

@ -1,6 +1,7 @@
--- kio-extras-16.08.3/CMakeLists.txt 2016-11-07 06:21:48.000000000 -0600
+++ kio-extras-16.08.3/CMakeLists.txt 2017-02-02 09:45:43.808487100 -0600
@@ -152,9 +152,11 @@ endif()
diff -ur kio-extras-17.12.0/CMakeLists.txt kio-extras-17.12.0-nfs-libtirpc/CMakeLists.txt
--- kio-extras-17.12.0/CMakeLists.txt 2017-12-08 02:00:30.000000000 +0100
+++ kio-extras-17.12.0-nfs-libtirpc/CMakeLists.txt 2018-01-10 19:56:58.179385571 +0100
@@ -177,9 +177,11 @@
if(Gperf_FOUND AND KF5KHtml_FOUND)
add_subdirectory( man )
endif()
@ -15,9 +16,10 @@
add_subdirectory( nfs )
endif()
endif()
--- kio-extras-16.08.3/nfs/CMakeLists.txt 2016-11-07 06:21:48.000000000 -0600
+++ kio-extras-16.08.3/nfs/CMakeLists.txt 2017-02-02 10:01:19.502229500 -0600
@@ -10,6 +10,7 @@ if (NOT HAVE_XDR_U_INT64_T AND NOT HAVE_
diff -ur kio-extras-17.12.0/nfs/CMakeLists.txt kio-extras-17.12.0-nfs-libtirpc/nfs/CMakeLists.txt
--- kio-extras-17.12.0/nfs/CMakeLists.txt 2017-12-05 00:08:51.000000000 +0100
+++ kio-extras-17.12.0-nfs-libtirpc/nfs/CMakeLists.txt 2018-01-10 19:56:58.179385571 +0100
@@ -10,6 +10,7 @@
message(FATAL_ERROR "Could not find 64-bit XDR datatype functions!")
endif (NOT HAVE_XDR_U_INT64_T AND NOT HAVE_XDR_UINT64_T AND NOT HAVE_XDR_U_HYPER AND NOT HAVE_XDR_U_LONGLONG_T)
@ -25,8 +27,8 @@
if (HAVE_XDR_U_INT64_T)
add_definitions(-DHAVE_XDR_U_INT64_T)
endif (HAVE_XDR_U_INT64_T)
@@ -26,7 +27,7 @@ endif (HAVE_XDR_U_LONGLONG_T)
add_definitions(-DTRANSLATION_DOMAIN=\"kio_nfs\")
@@ -26,7 +27,7 @@
add_definitions(-DTRANSLATION_DOMAIN=\"kio5_nfs\")
add_library(kio_nfs MODULE kio_nfs.cpp nfsv2.cpp nfsv3.cpp rpc_nfs3_prot_xdr.c rpc_nfs2_prot_xdr.c)
-target_link_libraries(kio_nfs KF5::KIOCore KF5::I18n Qt5::Network)

@ -25,7 +25,7 @@ Source0: http://download.kde.org/%{stable}/applications/%{version}/src/%{name}-%
# patch to use libtirpc for RPC, from Cygwin Ports
# should be upstreamable, considering that glibc's builtin RPC is obsolete
# https://github.com/cygwinports/kf5-kio-extras/blob/master/16.08.3-nfs-libtirpc.patch
Patch0: kio-extras-16.08.3-nfs-libtirpc.patch
Patch0: kio-extras-17.12.0-nfs-libtirpc.patch
## upstream patches

Loading…
Cancel
Save