restore nfs-libtirpc.patch

still needed
epel9
Rex Dieter 6 years ago
parent 1b66c4c48b
commit 4d65c74455

@ -0,0 +1,38 @@
diff -ur kio-extras-17.12.0/CMakeLists.txt kio-extras-17.12.0-nfs-libtirpc/CMakeLists.txt
--- kio-extras-17.12.0/CMakeLists.txt 2017-12-08 02:00:30.000000000 +0100
+++ kio-extras-17.12.0-nfs-libtirpc/CMakeLists.txt 2018-01-10 19:56:58.179385571 +0100
@@ -177,9 +177,11 @@
if(Gperf_FOUND AND KF5KHtml_FOUND)
add_subdirectory( man )
endif()
- check_include_files(rpc/rpc.h HAVE_RPC_RPC_H)
- add_feature_info("NFS kioslave" HAVE_RPC_RPC_H "The RPC library is needed to build the NFS kioslave")
- if(HAVE_RPC_RPC_H)
+ pkg_check_modules(TIRPC libtirpc)
+ include_directories(${TIRPC_INCLUDE_DIRS})
+ set(CMAKE_REQUIRED_LIBRARIES ${TIRPC_LIBRARIES})
+ add_feature_info("NFS kioslave" TIRPC_FOUND "The RPC library is needed to build the NFS kioslave")
+ if(TIRPC_FOUND)
add_subdirectory( nfs )
endif()
endif()
diff -ur kio-extras-17.12.0/nfs/CMakeLists.txt kio-extras-17.12.0-nfs-libtirpc/nfs/CMakeLists.txt
--- kio-extras-17.12.0/nfs/CMakeLists.txt 2017-12-05 00:08:51.000000000 +0100
+++ kio-extras-17.12.0-nfs-libtirpc/nfs/CMakeLists.txt 2018-01-10 19:56:58.179385571 +0100
@@ -10,6 +10,7 @@
message(FATAL_ERROR "Could not find 64-bit XDR datatype functions!")
endif (NOT HAVE_XDR_U_INT64_T AND NOT HAVE_XDR_UINT64_T AND NOT HAVE_XDR_U_HYPER AND NOT HAVE_XDR_U_LONGLONG_T)
+add_definitions(-D_DEFAULT_SOURCE)
if (HAVE_XDR_U_INT64_T)
add_definitions(-DHAVE_XDR_U_INT64_T)
endif (HAVE_XDR_U_INT64_T)
@@ -26,7 +27,7 @@
add_definitions(-DTRANSLATION_DOMAIN=\"kio5_nfs\")
add_library(kio_nfs MODULE kio_nfs.cpp nfsv2.cpp nfsv3.cpp rpc_nfs3_prot_xdr.c rpc_nfs2_prot_xdr.c)
-target_link_libraries(kio_nfs KF5::KIOCore KF5::I18n Qt5::Network)
+target_link_libraries(kio_nfs KF5::KIOCore KF5::I18n Qt5::Network ${TIRPC_LIBRARIES})
set_target_properties(kio_nfs PROPERTIES OUTPUT_NAME "nfs")
install(TARGETS kio_nfs DESTINATION ${PLUGIN_INSTALL_DIR}/kf5/kio)

@ -29,7 +29,6 @@ Source0: http://download.kde.org/%{stable}/applications/%{version}/src/%{name}-%
Patch1000: kio-extras-17.12.0-nfs-libtirpc.patch Patch1000: kio-extras-17.12.0-nfs-libtirpc.patch
## upstream patches ## upstream patches
Patch1: 0001-Avoid-crash-by-not-checking-free-space-for-smb.patch
# filter plugin provides # filter plugin provides
%global __provides_exclude_from ^(%{_kf5_qtplugindir}/.*\\.so)$ %global __provides_exclude_from ^(%{_kf5_qtplugindir}/.*\\.so)$

Loading…
Cancel
Save