parent
42ccbd0b65
commit
95067f41ab
@ -0,0 +1 @@
|
|||||||
|
/kxmlrpcclient-5.8.0.tar.xz
|
@ -0,0 +1,29 @@
|
|||||||
|
From: Hrvoje Senjan <hrvoje.senjan@gmail.com>
|
||||||
|
Date: Mon, 09 Mar 2015 17:34:14 +0000
|
||||||
|
Subject: Install translations if available
|
||||||
|
X-Git-Url: http://quickgit.kde.org/?p=kxmlrpcclient.git&a=commitdiff&h=5c4860018c74992f8acf225aa6644f9cb65a8387
|
||||||
|
---
|
||||||
|
Install translations if available
|
||||||
|
|
||||||
|
CCMAIL: faure@kde.org
|
||||||
|
CCMAIL: dvratil@redhat.com
|
||||||
|
---
|
||||||
|
|
||||||
|
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -27,9 +27,13 @@
|
||||||
|
)
|
||||||
|
|
||||||
|
########### Find packages ###########
|
||||||
|
+find_package(KF5I18n ${KF5_DEP_VERSION} CONFIG REQUIRED)
|
||||||
|
find_package(KF5KIO ${KF5_DEP_VERSION} CONFIG REQUIRED)
|
||||||
|
|
||||||
|
########### Targets ###########
|
||||||
|
+if(IS_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/po")
|
||||||
|
+ ki18n_install(po)
|
||||||
|
+endif()
|
||||||
|
add_subdirectory(src)
|
||||||
|
add_subdirectory(autotests)
|
||||||
|
|
||||||
|
|
@ -0,0 +1,79 @@
|
|||||||
|
%global framework kxmlrpcclient
|
||||||
|
|
||||||
|
Name: kf5-%{framework}
|
||||||
|
Version: 5.8.0
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: KDE Frameworks 5 Tier 3 library for interaction with XML RPC services
|
||||||
|
|
||||||
|
License: LGPLv2+ and BSD
|
||||||
|
URL: https://projects.kde.org/projects/frameworks/kxmlrpcclient
|
||||||
|
|
||||||
|
%global versiondir %(echo %{version} | cut -d. -f1-2)
|
||||||
|
%global revision %(echo %{version} | cut -d. -f3)
|
||||||
|
%if %{revision} >= 50
|
||||||
|
%global stable unstable
|
||||||
|
%else
|
||||||
|
%global stable stable
|
||||||
|
%endif
|
||||||
|
Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{framework}-%{version}.tar.xz
|
||||||
|
|
||||||
|
# Upstream patches
|
||||||
|
Patch0: kf5-kxmlrpcclient-install-translations.patch
|
||||||
|
|
||||||
|
BuildRequires: kf5-rpm-macros
|
||||||
|
BuildRequires: extra-cmake-modules
|
||||||
|
BuildRequires: qt5-qtbase-devel
|
||||||
|
|
||||||
|
BuildRequires: kf5-ki18n-devel
|
||||||
|
BuildRequires: kf5-kio-devel
|
||||||
|
|
||||||
|
Requires: kf5-filesystem
|
||||||
|
|
||||||
|
%description
|
||||||
|
KDE Frameworks 5 Tier 3 library for interaction with XML RPC services.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: kf5-kio-devel
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{framework}-%{version}
|
||||||
|
|
||||||
|
%patch0 -p 1 -b .translations
|
||||||
|
|
||||||
|
%build
|
||||||
|
mkdir -p %{_target_platform}
|
||||||
|
pushd %{_target_platform}
|
||||||
|
%{cmake_kf5} ..
|
||||||
|
popd
|
||||||
|
|
||||||
|
make %{?_smp_mflags} -C %{_target_platform}
|
||||||
|
|
||||||
|
%install
|
||||||
|
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
|
||||||
|
%find_lang kxmlrpcclient5_qt --with-qt --all-name
|
||||||
|
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files -f kxmlrpcclient5_qt.lang
|
||||||
|
%doc COPYING.BSD README.md
|
||||||
|
%{_kf5_libdir}/libKF5XmlRpcClient.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_kf5_includedir}/kxmlrpcclient_version.h
|
||||||
|
%{_kf5_includedir}/KXmlRpcClient
|
||||||
|
%{_kf5_libdir}/libKF5XmlRpcClient.so
|
||||||
|
%{_kf5_libdir}/cmake/KF5XmlRpcClient
|
||||||
|
%{_kf5_archdatadir}/mkspecs/modules/qt_KXmlRpcClient.pri
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Mar 16 2015 Daniel Vrátil <dvratil@redhat.com> - 5.8.0-1
|
||||||
|
- KDE Frameworks 5.8.0
|
Loading…
Reference in new issue