.spec cosmetics, disable debug output

epel8
Rex Dieter 10 years ago
parent 09b8d2f4b5
commit f1f30d3930

@ -2,7 +2,7 @@
Name: kf5-%{framework}
Version: 5.10.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: KDE Frameworks 5 Tier 3 solution for advanced plugin and service introspection
License: GPLv2+ and LGPLv2+
@ -17,6 +17,9 @@ URL: http://www.kde.org
%endif
Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{framework}-%{version}.tar.xz
# disable debug output by default
Patch1: kservice-5.10.0-no_debug.patch
BuildRequires: kf5-rpm-macros
BuildRequires: extra-cmake-modules
BuildRequires: qt5-qtbase-devel
@ -50,22 +53,26 @@ developing applications that use %{name}.
%prep
%setup -q -n %{framework}-%{version}
%patch1 -p1 -b .no_debug
%build
mkdir -p %{_target_platform}
mkdir %{_target_platform}
pushd %{_target_platform}
%{cmake_kf5} ..
popd
make %{?_smp_mflags} -C %{_target_platform}
%install
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%find_lang kservice5_qt --with-qt --all-name
mv %{buildroot}/%{_kf5_sysconfdir}/xdg/menus/applications.menu %{buildroot}/%{_kf5_sysconfdir}/xdg/menus/kf5-applications.menu
mv %{buildroot}%{_kf5_sysconfdir}/xdg/menus/applications.menu %{buildroot}/%{_kf5_sysconfdir}/xdg/menus/kf5-applications.menu
mkdir -p %{buildroot}/%{_kf5_datadir}/kservices5
mkdir -p %{buildroot}/%{_kf5_datadir}/kservicetypes5
mkdir -p %{buildroot}%{_kf5_datadir}/kservices5
mkdir -p %{buildroot}%{_kf5_datadir}/kservicetypes5
%post -p /sbin/ldconfig
@ -73,24 +80,29 @@ mkdir -p %{buildroot}/%{_kf5_datadir}/kservicetypes5
%files -f kservice5_qt.lang
%doc COPYING COPYING.LIB README.md
%config %{_kf5_sysconfdir}/xdg/menus/kf5-applications.menu
# this is not a config file, despite rpmlint complaining otherwise -- rex
%{_kf5_sysconfdir}/xdg/menus/kf5-applications.menu
%{_kf5_bindir}/kbuildsycoca5
%{_kf5_libdir}/libKF5Service.so.*
%{_kf5_datadir}/kservicetypes5
%{_kf5_datadir}/kservices5
%{_kf5_datadir}/kservicetypes5/
%{_kf5_datadir}/kservices5/
%{_kf5_mandir}/man8/*
%{_kf5_mandir}/*/man8/*
# why is this? -- rex
%exclude %{_kf5_mandir}/man8
%files devel
%{_kf5_includedir}/kservice_version.h
%{_kf5_includedir}/KService
%{_kf5_includedir}/KService/
%{_kf5_libdir}/libKF5Service.so
%{_kf5_libdir}/cmake/KF5Service
%{_kf5_libdir}/cmake/KF5Service/
%{_kf5_archdatadir}/mkspecs/modules/qt_KService.pri
%changelog
* Tue May 19 2015 Rex Dieter <rdieter@fedoraproject.org> 5.10.0-2
- .spec cosmetics, disable debug output
* Mon May 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.10.0-1
- KDE Frameworks 5.10.0

@ -0,0 +1,9 @@
diff -up kservice-5.10.0/src/sycoca/sycocadebug.cpp.no_debug kservice-5.10.0/src/sycoca/sycocadebug.cpp
--- kservice-5.10.0/src/sycoca/sycocadebug.cpp.no_debug 2015-05-03 10:22:52.000000000 -0500
+++ kservice-5.10.0/src/sycoca/sycocadebug.cpp 2015-05-19 15:36:20.841447165 -0500
@@ -15,4 +15,4 @@
#include "sycocadebug.h"
-Q_LOGGING_CATEGORY(SYCOCA, "kf5.kservice.sycoca")
+Q_LOGGING_CATEGORY(SYCOCA, "kf5.kservice.sycoca", QtWarningMsg)
Loading…
Cancel
Save