- use non-conflicting libkpeople5 translation catalog (#1208946)
- minor .spec cosmetics
epel9
Rex Dieter 10 years ago
parent 4c89ba377f
commit 7e6b9fcbae

@ -17,9 +17,10 @@ URL: https://projects.kde.org/projects/frameworks/kpeople
%endif
Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{framework}-%{version}.tar.xz
## Temporary, see http://bugzilla.redhat.com/1208946
Conflicts: libkpeople < 1.0
## Once ktp-kf5 stack is ready, switch Conflicts to Obsoletes
# use non-conflicting libkpeople5 translation catalog
Patch1: kpeople-catalog.patch
## Once ktp-kf5 stack is ready, can consider Obsoletes
#Obsoletes: libkpeople < 1.0
BuildRequires: kf5-rpm-macros
@ -53,8 +54,17 @@ developing applications that use %{name}.
%prep
%setup -q -n %{framework}-%{version}
%patch1 -p1 -b .catalog
for po in po/*/libkpeople.po ; do
pushd $(dirname $po)
mv libkpeople.po libkpeople5.po
popd
done
%build
mkdir -p %{_target_platform}
mkdir %{_target_platform}
pushd %{_target_platform}
%{cmake_kf5} .. \
-DENABLE_EXAMPLES:BOOL=OFF
@ -62,6 +72,7 @@ popd
make %{?_smp_mflags} -C %{_target_platform}
%install
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%find_lang kpeople5_qt --with-qt --all-name
@ -88,7 +99,12 @@ make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%{_kf5_archdatadir}/mkspecs/modules/qt_KPeople.pri
%{_kf5_archdatadir}/mkspecs/modules/qt_KPeopleWidgets.pri
%changelog
* Tue Apr 07 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.8.0-3
- use non-conflicting libkpeople5 translation catalog (#1208946)
- minor .spec cosmetics
* Sat Apr 04 2015 Rex Dieter <rdieter@fedoraproject.org> 5.8.0-2
- Conflicts: libkpeople (#1208946)

@ -0,0 +1,12 @@
diff -up kpeople-5.8.0/CMakeLists.txt.catalog kpeople-5.8.0/CMakeLists.txt
--- kpeople-5.8.0/CMakeLists.txt.catalog 2015-03-13 03:07:30.000000000 -0500
+++ kpeople-5.8.0/CMakeLists.txt 2015-04-07 16:42:40.806906451 -0500
@@ -30,7 +30,7 @@ include(KDEInstallDirs)
include(KDEFrameworkCompilerSettings)
include(KDECMakeSettings)
-add_definitions(-DTRANSLATION_DOMAIN=\"libkpeople\")
+add_definitions(-DTRANSLATION_DOMAIN=\"libkpeople5\")
set(CMAKECONFIG_INSTALL_DIR "${CMAKECONFIG_INSTALL_PREFIX}/KF5People")
Loading…
Cancel
Save