- .spec cosmetics
- Backport klauncher QT_NO_GLIB hack (#983110)
- %lang'ify translated manpages
epel9
Rex Dieter 10 years ago
parent 92aff2e8b2
commit 0c5f8bc768

@ -2,7 +2,7 @@
Name: kf5-%{framework}
Version: 5.10.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: KDE Frameworks 5 tier 3 solution for process launching
License: LGPLv2+ and BSD
@ -17,6 +17,9 @@ URL: http://www.kde.org
%endif
Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{framework}-%{version}.tar.xz
# backport hack to workaround klauncher/SM issues, see bug http://bugzilla.redhat.com/983110
Patch1: kinit-5.10.0-klauncher-qt_no_glib.patch
BuildRequires: libX11-devel
BuildRequires: kf5-rpm-macros
@ -53,17 +56,21 @@ developing applications that use %{name}.
%prep
%setup -q -n %{framework}-%{version}
%patch1 -p1 -b .klauncher-qt_no_glib
%build
mkdir -p %{_target_platform}
mkdir %{_target_platform}
pushd %{_target_platform}
%{cmake_kf5} ..
popd
make %{?_smp_mflags} -C %{_target_platform}
%install
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%find_lang kinit5_qt --with-qt --all-name
%find_lang kinit5_qt --with-man --with-qt --all-name
%post -p /sbin/ldconfig
@ -74,16 +81,19 @@ make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%{_kf5_bindir}/*
%{_kf5_libdir}/libkdeinit5_klauncher.so
%{_kf5_libexecdir}/*
%{_kf5_mandir}/man8/kdeinit5.8.gz
%{_kf5_mandir}/*/man8/kdeinit5.8.gz
%exclude %{_kf5_mandir}/man8
%{_kf5_mandir}/man8/kdeinit5.8*
%files devel
%{_kf5_libdir}/cmake/KF5Init
%{_kf5_libdir}/cmake/KF5Init/
%{_kf5_datadir}/dbus-1/interfaces/*.xml
%changelog
* Wed May 20 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.10.0-2
- .spec cosmetics
- Backport klauncher QT_NO_GLIB hack (#983110)
- %%lang'ify translated manpages
* Mon May 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.10.0-1
- KDE Frameworks 5.10.0

@ -0,0 +1,25 @@
diff -up kinit-5.10.0/src/klauncher/klauncher_main.cpp.qt_no_glib kinit-5.10.0/src/klauncher/klauncher_main.cpp
--- kinit-5.10.0/src/klauncher/klauncher_main.cpp.qt_no_glib 2015-05-03 10:14:51.000000000 -0500
+++ kinit-5.10.0/src/klauncher/klauncher_main.cpp 2015-05-20 08:49:34.594814571 -0500
@@ -152,10 +152,21 @@ extern "C" Q_DECL_EXPORT int kdemain(int
// WABA: Make sure not to enable session management.
putenv(strdup("SESSION_MANAGER="));
+ // Disable the GLib event loop (rh#983110)
+ bool wasQtNoGlibSet = (getenv("QT_NO_GLIB") != 0);
+ if (!wasQtNoGlibSet) {
+ setenv("QT_NO_GLIB", "1", true);
+ }
+
// We need a QGuiApplication as we use X11
QGuiApplication app(argc, argv);
app.setApplicationName(QStringLiteral("klauncher"));
+ // Now get rid of QT_NO_GLIB again so launched processes don't inherit it
+ if (!wasQtNoGlibSet) {
+ unsetenv("QT_NO_GLIB");
+ }
+
int maxTry = 3;
while (true) {
QString service(QLatin1String("org.kde.klauncher5")); // same as ktoolinvocation.cpp
Loading…
Cancel
Save