parent
dffb2ea21f
commit
34da0ad594
@ -1,25 +0,0 @@
|
|||||||
From 0cb0ecf8001d62ae0977c6f48f1807de45de314a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rex Dieter <rdieter@math.unl.edu>
|
|
||||||
Date: Tue, 20 Oct 2015 06:55:03 -0500
|
|
||||||
Subject: [PATCH 4/4] use KDE_INSTALL_FULL_ variant, so there is no ambiguity
|
|
||||||
|
|
||||||
---
|
|
||||||
src/core/CMakeLists.txt | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
|
|
||||||
index 3d8d4cb..0ad24b9 100644
|
|
||||||
--- a/src/core/CMakeLists.txt
|
|
||||||
+++ b/src/core/CMakeLists.txt
|
|
||||||
@@ -21,7 +21,7 @@ add_library(KF5::ConfigCore ALIAS KF5ConfigCore)
|
|
||||||
|
|
||||||
target_compile_definitions(KF5ConfigCore
|
|
||||||
PRIVATE
|
|
||||||
- KCONF_UPDATE_INSTALL_LOCATION="${CMAKE_INSTALL_PREFIX}/${KDE_INSTALL_LIBEXECDIR_KF5}/$<TARGET_FILE_NAME:KF5::kconf_update>"
|
|
||||||
+ KCONF_UPDATE_INSTALL_LOCATION="${KDE_INSTALL_FULL_LIBEXECDIR_KF5}/$<TARGET_FILE_NAME:KF5::kconf_update>"
|
|
||||||
)
|
|
||||||
|
|
||||||
target_include_directories(KF5ConfigCore INTERFACE "$<INSTALL_INTERFACE:${KDE_INSTALL_INCLUDEDIR_KF5}/KConfigCore>")
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
Loading…
Reference in new issue