restore/upstream fullpath patch, BR: cmake, sort BR's

epel8
Rex Dieter 9 years ago
parent 170167e096
commit 2abf1477cb

@ -0,0 +1,25 @@
From 0cb0ecf8001d62ae0977c6f48f1807de45de314a Mon Sep 17 00:00:00 2001
From: Rex Dieter <rdieter@math.unl.edu>
Date: Tue, 20 Oct 2015 06:55:03 -0500
Subject: [PATCH 4/4] use KDE_INSTALL_FULL_ variant, so there is no ambiguity
---
src/core/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 3d8d4cb..0ad24b9 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -21,7 +21,7 @@ add_library(KF5::ConfigCore ALIAS KF5ConfigCore)
target_compile_definitions(KF5ConfigCore
PRIVATE
- KCONF_UPDATE_INSTALL_LOCATION="${CMAKE_INSTALL_PREFIX}/${KDE_INSTALL_LIBEXECDIR_KF5}/$<TARGET_FILE_NAME:KF5::kconf_update>"
+ KCONF_UPDATE_INSTALL_LOCATION="${KDE_INSTALL_FULL_LIBEXECDIR_KF5}/$<TARGET_FILE_NAME:KF5::kconf_update>"
)
target_include_directories(KF5ConfigCore INTERFACE "$<INSTALL_INTERFACE:${KDE_INSTALL_INCLUDEDIR_KF5}/KConfigCore>")
--
2.5.0

@ -1,12 +0,0 @@
diff -up kconfig-5.12.0/src/core/CMakeLists.txt.fullpath kconfig-5.12.0/src/core/CMakeLists.txt
--- kconfig-5.12.0/src/core/CMakeLists.txt.fullpath 2015-07-05 03:54:35.000000000 -0500
+++ kconfig-5.12.0/src/core/CMakeLists.txt 2015-07-09 13:13:53.978827068 -0500
@@ -21,7 +21,7 @@ add_library(KF5::ConfigCore ALIAS KF5Con
target_compile_definitions(KF5ConfigCore
PRIVATE
- KCONF_UPDATE_INSTALL_LOCATION="${CMAKE_INSTALL_PREFIX}/${KDE_INSTALL_LIBEXECDIR_KF5}/$<TARGET_FILE_NAME:KF5::kconf_update>"
+ KCONF_UPDATE_INSTALL_LOCATION="${KDE_INSTALL_LIBEXECDIR_KF5}/$<TARGET_FILE_NAME:KF5::kconf_update>"
)
target_include_directories(KF5ConfigCore INTERFACE "$<INSTALL_INTERFACE:${KDE_INSTALL_INCLUDEDIR_KF5}/KConfigCore>")

@ -2,7 +2,7 @@
Name: kf5-%{framework} Name: kf5-%{framework}
Version: 5.15.0 Version: 5.15.0
Release: 1%{?dist} Release: 2%{?dist}
Summary: KDE Frameworks 5 Tier 1 addon with advanced configuration system Summary: KDE Frameworks 5 Tier 1 addon with advanced configuration system
License: GPLv2+ and LGPLv2+ and MIT License: GPLv2+ and LGPLv2+ and MIT
@ -18,12 +18,14 @@ URL: https://projects.kde.org/projects/frameworks/kconfig
Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{framework}-%{version}.tar.xz Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{framework}-%{version}.tar.xz
## upstream patches ## upstream patches
# http://commits.kde.org/kconfig/0cb0ecf8001d62ae0977c6f48f1807de45de314a
Patch4: 0004-use-KDE_INSTALL_FULL_-variant-so-there-is-no-ambigui.patch
## upstreamable patches ## upstreamable patches
# assume KDE_INSTALL_LIBEXECDIR_KF5 is a full (not relative to CMAKE_INSTALL_PREFIX) path
BuildRequires: kf5-rpm-macros >= %{version} BuildRequires: cmake
BuildRequires: extra-cmake-modules >= %{version} BuildRequires: extra-cmake-modules >= %{version}
BuildRequires: kf5-rpm-macros >= %{version}
BuildRequires: qt5-qtbase-devel BuildRequires: qt5-qtbase-devel
BuildRequires: qt5-qttools-devel BuildRequires: qt5-qttools-devel
@ -114,6 +116,9 @@ make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%changelog %changelog
* Tue Oct 20 2015 Rex Dieter <rdieter@fedoraproject.org> 5.15.0-2
- restore/upstream fullpath patch, BR: cmake, sort BR's
* Thu Oct 08 2015 Daniel Vrátil <dvratil@redhat.com> - 5.15.0-1 * Thu Oct 08 2015 Daniel Vrátil <dvratil@redhat.com> - 5.15.0-1
- KDE Frameworks 5.15.0 - KDE Frameworks 5.15.0

Loading…
Cancel
Save