- index only well-known document-centric dirs by default (#1235026)
- .spec cosmetics
- polish licensing
- -devel: drop xapian dep
epel9
Rex Dieter 9 years ago
parent 4246bd891a
commit 607777fb24

9
.gitignore vendored

@ -1,10 +1 @@
/baloo-5.5.95.tar.xz
/baloo-5.6.0.tar.xz
/baloo-5.6.1.tar.xz
/baloo-5.6.2.tar.xz
/baloo-5.6.95.tar.xz
/baloo-5.9.0.tar.xz
/baloo-5.9.1.tar.xz
/baloo-5.9.2.tar.xz
/baloo-5.13.0.tar.xz
/baloo-5.14.0.tar.xz /baloo-5.14.0.tar.xz

@ -0,0 +1,19 @@
diff -up baloo-5.14.0/src/file/fileindexerconfig.cpp.balooconfig baloo-5.14.0/src/file/fileindexerconfig.cpp
--- baloo-5.14.0/src/file/fileindexerconfig.cpp.balooconfig 2015-09-10 01:43:46.000000000 -0500
+++ baloo-5.14.0/src/file/fileindexerconfig.cpp 2015-10-03 09:48:28.880859786 -0500
@@ -276,8 +276,13 @@ void cleanupList(QList<QPair<QString, bo
void FileIndexerConfig::buildFolderCache()
{
KConfigGroup group = m_config.group("General");
- QStringList includeFoldersPlain = group.readPathEntry("folders", QStringList() << QDir::homePath());
- QStringList excludeFoldersPlain = group.readPathEntry("exclude folders", QStringList());
+ QStringList includeFoldersPlain = group.readPathEntry("folders", QStringList() <<
+ QStandardPaths::standardLocations(QStandardPaths::DocumentsLocation) <<
+ QStandardPaths::standardLocations(QStandardPaths::MusicLocation) <<
+ QStandardPaths::standardLocations(QStandardPaths::MoviesLocation) <<
+ QStandardPaths::standardLocations(QStandardPaths::PicturesLocation)
+ );
+ QStringList excludeFoldersPlain = group.readPathEntry("exclude folders", QStringList() << QDir::homePath());
// Add all removable media and network shares as ignored unless they have
// been explicitly added in the include list

@ -1,10 +1,13 @@
%define framework baloo %define framework baloo
Name: kf5-%{framework} Name: kf5-%{framework}
Version: 5.14.0
Release: 1%{?dist}
Summary: A Tier 3 KDE Frameworks 5 module that provides indexing and search functionality Summary: A Tier 3 KDE Frameworks 5 module that provides indexing and search functionality
License: LGPLv2+ Version: 5.14.0
Release: 2%{?dist}
# libs are LGPL, tools are GPL
# KDE e.V. may determine that future LGPL/GPL versions are accepted
License: (LGPLv2 or LGPLv3) and (GPLv2 or GPLv3)
URL: https://projects.kde.org/projects/kde/kdelibs/baloo URL: https://projects.kde.org/projects/kde/kdelibs/baloo
%global versiondir %(echo %{version} | cut -d. -f1-2) %global versiondir %(echo %{version} | cut -d. -f1-2)
@ -18,21 +21,25 @@ Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{fra
Source1: 97-kde-baloo-filewatch-inotify.conf Source1: 97-kde-baloo-filewatch-inotify.conf
BuildRequires: qt5-qtbase-devel ## upstreamable patches
BuildRequires: qt5-qtdeclarative-devel # http://bugzilla.redhat.com/1235026
BuildRequires: kf5-rpm-macros >= %{version} Patch1: baloo-5.14.0-baloofile_config.patch
BuildRequires: extra-cmake-modules >= %{version}
BuildRequires: lmdb-devel
BuildRequires: kf5-ki18n-devel >= %{version} BuildRequires: cmake
BuildRequires: kf5-kconfig-devel >= %{version} BuildRequires: extra-cmake-modules >= %{version}
BuildRequires: kf5-kidletime-devel >= %{version}
BuildRequires: kf5-kauth-devel >= %{version} BuildRequires: kf5-kauth-devel >= %{version}
BuildRequires: kf5-kconfig-devel >= %{version}
BuildRequires: kf5-kcrash-devel >= %{version} BuildRequires: kf5-kcrash-devel >= %{version}
BuildRequires: kf5-solid-devel >= %{version}
BuildRequires: kf5-kdbusaddons-devel >= %{version} BuildRequires: kf5-kdbusaddons-devel >= %{version}
BuildRequires: kf5-kfilemetadata-devel >= %{version} BuildRequires: kf5-kfilemetadata-devel >= %{version}
BuildRequires: kf5-ki18n-devel >= %{version}
BuildRequires: kf5-kidletime-devel >= %{version}
BuildRequires: kf5-kio-devel >= %{version} BuildRequires: kf5-kio-devel >= %{version}
BuildRequires: kf5-rpm-macros >= %{version}
BuildRequires: kf5-solid-devel >= %{version}
BuildRequires: lmdb-devel
BuildRequires: qt5-qtbase-devel
BuildRequires: qt5-qtdeclarative-devel
Requires: kf5-filesystem >= %{version} Requires: kf5-filesystem >= %{version}
@ -45,19 +52,20 @@ Provides: baloo = %{version}-%{release}
%package devel %package devel
Summary: Development files for %{name} Summary: Development files for %{name}
Group: Development/Libraries # KDE e.V. may determine that future LGPL versions are accepted
License: LGPLv2 or LGPLv3
Requires: %{name}%{?_isa} = %{version}-%{release} Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{name}-file%{?_isa} = %{version}-%{release} Requires: %{name}-file%{?_isa} = %{version}-%{release}
Requires: kf5-kfilemetadata-devel >= %{version}
Requires: xapian-core-devel
Requires: kf5-kcoreaddons-devel >= %{version} Requires: kf5-kcoreaddons-devel >= %{version}
Requires: kf5-kfilemetadata-devel >= %{version}
%description devel %description devel
The %{name}-devel package contains libraries and header files for The %{name}-devel package contains libraries and header files for
developing applications that use %{name}. developing applications that use %{name}.
%package file %package file
Summary: File indexing and search for Baloo Summary: File indexing and search for Baloo
# KDE e.V. may determine that future LGPL versions are accepted
License: LGPLv2 or LGPLv3
Obsoletes: %{name} < 5.0.1-2 Obsoletes: %{name} < 5.0.1-2
Obsoletes: baloo-file < 5.0.1-2 Obsoletes: baloo-file < 5.0.1-2
Provides: baloo-file = %{version}-%{release} Provides: baloo-file = %{version}-%{release}
@ -67,15 +75,20 @@ Requires: %{name} = %{version}-%{release}
%package libs %package libs
Summary: Runtime libraries for %{name} Summary: Runtime libraries for %{name}
# KDE e.V. may determine that future LGPL versions are accepted
License: LGPLv2 or LGPLv3
%description libs %description libs
%{summary}. %{summary}.
%prep %prep
%setup -qn %{framework}-%{version} %setup -qn %{framework}-%{version}
%build %patch1 -p1 -b .baloofile_config
mkdir -p %{_target_platform} %build
mkdir %{_target_platform}
pushd %{_target_platform} pushd %{_target_platform}
%{cmake_kf5} .. %{cmake_kf5} ..
popd popd
@ -116,6 +129,7 @@ gtk-update-icon-cache %{_kf5_datadir}/icons/hicolor &> /dev/null || :
fi fi
%files -f %{name}.lang %files -f %{name}.lang
%license COPYING
%{_kf5_bindir}/baloosearch %{_kf5_bindir}/baloosearch
%{_kf5_bindir}/balooshow %{_kf5_bindir}/balooshow
%{_kf5_bindir}/balooctl %{_kf5_bindir}/balooctl
@ -139,26 +153,31 @@ fi
%{_kf5_sysconfdir}/dbus-1/system.d/org.kde.baloo.filewatch.conf %{_kf5_sysconfdir}/dbus-1/system.d/org.kde.baloo.filewatch.conf
%{_kf5_datadir}/polkit-1/actions/org.kde.baloo.filewatch.policy %{_kf5_datadir}/polkit-1/actions/org.kde.baloo.filewatch.policy
%{_kf5_datadir}/dbus-1/system-services/org.kde.baloo.filewatch.service %{_kf5_datadir}/dbus-1/system-services/org.kde.baloo.filewatch.service
%{_kf5_datadir}/dbus-1/interfaces/org.kde.baloo.file.indexer.xml
%post libs -p /sbin/ldconfig %post libs -p /sbin/ldconfig
%postun libs -p /sbin/ldconfig %postun libs -p /sbin/ldconfig
%files libs %files libs
%license COPYING.LIB
%{_kf5_libdir}/libKF5Baloo.so.* %{_kf5_libdir}/libKF5Baloo.so.*
%{_kf5_libdir}/libKF5BalooEngine.so.* %{_kf5_libdir}/libKF5BalooEngine.so.*
%files devel %files devel
%{_kf5_libdir}/libKF5Baloo.so %{_kf5_libdir}/libKF5Baloo.so
%{_kf5_libdir}/cmake/KF5Baloo %{_kf5_libdir}/cmake/KF5Baloo/
%{_kf5_libdir}/pkgconfig/Baloo.pc %{_kf5_libdir}/pkgconfig/Baloo.pc
%{_kf5_includedir}/Baloo %{_kf5_includedir}/Baloo/
%{_kf5_includedir}/baloo_version.h %{_kf5_includedir}/baloo_version.h
%{_kf5_datadir}/dbus-1/interfaces/org.kde.baloo.*.xml %{_kf5_datadir}/dbus-1/interfaces/org.kde.baloo.*.xml
%changelog %changelog
* Sat Oct 03 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.14.0-2
- index only well-known document-centric dirs by default (#1235026)
- .spec cosmetics
- polish licensing
- -devel: drop xapian dep
* Wed Sep 16 2015 Daniel Vrátil <dvratil@redhat.com> - 5.14.0-1 * Wed Sep 16 2015 Daniel Vrátil <dvratil@redhat.com> - 5.14.0-1
- KDE Frameworks 5.14.0 - KDE Frameworks 5.14.0

Loading…
Cancel
Save