.spec cleanup

epel9
Rex Dieter 7 years ago
parent e060682b6f
commit 4c92f6a987

@ -0,0 +1,29 @@
From d45f3107c1015bcf10ca6fd199f9e0c425dfd343 Mon Sep 17 00:00:00 2001
From: Rex Dieter <rdieter@gmail.com>
Date: Mon, 15 Jan 2018 10:17:05 -0600
Subject: [PATCH 3/3] validate baloo_file.desktop
Fix per,
$ desktop-file-validate /etc/xdg/autostart/baloo_file.desktop --warn-kde
/etc/xdg/autostart/baloo_file.desktop: warning: value "Service" for key "Type" in group "Desktop Entry" is a reserved value for KDE
/etc/xdg/autostart/baloo_file.desktop: error: key "Exec" is present in group "Desktop Entry", but the type is "Service" while this key is only valid for type "Application"
other DE's complain about this on login otherwise (e.g. gnome)
---
src/file/baloo_file.desktop | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/file/baloo_file.desktop b/src/file/baloo_file.desktop
index 5136828b..c2c2b901 100644
--- a/src/file/baloo_file.desktop
+++ b/src/file/baloo_file.desktop
@@ -1,5 +1,5 @@
[Desktop Entry]
-Type=Service
+Type=Application
Exec=baloo_file
X-KDE-StartupNotify=false
X-KDE-autostart-condition=baloofilerc:Basic Settings:Indexing-Enabled:true
--
2.14.3

@ -1,10 +0,0 @@
diff -up baloo-5.27.0/src/file/baloo_file.desktop.dt baloo-5.27.0/src/file/baloo_file.desktop
--- baloo-5.27.0/src/file/baloo_file.desktop.dt 2016-10-02 04:42:18.000000000 -0500
+++ baloo-5.27.0/src/file/baloo_file.desktop 2016-10-04 07:06:17.588566558 -0500
@@ -1,5 +1,5 @@
[Desktop Entry]
-Type=Service
+Type=Application
Exec=baloo_file
X-KDE-StartupNotify=false
X-KDE-autostart-condition=baloofilerc:Basic Settings:Indexing-Enabled:true

@ -10,7 +10,7 @@
Name: kf5-%{framework}
Summary: A Tier 3 KDE Frameworks 5 module that provides indexing and search functionality
Version: 5.42.0
Release: 1%{?dist}
Release: 2%{?dist}
# libs are LGPL, tools are GPL
# KDE e.V. may determine that future LGPL/GPL versions are accepted
@ -18,47 +18,49 @@ License: (LGPLv2 or LGPLv3) and (GPLv2 or GPLv3)
URL: https://community.kde.org/Baloo
#URL: https://cgit.kde.org/%{framework}.git
%global versiondir %(echo %{version} | cut -d. -f1-2)
%global majmin %(echo %{version} | cut -d. -f1-2)
%global revision %(echo %{version} | cut -d. -f3)
%if %{revision} >= 50
%global stable unstable
%else
%global stable stable
%endif
Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{framework}-%{version}.tar.xz
Source0: http://download.kde.org/%{stable}/frameworks/%{majmin}/%{framework}-%{version}.tar.xz
Source1: 97-kde-baloo-filewatch-inotify.conf
## upstreamable patches
# http://bugzilla.redhat.com/1235026
Patch1: baloo-5.14.0-baloofile_config.patch
# make 'desktop-file-validate baloo_file.desktop' pass
Patch2: baloo-5.27.0-dt_validate.patch
BuildRequires: extra-cmake-modules >= %{version}
BuildRequires: kf5-kconfig-devel >= %{version}
BuildRequires: kf5-kcoreaddons-devel >= %{version}
BuildRequires: kf5-kcrash-devel >= %{version}
BuildRequires: kf5-kdbusaddons-devel >= %{version}
BuildRequires: kf5-kfilemetadata-devel >= %{version}
BuildRequires: kf5-ki18n-devel >= %{version}
BuildRequires: kf5-kidletime-devel >= %{version}
BuildRequires: kf5-kio-devel >= %{version}
BuildRequires: kf5-rpm-macros >= %{version}
BuildRequires: kf5-solid-devel >= %{version}
Patch100: baloo-5.14.0-baloofile_config.patch
## upstream patches
Patch3: 0003-validate-baloo_file.desktop.patch
BuildRequires: extra-cmake-modules >= %{majmin}
BuildRequires: kf5-kconfig-devel >= %{majmin}
BuildRequires: kf5-kcoreaddons-devel >= %{majmin}
BuildRequires: kf5-kcrash-devel >= %{majmin}
BuildRequires: kf5-kdbusaddons-devel >= %{majmin}
BuildRequires: kf5-kfilemetadata-devel >= %{majmin}
BuildRequires: kf5-ki18n-devel >= %{majmin}
BuildRequires: kf5-kidletime-devel >= %{majmin}
BuildRequires: kf5-kio-devel >= %{majmin}
BuildRequires: kf5-rpm-macros >= %{majmin}
BuildRequires: kf5-solid-devel >= %{majmin}
BuildRequires: lmdb-devel
BuildRequires: qt5-qtbase-devel
BuildRequires: qt5-qtdeclarative-devel
%if 0%{?tests}
BuildRequires: dbus-x11
BuildRequires: time
BuildRequires: xorg-x11-server-Xvfb
%endif
Requires: kf5-filesystem >= %{version}
Obsoletes: kf5-baloo-tools < 5.5.95-1
Provides: kf5-baloo-tools = %{version}-%{release}
%if 0%{?fedora}
Obsoletes: baloo < 5
Provides: baloo = %{version}-%{release}
@ -77,8 +79,8 @@ Summary: Development files for %{name}
# KDE e.V. may determine that future LGPL versions are accepted
License: LGPLv2 or LGPLv3
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Requires: kf5-kcoreaddons-devel >= %{version}
Requires: kf5-kfilemetadata-devel >= %{version}
Requires: kf5-kcoreaddons-devel >= %{majmin}
Requires: kf5-kfilemetadata-devel >= %{majmin}
Requires: qt5-qtbase-devel
%description devel
@ -126,15 +128,15 @@ make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
install -p -m644 -D %{SOURCE1} %{buildroot}%{_prefix}/lib/sysctl.d/97-kde-baloo-filewatch-inotify.conf
%find_lang kio5_baloosearch --with-qt
%find_lang kio5_tags --with-qt
%find_lang kio5_timeline --with-qt
%find_lang balooctl5 --with-qt
%find_lang baloosearch5 --with-qt
%find_lang balooshow5 --with-qt
%find_lang baloo_file5 --with-qt
%find_lang baloo_file_extractor5 --with-qt
%find_lang baloomonitorplugin --with-qt
%find_lang kio5_baloosearch
%find_lang kio5_tags
%find_lang kio5_timeline
%find_lang balooctl5
%find_lang baloosearch5
%find_lang balooshow5
%find_lang baloo_file5
%find_lang baloo_file_extractor5
%find_lang baloomonitorplugin
cat kio5_tags.lang kio5_baloosearch.lang kio5_timeline.lang balooctl5.lang baloosearch5.lang balooshow5.lang baloomonitorplugin.lang \
> %{name}.lang
@ -206,6 +208,9 @@ fi
%changelog
* Mon Jan 15 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.42.0-2
- .spec cleanup
* Mon Jan 08 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.42.0-1
- 5.42.0

Loading…
Cancel
Save