parent
35e8fa119c
commit
5459b67116
@ -1,2 +1,3 @@
|
|||||||
kaccounts-integration-16.04.3.tar.xz
|
kaccounts-integration-16.04.3.tar.xz
|
||||||
/kaccounts-integration-16.07.80.tar.xz
|
/kaccounts-integration-16.07.80.tar.xz
|
||||||
|
/kaccounts-integration-16.07.90.tar.xz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
commit 868f7b29df5d72d3bb62d6527c9c09464b751b85
|
|
||||||
Author: Rex Dieter <rdieter@math.unl.edu>
|
|
||||||
Date: Fri Jul 29 10:28:38 2016 -0500
|
|
||||||
|
|
||||||
better CMAKECONFIG_INSTALL_DIR fix
|
|
||||||
|
|
||||||
this should handle both relative and full paths properly
|
|
||||||
|
|
||||||
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
|
|
||||||
index 9aaf488..650f046 100644
|
|
||||||
--- a/src/lib/CMakeLists.txt
|
|
||||||
+++ b/src/lib/CMakeLists.txt
|
|
||||||
@@ -4,7 +4,7 @@ include_directories(
|
|
||||||
${CMAKE_CURRENT_BINARY_DIR}
|
|
||||||
)
|
|
||||||
|
|
||||||
-set(CMAKECONFIG_INSTALL_DIR "${CMAKECONFIG_INSTALL_PREFIX}/KAccounts")
|
|
||||||
+set(CMAKECONFIG_INSTALL_DIR "${KDE_INSTALL_FULL_CMAKEPACKAGEDIR}/KAccounts")
|
|
||||||
|
|
||||||
include(ECMPackageConfigHelpers)
|
|
||||||
include(ECMSetupVersion)
|
|
||||||
diff --git a/src/lib/KAccountsConfig.cmake.in b/src/lib/KAccountsConfig.cmake.in
|
|
||||||
index 3a1e524..0922496 100644
|
|
||||||
--- a/src/lib/KAccountsConfig.cmake.in
|
|
||||||
+++ b/src/lib/KAccountsConfig.cmake.in
|
|
||||||
@@ -9,4 +9,4 @@ include("${CMAKE_CURRENT_LIST_DIR}/FindAccountsFileDir.cmake")
|
|
||||||
include("${CMAKE_CURRENT_LIST_DIR}/KAccountsTargets.cmake")
|
|
||||||
include("${CMAKE_CURRENT_LIST_DIR}/KAccountsMacros.cmake")
|
|
||||||
|
|
||||||
-set(KACCOUNTS_MACROS_PATH "@CMAKE_INSTALL_PREFIX@/@CMAKECONFIG_INSTALL_DIR@")
|
|
||||||
+set(KACCOUNTS_MACROS_PATH "@CMAKECONFIG_INSTALL_DIR@")
|
|
Loading…
Reference in new issue