i8c-stream-201902
changed/i8c-stream-201902/jdom2-2.0.6-14.module_el8.2.0+363+9996591c
commit
e6bc5d49ce
@ -0,0 +1 @@
|
|||||||
|
SOURCES/jdom2-2.0.6.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
d47a717b9ea4e9917652d4b80a669b5f55fe7639 SOURCES/jdom2-2.0.6.tar.gz
|
@ -0,0 +1,101 @@
|
|||||||
|
From 05a8a2fa49e92ad36a86d5d73588a2e46bf9ff95 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Simacek <msimacek@redhat.com>
|
||||||
|
Date: Mon, 23 Jul 2018 14:30:14 +0200
|
||||||
|
Subject: [PATCH] Adapt build
|
||||||
|
|
||||||
|
---
|
||||||
|
build.xml | 40 +++++++++++++++++++++++++---------------
|
||||||
|
1 file changed, 25 insertions(+), 15 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/build.xml b/build.xml
|
||||||
|
index cd7c2ed..10d8df6 100644
|
||||||
|
--- a/build.xml
|
||||||
|
+++ b/build.xml
|
||||||
|
@@ -112,17 +112,7 @@ For instructions on how to build JDOM, please view the README.txt file.
|
||||||
|
|
||||||
|
<!-- Compilation class path -->
|
||||||
|
<path id="base.class.path">
|
||||||
|
- <pathelement location="${jaxen.jar}" />
|
||||||
|
- <pathelement location="${parser.jar}" />
|
||||||
|
- <pathelement location="${xmlapi.jar}" />
|
||||||
|
- <pathelement location="${junit.jar}" />
|
||||||
|
- <pathelement location="${isorelax.jar}" />
|
||||||
|
- <pathelement location="${xalan.jar}" />
|
||||||
|
- <pathelement location="${xalanser.jar}" />
|
||||||
|
- <!-- normally these stax jars will not be found -->
|
||||||
|
- <!-- this is used for testing Java5 (the test sets stax.dir) -->
|
||||||
|
- <pathelement location="${stax.dir}/jsr173_1.0_api.jar" />
|
||||||
|
- <pathelement location="${stax.dir}/sjsxp.jar" />
|
||||||
|
+ <fileset dir="${lib.dir}" includes="*.jar" />
|
||||||
|
</path>
|
||||||
|
|
||||||
|
<path id="core.class.path">
|
||||||
|
@@ -289,6 +279,7 @@ For instructions on how to build JDOM, please view the README.txt file.
|
||||||
|
header="<b>${Name}<br><font size='-1'>${version}</font></b>"
|
||||||
|
bottom="Copyright © ${year} Jason Hunter, Brett McLaughlin. All Rights Reserved.">
|
||||||
|
<classpath refid="base.class.path"/>
|
||||||
|
+ <link href="${j2se.apidoc}"/>
|
||||||
|
</javadoc>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
@@ -373,11 +364,11 @@ For instructions on how to build JDOM, please view the README.txt file.
|
||||||
|
<!-- =================================================================== -->
|
||||||
|
<target name="package" depends="coverage, jars"
|
||||||
|
description="Creates the class package">
|
||||||
|
- <zip destfile="${package}/${jarbase}.zip">
|
||||||
|
+ <!--<zip destfile="${package}/${jarbase}.zip">
|
||||||
|
<fileset dir="${package}" includes="${jarbase}*.jar" />
|
||||||
|
<fileset dir="${basedir}" includes="lib/xerces* lib/jaxen* lib/xml* lib/xalan/**" />
|
||||||
|
<fileset dir="${basedir}" includes="LICENSE.txt README.txt" />
|
||||||
|
- </zip>
|
||||||
|
+ </zip>-->
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<!-- =================================================================== -->
|
||||||
|
@@ -401,6 +392,7 @@ For instructions on how to build JDOM, please view the README.txt file.
|
||||||
|
<include name="**/*.class"/>
|
||||||
|
<!-- exclude name="**/**/jaxen/**/*.class"/ -->
|
||||||
|
</fileset>
|
||||||
|
+ <classpath refid="junit.class.path" />
|
||||||
|
</cobertura-instrument>
|
||||||
|
|
||||||
|
<property name="forkjunit" value="true" />
|
||||||
|
@@ -528,7 +520,25 @@ For instructions on how to build JDOM, please view the README.txt file.
|
||||||
|
</filterset>
|
||||||
|
</copy>
|
||||||
|
|
||||||
|
- <exec dir="${mavendir}/core" executable="${gpg}">
|
||||||
|
+ <copy filtering="true" file="maven/contrib.pom" tofile="${mavendir}/core/${mavenbase}-contrib.pom">
|
||||||
|
+ <filterset>
|
||||||
|
+ <filter token="artifactID" value="${mavenartifact}"/>
|
||||||
|
+ <filter token="version" value="${version}" />
|
||||||
|
+ <filter token="jdk" value="${compile.target}" />
|
||||||
|
+ <filter token="license" value="${license}" />
|
||||||
|
+ </filterset>
|
||||||
|
+ </copy>
|
||||||
|
+
|
||||||
|
+ <copy filtering="true" file="maven/junit.pom" tofile="${mavendir}/core/${mavenbase}-junit.pom">
|
||||||
|
+ <filterset>
|
||||||
|
+ <filter token="artifactID" value="${mavenartifact}"/>
|
||||||
|
+ <filter token="version" value="${version}" />
|
||||||
|
+ <filter token="jdk" value="${compile.target}" />
|
||||||
|
+ <filter token="license" value="${license}" />
|
||||||
|
+ </filterset>
|
||||||
|
+ </copy>
|
||||||
|
+
|
||||||
|
+ <!--exec dir="${mavendir}/core" executable="${gpg}">
|
||||||
|
<arg value="-abv"/>
|
||||||
|
<arg value="${mavenbase}.pom"/>
|
||||||
|
</exec>
|
||||||
|
@@ -543,7 +553,7 @@ For instructions on how to build JDOM, please view the README.txt file.
|
||||||
|
<exec dir="${mavendir}/core" executable="${gpg}">
|
||||||
|
<arg value="-abv"/>
|
||||||
|
<arg value="${mavenbase}-javadoc.jar"/>
|
||||||
|
- </exec>
|
||||||
|
+ </exec-->
|
||||||
|
|
||||||
|
<jar destfile="${mavendir}/${mavenbase}-maven-bundle.jar"
|
||||||
|
basedir="${mavendir}/core"
|
||||||
|
--
|
||||||
|
2.17.1
|
||||||
|
|
@ -0,0 +1,4 @@
|
|||||||
|
Bundle-Name=JDOM 2
|
||||||
|
Bundle-SymbolicName=org.jdom2
|
||||||
|
Export-Package=*
|
||||||
|
Import-Package=org.jaxen.*;resolution:=optional,*
|
@ -0,0 +1,22 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
set -e
|
||||||
|
|
||||||
|
name=jdom2
|
||||||
|
version="$(sed -n 's/Version:\s*//p' *.spec)"
|
||||||
|
|
||||||
|
# RETRIEVE
|
||||||
|
wget "https://github.com/hunterhacker/jdom/archive/JDOM-${version}.tar.gz" -O "${name}-${version}.orig.tar.gz"
|
||||||
|
|
||||||
|
rm -rf tarball-tmp
|
||||||
|
mkdir tarball-tmp
|
||||||
|
cd tarball-tmp
|
||||||
|
tar xf "../${name}-${version}.orig.tar.gz"
|
||||||
|
|
||||||
|
# CLEAN TARBALL
|
||||||
|
rm -r */lib */*/lib
|
||||||
|
find -name '*.jar' -delete
|
||||||
|
find -name '*.class' -delete
|
||||||
|
|
||||||
|
tar cf "../${name}-${version}.tar.gz" *
|
||||||
|
cd ..
|
||||||
|
rm -r tarball-tmp "${name}-${version}.orig.tar.gz"
|
@ -0,0 +1,96 @@
|
|||||||
|
<project>
|
||||||
|
<modelVersion>4.0.0</modelVersion>
|
||||||
|
<groupId>org.jdom</groupId>
|
||||||
|
<artifactId>@artifactID@-contrib</artifactId>
|
||||||
|
<packaging>jar</packaging>
|
||||||
|
|
||||||
|
<name>JDOM Contrib</name>
|
||||||
|
<version>@version@</version>
|
||||||
|
|
||||||
|
<description>
|
||||||
|
A complete, Java-based solution for accessing, manipulating,
|
||||||
|
and outputting XML data
|
||||||
|
</description>
|
||||||
|
<url>http://www.jdom.org</url>
|
||||||
|
|
||||||
|
<organization>
|
||||||
|
<name>JDOM</name>
|
||||||
|
<url>http://www.jdom.org</url>
|
||||||
|
</organization>
|
||||||
|
|
||||||
|
<mailingLists>
|
||||||
|
<mailingList>
|
||||||
|
<name>JDOM-interest Mailing List</name>
|
||||||
|
<post>jdom-interest@jdom.org</post>
|
||||||
|
<archive>http://jdom.markmail.org/</archive>
|
||||||
|
</mailingList>
|
||||||
|
</mailingLists>
|
||||||
|
|
||||||
|
<licenses>
|
||||||
|
<license>
|
||||||
|
<name>Similar to Apache License but with the acknowledgment clause removed</name>
|
||||||
|
<url>https://raw.github.com/hunterhacker/jdom/master/LICENSE.txt</url>
|
||||||
|
<distribution>repo</distribution>
|
||||||
|
<comments xml:space="preserve"><![CDATA[
|
||||||
|
|
||||||
|
@license@
|
||||||
|
|
||||||
|
]]></comments>
|
||||||
|
</license>
|
||||||
|
</licenses>
|
||||||
|
|
||||||
|
<scm>
|
||||||
|
<url>git@github.com:/hunterhacker/jdom</url>
|
||||||
|
<connection>scm:git:git@github.com:hunterhacker/jdom</connection>
|
||||||
|
<developerConnection>scm:git:git@github.com:hunterhacker/jdom</developerConnection>
|
||||||
|
</scm>
|
||||||
|
|
||||||
|
<developers>
|
||||||
|
<developer>
|
||||||
|
<id>hunterhacker</id>
|
||||||
|
<name>Jason Hunter</name>
|
||||||
|
<email>jhunter@servlets.com</email>
|
||||||
|
</developer>
|
||||||
|
<developer>
|
||||||
|
<id>rolfl</id>
|
||||||
|
<name>Rolf Lear</name>
|
||||||
|
<email>jdom@tuis.net</email>
|
||||||
|
</developer>
|
||||||
|
</developers>
|
||||||
|
|
||||||
|
<dependencies>
|
||||||
|
<dependency>
|
||||||
|
<groupId>org.jdom</groupId>
|
||||||
|
<artifactId>@artifactID@</artifactId>
|
||||||
|
<version>@version@</version>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>jaxen</groupId>
|
||||||
|
<artifactId>jaxen</artifactId>
|
||||||
|
<version>1.1.4</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>xerces</groupId>
|
||||||
|
<artifactId>xercesImpl</artifactId>
|
||||||
|
<version>2.10.0</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>isorelax</groupId>
|
||||||
|
<artifactId>isorelax</artifactId>
|
||||||
|
<version>20030108</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>stax</groupId>
|
||||||
|
<artifactId>stax-api</artifactId>
|
||||||
|
<version>1.0.1</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
</dependencies>
|
||||||
|
|
||||||
|
<properties>
|
||||||
|
<jdk.version>@jdk@</jdk.version>
|
||||||
|
</properties>
|
||||||
|
</project>
|
@ -0,0 +1,120 @@
|
|||||||
|
<project>
|
||||||
|
<modelVersion>4.0.0</modelVersion>
|
||||||
|
<groupId>org.jdom</groupId>
|
||||||
|
<artifactId>@artifactID@-junit</artifactId>
|
||||||
|
<packaging>jar</packaging>
|
||||||
|
|
||||||
|
<name>JDOM Junit</name>
|
||||||
|
<version>@version@</version>
|
||||||
|
|
||||||
|
<description>
|
||||||
|
A complete, Java-based solution for accessing, manipulating,
|
||||||
|
and outputting XML data
|
||||||
|
</description>
|
||||||
|
<url>http://www.jdom.org</url>
|
||||||
|
|
||||||
|
<organization>
|
||||||
|
<name>JDOM</name>
|
||||||
|
<url>http://www.jdom.org</url>
|
||||||
|
</organization>
|
||||||
|
|
||||||
|
<mailingLists>
|
||||||
|
<mailingList>
|
||||||
|
<name>JDOM-interest Mailing List</name>
|
||||||
|
<post>jdom-interest@jdom.org</post>
|
||||||
|
<archive>http://jdom.markmail.org/</archive>
|
||||||
|
</mailingList>
|
||||||
|
</mailingLists>
|
||||||
|
|
||||||
|
<licenses>
|
||||||
|
<license>
|
||||||
|
<name>Similar to Apache License but with the acknowledgment clause removed</name>
|
||||||
|
<url>https://raw.github.com/hunterhacker/jdom/master/LICENSE.txt</url>
|
||||||
|
<distribution>repo</distribution>
|
||||||
|
<comments xml:space="preserve"><![CDATA[
|
||||||
|
|
||||||
|
@license@
|
||||||
|
|
||||||
|
]]></comments>
|
||||||
|
</license>
|
||||||
|
</licenses>
|
||||||
|
|
||||||
|
<scm>
|
||||||
|
<url>git@github.com:/hunterhacker/jdom</url>
|
||||||
|
<connection>scm:git:git@github.com:hunterhacker/jdom</connection>
|
||||||
|
<developerConnection>scm:git:git@github.com:hunterhacker/jdom</developerConnection>
|
||||||
|
</scm>
|
||||||
|
|
||||||
|
<developers>
|
||||||
|
<developer>
|
||||||
|
<id>hunterhacker</id>
|
||||||
|
<name>Jason Hunter</name>
|
||||||
|
<email>jhunter@servlets.com</email>
|
||||||
|
</developer>
|
||||||
|
<developer>
|
||||||
|
<id>rolfl</id>
|
||||||
|
<name>Rolf Lear</name>
|
||||||
|
<email>jdom@tuis.net</email>
|
||||||
|
</developer>
|
||||||
|
</developers>
|
||||||
|
|
||||||
|
<dependencies>
|
||||||
|
<dependency>
|
||||||
|
<groupId>org.jdom</groupId>
|
||||||
|
<artifactId>@artifactID@</artifactId>
|
||||||
|
<version>@version@</version>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>jaxen</groupId>
|
||||||
|
<artifactId>jaxen</artifactId>
|
||||||
|
<version>1.1.4</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>xerces</groupId>
|
||||||
|
<artifactId>xercesImpl</artifactId>
|
||||||
|
<version>2.10.0</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>junit</groupId>
|
||||||
|
<artifactId>junit</artifactId>
|
||||||
|
<version>4.11</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>asm</groupId>
|
||||||
|
<artifactId>asm</artifactId>
|
||||||
|
<version>3.3.1</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>asm</groupId>
|
||||||
|
<artifactId>asm-tree</artifactId>
|
||||||
|
<version>3.3.1</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>log4j</groupId>
|
||||||
|
<artifactId>log4j</artifactId>
|
||||||
|
<version>1.2.17</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>net.sourceforge.cobertura</groupId>
|
||||||
|
<artifactId>cobertura</artifactId>
|
||||||
|
<version>1.9.4.1</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>net.sourceforge.cobertura</groupId>
|
||||||
|
<artifactId>cobertura-runtime</artifactId>
|
||||||
|
<version>1.9.4.1</version>
|
||||||
|
<optional>true</optional>
|
||||||
|
</dependency>
|
||||||
|
</dependencies>
|
||||||
|
|
||||||
|
<properties>
|
||||||
|
<jdk.version>@jdk@</jdk.version>
|
||||||
|
</properties>
|
||||||
|
</project>
|
@ -0,0 +1,150 @@
|
|||||||
|
Name: jdom2
|
||||||
|
Version: 2.0.6
|
||||||
|
Release: 14%{?dist}
|
||||||
|
Summary: Java manipulation of XML made easy
|
||||||
|
License: Saxpath
|
||||||
|
URL: http://www.jdom.org/
|
||||||
|
# ./generate-tarball.sh
|
||||||
|
Source0: %{name}-%{version}.tar.gz
|
||||||
|
# originally taken from http://repo1.maven.org/maven2/org/jdom/jdom-contrib/1.1.3/jdom-contrib-1.1.3.pom
|
||||||
|
Source1: jdom-contrib-template.pom
|
||||||
|
Source2: jdom-junit-template.pom
|
||||||
|
# Bnd tool configuration
|
||||||
|
Source3: bnd.properties
|
||||||
|
# Remove bundled jars that might not have clear licensing
|
||||||
|
Source4: generate-tarball.sh
|
||||||
|
# Use system libraries
|
||||||
|
# Disable gpg signatures
|
||||||
|
# Process contrib and junit pom files
|
||||||
|
Patch0: 0001-Adapt-build.patch
|
||||||
|
|
||||||
|
BuildRequires: javapackages-local
|
||||||
|
BuildRequires: ant
|
||||||
|
BuildRequires: ant-junit
|
||||||
|
BuildRequires: isorelax
|
||||||
|
BuildRequires: jaxen
|
||||||
|
BuildRequires: xalan-j2
|
||||||
|
BuildRequires: xerces-j2
|
||||||
|
BuildRequires: xml-commons-apis
|
||||||
|
BuildRequires: log4j12
|
||||||
|
#BuildRequires: aqute-bnd
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description
|
||||||
|
JDOM is a Java-oriented object model which models XML documents.
|
||||||
|
It provides a Java-centric means of generating and manipulating
|
||||||
|
XML documents. While JDOM inter-operates well with existing
|
||||||
|
standards such as the Simple API for XML (SAX) and the Document
|
||||||
|
Object Model (DOM), it is not an abstraction layer or
|
||||||
|
enhancement to those APIs. Rather, it seeks to provide a robust,
|
||||||
|
light-weight means of reading and writing XML data without the
|
||||||
|
complex and memory-consumptive options that current API
|
||||||
|
offerings provide.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Summary: Javadoc for %{name}
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
This package contains javadoc for %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n jdom-JDOM-%{version}
|
||||||
|
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
cp -p %{SOURCE1} maven/contrib.pom
|
||||||
|
cp -p %{SOURCE2} maven/junit.pom
|
||||||
|
|
||||||
|
sed -i 's/\r//' LICENSE.txt README.txt
|
||||||
|
|
||||||
|
# Unable to run coverage: use log4j12 but switch to log4j 2.x
|
||||||
|
sed -i.coverage "s|coverage, jars|jars|" build.xml
|
||||||
|
|
||||||
|
%build
|
||||||
|
mkdir lib
|
||||||
|
build-jar-repository lib xerces-j2 xml-commons-apis jaxen junit isorelax xalan-j2 xalan-j2-serializer
|
||||||
|
ant -Dversion=%{version} -Dcompile.source=1.6 -Dcompile.target=1.6 -Dj2se.apidoc=%{_javadocdir}/java maven
|
||||||
|
|
||||||
|
# Make jar into an OSGi bundle
|
||||||
|
# XXX disabled until BND is fixed
|
||||||
|
#bnd wrap --output build/package/jdom-%{version}.bar --properties %{SOURCE3} \
|
||||||
|
# --version %{version} build/package/jdom-%{version}.jar
|
||||||
|
#mv build/package/jdom-%{version}.bar build/package/jdom-%{version}.jar
|
||||||
|
|
||||||
|
%install
|
||||||
|
%mvn_artifact build/maven/core/%{name}-%{version}.pom build/package/jdom-%{version}.jar
|
||||||
|
%mvn_artifact build/maven/core/%{name}-%{version}-contrib.pom build/package/jdom-%{version}-contrib.jar
|
||||||
|
%mvn_artifact build/maven/core/%{name}-%{version}-junit.pom build/package/jdom-%{version}-junit.jar
|
||||||
|
%mvn_install -J build/apidocs
|
||||||
|
|
||||||
|
%files -f .mfiles
|
||||||
|
%doc CHANGES.txt COMMITTERS.txt README.txt TODO.txt
|
||||||
|
%license LICENSE.txt
|
||||||
|
|
||||||
|
%files javadoc -f .mfiles-javadoc
|
||||||
|
%license LICENSE.txt
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue May 07 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 2.0.6-14
|
||||||
|
- Rebuilt for MSVSphere 8.9
|
||||||
|
|
||||||
|
* Tue Nov 05 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.0.6-14
|
||||||
|
- Mass rebuild for javapackages-tools 201902
|
||||||
|
|
||||||
|
* Fri May 24 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.0.6-13
|
||||||
|
- Mass rebuild for javapackages-tools 201901
|
||||||
|
|
||||||
|
* Mon Jul 23 2018 Michael Simacek <msimacek@redhat.com> - 2.0.6-12
|
||||||
|
- Repack tarball without bundled jars
|
||||||
|
- The repacked jar contains slightly different source (force push by upstream?)
|
||||||
|
- Correct license tag
|
||||||
|
|
||||||
|
* Tue Jul 17 2018 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.0.6-11
|
||||||
|
- Remove unneeded buildrequires
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.6-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.6-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.6-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed May 31 2017 Michael Simacek <msimacek@redhat.com> - 2.0.6-7
|
||||||
|
- Avoid hardcoded jar paths
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.6-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Apr 14 2016 Mat Booth <mat.booth@redhat.com> - 2.0.6-6
|
||||||
|
- Add OSGi metadata to main jar
|
||||||
|
- Fix file listed twice warning
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.6-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.6-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Mar 24 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.0.6-3
|
||||||
|
- Remove unneeded BR on cobertura
|
||||||
|
|
||||||
|
* Fri Feb 06 2015 gil cattaneo <puntogil@libero.it> 2.0.6-2
|
||||||
|
- introduce license macro
|
||||||
|
|
||||||
|
* Tue Oct 21 2014 gil cattaneo <puntogil@libero.it> 2.0.6-1
|
||||||
|
- update to 2.0.6 (rhbz#1118627)
|
||||||
|
|
||||||
|
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.5-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Mar 28 2014 Michael Simacek <msimacek@redhat.com> - 2.0.5-3
|
||||||
|
- Use Requires: java-headless rebuild (#1067528)
|
||||||
|
|
||||||
|
* Thu Nov 14 2013 gil cattaneo <puntogil@libero.it> 2.0.5-2
|
||||||
|
- use objectweb-asm3
|
||||||
|
|
||||||
|
* Thu Sep 12 2013 gil cattaneo <puntogil@libero.it> 2.0.5-1
|
||||||
|
- initial rpm
|
Loading…
Reference in new issue