parent
be1c76ab43
commit
5b9e1f5b22
@ -1,2 +1,2 @@
|
|||||||
SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
||||||
SOURCES/openjdk-21.0.1+12.tar.xz
|
SOURCES/openjdk-21.0.2+13.tar.xz
|
||||||
|
@ -1,2 +1,2 @@
|
|||||||
c8281ee37b77d535c9c1af86609a531958ff7b34 SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
c8281ee37b77d535c9c1af86609a531958ff7b34 SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
||||||
062c60df2265006e2be6e2cec33b961d5183acd9 SOURCES/openjdk-21.0.1+12.tar.xz
|
0768105cb0e64a986b767cde0dabad6cafc76c6b SOURCES/openjdk-21.0.2+13.tar.xz
|
||||||
|
@ -1,39 +0,0 @@
|
|||||||
OpenJDK 21 is the latest Long-Term Support (LTS) release of the Java platform.
|
|
||||||
|
|
||||||
For a list of major changes from OpenJDK 17 (java-17-openjdk), see the upstream
|
|
||||||
release page for OpenJDK 21 and the preceding interim releases:
|
|
||||||
|
|
||||||
* 18: https://openjdk.java.net/projects/jdk/18/
|
|
||||||
* 19: https://openjdk.java.net/projects/jdk/19/
|
|
||||||
* 20: https://openjdk.java.net/projects/jdk/20/
|
|
||||||
* 21: https://openjdk.java.net/projects/jdk/21/
|
|
||||||
|
|
||||||
# Rebuilding the OpenJDK package
|
|
||||||
|
|
||||||
The OpenJDK packages are now created from a single build which is then
|
|
||||||
packaged for different major versions of Red Hat Enterprise Linux
|
|
||||||
(RHEL). This allows the OpenJDK team to focus their efforts on the
|
|
||||||
development and testing of this single build, rather than having
|
|
||||||
multiple builds which only differ by the platform they were built on.
|
|
||||||
|
|
||||||
This does make rebuilding the package slightly more complicated than a
|
|
||||||
normal package. Modifications should be made to the
|
|
||||||
`java-21-openjdk-portable.specfile` file, which can be found with this
|
|
||||||
README file in the source RPM or installed in the documentation tree
|
|
||||||
by the `java-21-openjdk-headless` RPM.
|
|
||||||
|
|
||||||
Once the modified `java-21-openjdk-portable` RPMs are built, they
|
|
||||||
should be installed and will produce a number of tarballs in the
|
|
||||||
`/usr/lib/jvm` directory. The `java-21-openjdk` RPMs can then be
|
|
||||||
built, which will use these tarballs to create the usual RPMs found in
|
|
||||||
RHEL. The `java-21-openjdk-portable` RPMs can be uninstalled once the
|
|
||||||
desired final RPMs are produced.
|
|
||||||
|
|
||||||
Note that the `java-21-openjdk.spec` file has a hard requirement on
|
|
||||||
the exact version of java-21-openjdk-portable to use, so this will
|
|
||||||
need to be modified if the version or rpmrelease values are changed in
|
|
||||||
`java-21-openjdk-portable.specfile`.
|
|
||||||
|
|
||||||
To reduce the number of RPMs involved, the `fastdebug` and `slowdebug`
|
|
||||||
builds may be disabled using `--without fastdebug` and `--without
|
|
||||||
slowdebug`.
|
|
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
@ -1,10 +0,0 @@
|
|||||||
[Desktop Entry]
|
|
||||||
Name=OpenJDK @JAVA_VER@ for @target_cpu@ Monitoring & Management Console (@OPENJDK_VER@)
|
|
||||||
Comment=Monitor and manage OpenJDK applications
|
|
||||||
Exec=_SDKBINDIR_/jconsole
|
|
||||||
Icon=java-@JAVA_VER@-@JAVA_VENDOR@
|
|
||||||
Terminal=false
|
|
||||||
Type=Application
|
|
||||||
StartupWMClass=sun-tools-jconsole-JConsole
|
|
||||||
Categories=Development;Profiling;Java;
|
|
||||||
Version=1.0
|
|
@ -1,53 +0,0 @@
|
|||||||
commit 1b3825db8631e55771fb723d4fcd10040ea15b7e
|
|
||||||
Author: duke <duke@openjdk.org>
|
|
||||||
Date: Wed Apr 12 17:25:27 2023 +0000
|
|
||||||
|
|
||||||
Backport ec199072c5867624d66840238cc8828e16ae8da7
|
|
||||||
|
|
||||||
diff --git a/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java b/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
|
|
||||||
index 6f6e190efcd..ef278203182 100644
|
|
||||||
--- a/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
|
|
||||||
+++ b/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
|
|
||||||
@@ -608,34 +608,6 @@ public final class ZoneInfoFile {
|
|
||||||
params[8] = endRule.secondOfDay * 1000;
|
|
||||||
params[9] = toSTZTime[endRule.timeDefinition];
|
|
||||||
dstSavings = (startRule.offsetAfter - startRule.offsetBefore) * 1000;
|
|
||||||
-
|
|
||||||
- // Note: known mismatching -> Asia/Amman
|
|
||||||
- // ZoneInfo : startDayOfWeek=5 <= Thursday
|
|
||||||
- // startTime=86400000 <= 24 hours
|
|
||||||
- // This: startDayOfWeek=6
|
|
||||||
- // startTime=0
|
|
||||||
- // Similar workaround needs to be applied to Africa/Cairo and
|
|
||||||
- // its endDayOfWeek and endTime
|
|
||||||
- // Below is the workarounds, it probably slows down everyone a little
|
|
||||||
- if (params[2] == 6 && params[3] == 0 &&
|
|
||||||
- (zoneId.equals("Asia/Amman"))) {
|
|
||||||
- params[2] = 5;
|
|
||||||
- params[3] = 86400000;
|
|
||||||
- }
|
|
||||||
- // Additional check for startDayOfWeek=6 and starTime=86400000
|
|
||||||
- // is needed for Asia/Amman;
|
|
||||||
- if (params[2] == 7 && params[3] == 0 &&
|
|
||||||
- (zoneId.equals("Asia/Amman"))) {
|
|
||||||
- params[2] = 6; // Friday
|
|
||||||
- params[3] = 86400000; // 24h
|
|
||||||
- }
|
|
||||||
- //endDayOfWeek and endTime workaround
|
|
||||||
- if (params[7] == 6 && params[8] == 0 &&
|
|
||||||
- (zoneId.equals("Africa/Cairo"))) {
|
|
||||||
- params[7] = 5;
|
|
||||||
- params[8] = 86400000;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
} else if (nTrans > 0) { // only do this if there is something in table already
|
|
||||||
if (lastyear < LASTYEAR) {
|
|
||||||
// ZoneInfo has an ending entry for 2037
|
|
||||||
@@ -908,7 +880,6 @@ public final class ZoneInfoFile {
|
|
||||||
this.dow = dowByte == 0 ? -1 : dowByte;
|
|
||||||
this.secondOfDay = timeByte == 31 ? in.readInt() : timeByte * 3600;
|
|
||||||
this.timeDefinition = (data & (3 << 12)) >>> 12;
|
|
||||||
-
|
|
||||||
this.standardOffset = stdByte == 255 ? in.readInt() : (stdByte - 128) * 900;
|
|
||||||
this.offsetBefore = beforeByte == 3 ? in.readInt() : standardOffset + beforeByte * 1800;
|
|
||||||
this.offsetAfter = afterByte == 3 ? in.readInt() : standardOffset + afterByte * 1800;
|
|
File diff suppressed because it is too large
Load Diff
@ -1,5 +0,0 @@
|
|||||||
name = NSS
|
|
||||||
nssLibraryDirectory = @NSS_LIBDIR@
|
|
||||||
nssDbMode = noDb
|
|
||||||
attributes = compatibility
|
|
||||||
handleStartupErrors = ignoreMultipleInitialisation
|
|
@ -1,16 +0,0 @@
|
|||||||
diff -r 618ad1237e73 src/java.desktop/share/classes/java/awt/Toolkit.java
|
|
||||||
--- a/src/java.desktop/share/classes/java/awt/Toolkit.java Thu Jun 13 19:37:49 2019 +0200
|
|
||||||
+++ b/src/java.desktop/share/classes/java/awt/Toolkit.java Thu Jul 04 10:35:42 2019 +0200
|
|
||||||
@@ -595,7 +595,11 @@
|
|
||||||
toolkit = new HeadlessToolkit(toolkit);
|
|
||||||
}
|
|
||||||
if (!GraphicsEnvironment.isHeadless()) {
|
|
||||||
- loadAssistiveTechnologies();
|
|
||||||
+ try {
|
|
||||||
+ loadAssistiveTechnologies();
|
|
||||||
+ } catch (AWTError error) {
|
|
||||||
+ // ignore silently
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
}
|
|
||||||
return toolkit;
|
|
@ -1,12 +0,0 @@
|
|||||||
diff --git openjdk.orig/src/java.base/share/conf/security/java.security openjdk/src/java.base/share/conf/security/java.security
|
|
||||||
index 68a9c1a2d08..7aa25eb2cb7 100644
|
|
||||||
--- openjdk.orig/src/java.base/share/conf/security/java.security
|
|
||||||
+++ openjdk/src/java.base/share/conf/security/java.security
|
|
||||||
@@ -78,6 +78,7 @@ security.provider.tbd=SunMSCAPI
|
|
||||||
security.provider.tbd=Apple
|
|
||||||
#endif
|
|
||||||
security.provider.tbd=SunPKCS11
|
|
||||||
+#security.provider.tbd=SunPKCS11 ${java.home}/lib/security/nss.cfg
|
|
||||||
|
|
||||||
#
|
|
||||||
# Security providers used when FIPS mode support is active
|
|
@ -1,20 +0,0 @@
|
|||||||
--- openjdk/src/java.base/share/conf/security/java.security
|
|
||||||
+++ openjdk/src/java.base/share/conf/security/java.security
|
|
||||||
@@ -304,6 +304,8 @@
|
|
||||||
#
|
|
||||||
package.access=sun.misc.,\
|
|
||||||
sun.reflect.,\
|
|
||||||
+ org.GNOME.Accessibility.,\
|
|
||||||
+ org.GNOME.Bonobo.,\
|
|
||||||
|
|
||||||
#
|
|
||||||
# List of comma-separated packages that start with or equal this string
|
|
||||||
@@ -316,6 +318,8 @@
|
|
||||||
#
|
|
||||||
package.definition=sun.misc.,\
|
|
||||||
sun.reflect.,\
|
|
||||||
+ org.GNOME.Accessibility.,\
|
|
||||||
+ org.GNOME.Bonobo.,\
|
|
||||||
|
|
||||||
#
|
|
||||||
# Determines whether this properties file can be appended to
|
|
@ -1,15 +0,0 @@
|
|||||||
diff --git a/openjdk/src/java.smartcardio/unix/classes/sun/security/smartcardio/PlatformPCSC.java b/src/java.smartcardio/unix/classes/sun/security/smartcardio/PlatformPCSC.java
|
|
||||||
index bacff32efbc..ff7b3dcc81c 100644
|
|
||||||
--- openjdk/src/java.smartcardio/unix/classes/sun/security/smartcardio/PlatformPCSC.java
|
|
||||||
+++ openjdk/src/java.smartcardio/unix/classes/sun/security/smartcardio/PlatformPCSC.java
|
|
||||||
@@ -46,8 +46,8 @@ class PlatformPCSC {
|
|
||||||
|
|
||||||
private static final String PROP_NAME = "sun.security.smartcardio.library";
|
|
||||||
|
|
||||||
- private static final String LIB1 = "/usr/$LIBISA/libpcsclite.so";
|
|
||||||
- private static final String LIB2 = "/usr/local/$LIBISA/libpcsclite.so";
|
|
||||||
+ private static final String LIB1 = "/usr/$LIBISA/libpcsclite.so.1";
|
|
||||||
+ private static final String LIB2 = "/usr/local/$LIBISA/libpcsclite.so.1";
|
|
||||||
private static final String PCSC_FRAMEWORK = "/System/Library/Frameworks/PCSC.framework/Versions/Current/PCSC";
|
|
||||||
|
|
||||||
PlatformPCSC() {
|
|
@ -1,117 +0,0 @@
|
|||||||
diff --git openjdk.orig/make/modules/java.base/Launcher.gmk openjdk/make/modules/java.base/Launcher.gmk
|
|
||||||
index 700ddefda49..2882de68eb2 100644
|
|
||||||
--- openjdk.orig/make/modules/java.base/Launcher.gmk
|
|
||||||
+++ openjdk/make/modules/java.base/Launcher.gmk
|
|
||||||
@@ -41,6 +41,14 @@ $(eval $(call SetupBuildLauncher, java, \
|
|
||||||
OPTIMIZATION := HIGH, \
|
|
||||||
))
|
|
||||||
|
|
||||||
+#Wno-error=cpp is present to allow commented warning in ifdef part of main.c
|
|
||||||
+$(eval $(call SetupBuildLauncher, alt-java, \
|
|
||||||
+ CFLAGS := -DEXPAND_CLASSPATH_WILDCARDS -DENABLE_ARG_FILES -DREDHAT_ALT_JAVA -Wno-error=cpp, \
|
|
||||||
+ EXTRA_RCFLAGS := $(JAVA_RCFLAGS), \
|
|
||||||
+ VERSION_INFO_RESOURCE := $(JAVA_VERSION_INFO_RESOURCE), \
|
|
||||||
+ OPTIMIZATION := HIGH, \
|
|
||||||
+))
|
|
||||||
+
|
|
||||||
ifeq ($(call isTargetOs, windows), true)
|
|
||||||
$(eval $(call SetupBuildLauncher, javaw, \
|
|
||||||
CFLAGS := -DJAVAW -DEXPAND_CLASSPATH_WILDCARDS -DENABLE_ARG_FILES, \
|
|
||||||
diff --git openjdk.orig/src/java.base/share/native/launcher/alt_main.h openjdk/src/java.base/share/native/launcher/alt_main.h
|
|
||||||
new file mode 100644
|
|
||||||
index 00000000000..697df2898ac
|
|
||||||
--- /dev/null
|
|
||||||
+++ openjdk/src/java.base/share/native/launcher/alt_main.h
|
|
||||||
@@ -0,0 +1,73 @@
|
|
||||||
+/*
|
|
||||||
+ * Copyright (c) 2019, Red Hat, Inc. All rights reserved.
|
|
||||||
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
|
||||||
+ *
|
|
||||||
+ * This code is free software; you can redistribute it and/or modify it
|
|
||||||
+ * under the terms of the GNU General Public License version 2 only, as
|
|
||||||
+ * published by the Free Software Foundation. Oracle designates this
|
|
||||||
+ * particular file as subject to the "Classpath" exception as provided
|
|
||||||
+ * by Oracle in the LICENSE file that accompanied this code.
|
|
||||||
+ *
|
|
||||||
+ * This code is distributed in the hope that it will be useful, but WITHOUT
|
|
||||||
+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
|
||||||
+ * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
|
|
||||||
+ * version 2 for more details (a copy is included in the LICENSE file that
|
|
||||||
+ * accompanied this code).
|
|
||||||
+ *
|
|
||||||
+ * You should have received a copy of the GNU General Public License version
|
|
||||||
+ * 2 along with this work; if not, write to the Free Software Foundation,
|
|
||||||
+ * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
|
|
||||||
+ *
|
|
||||||
+ * Please contact Oracle, 500 Oracle Parkway, Redwood Shores, CA 94065 USA
|
|
||||||
+ * or visit www.oracle.com if you need additional information or have any
|
|
||||||
+ * questions.
|
|
||||||
+ */
|
|
||||||
+
|
|
||||||
+#ifdef REDHAT_ALT_JAVA
|
|
||||||
+
|
|
||||||
+#include <sys/prctl.h>
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+/* Per task speculation control */
|
|
||||||
+#ifndef PR_GET_SPECULATION_CTRL
|
|
||||||
+# define PR_GET_SPECULATION_CTRL 52
|
|
||||||
+#endif
|
|
||||||
+#ifndef PR_SET_SPECULATION_CTRL
|
|
||||||
+# define PR_SET_SPECULATION_CTRL 53
|
|
||||||
+#endif
|
|
||||||
+/* Speculation control variants */
|
|
||||||
+#ifndef PR_SPEC_STORE_BYPASS
|
|
||||||
+# define PR_SPEC_STORE_BYPASS 0
|
|
||||||
+#endif
|
|
||||||
+/* Return and control values for PR_SET/GET_SPECULATION_CTRL */
|
|
||||||
+
|
|
||||||
+#ifndef PR_SPEC_NOT_AFFECTED
|
|
||||||
+# define PR_SPEC_NOT_AFFECTED 0
|
|
||||||
+#endif
|
|
||||||
+#ifndef PR_SPEC_PRCTL
|
|
||||||
+# define PR_SPEC_PRCTL (1UL << 0)
|
|
||||||
+#endif
|
|
||||||
+#ifndef PR_SPEC_ENABLE
|
|
||||||
+# define PR_SPEC_ENABLE (1UL << 1)
|
|
||||||
+#endif
|
|
||||||
+#ifndef PR_SPEC_DISABLE
|
|
||||||
+# define PR_SPEC_DISABLE (1UL << 2)
|
|
||||||
+#endif
|
|
||||||
+#ifndef PR_SPEC_FORCE_DISABLE
|
|
||||||
+# define PR_SPEC_FORCE_DISABLE (1UL << 3)
|
|
||||||
+#endif
|
|
||||||
+#ifndef PR_SPEC_DISABLE_NOEXEC
|
|
||||||
+# define PR_SPEC_DISABLE_NOEXEC (1UL << 4)
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+static void set_speculation() __attribute__((constructor));
|
|
||||||
+static void set_speculation() {
|
|
||||||
+ if ( prctl(PR_SET_SPECULATION_CTRL,
|
|
||||||
+ PR_SPEC_STORE_BYPASS,
|
|
||||||
+ PR_SPEC_DISABLE_NOEXEC, 0, 0) == 0 ) {
|
|
||||||
+ return;
|
|
||||||
+ }
|
|
||||||
+ prctl(PR_SET_SPECULATION_CTRL, PR_SPEC_STORE_BYPASS, PR_SPEC_DISABLE, 0, 0);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+#endif // REDHAT_ALT_JAVA
|
|
||||||
diff --git openjdk.orig/src/java.base/share/native/launcher/main.c openjdk/src/java.base/share/native/launcher/main.c
|
|
||||||
index b734fe2ba78..79dc8307650 100644
|
|
||||||
--- openjdk.orig/src/java.base/share/native/launcher/main.c
|
|
||||||
+++ openjdk/src/java.base/share/native/launcher/main.c
|
|
||||||
@@ -34,6 +34,14 @@
|
|
||||||
#include "jli_util.h"
|
|
||||||
#include "jni.h"
|
|
||||||
|
|
||||||
+#ifdef REDHAT_ALT_JAVA
|
|
||||||
+#if defined(__linux__) && defined(__x86_64__)
|
|
||||||
+#include "alt_main.h"
|
|
||||||
+#else
|
|
||||||
+#warning alt-java requested but SSB mitigation not available on this platform.
|
|
||||||
+#endif
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
/*
|
|
||||||
* Entry point.
|
|
||||||
*/
|
|
@ -1,19 +0,0 @@
|
|||||||
Remove uses of FAR in jpeg code
|
|
||||||
|
|
||||||
Upstream libjpeg-trubo removed the (empty) FAR macro:
|
|
||||||
http://sourceforge.net/p/libjpeg-turbo/code/1312/
|
|
||||||
|
|
||||||
Adjust our code to not use the undefined FAR macro anymore.
|
|
||||||
|
|
||||||
diff --git a/jdk/src/java.desktop/share/native/libjavajpeg/imageioJPEG.c b/jdk/src/java.desktop/share/native/libjavajpeg/imageioJPEG.c
|
|
||||||
--- openjdk/src/java.desktop/share/native/libjavajpeg/imageioJPEG.c
|
|
||||||
+++ openjdk/src/java.desktop/share/native/libjavajpeg/imageioJPEG.c
|
|
||||||
@@ -1385,7 +1385,7 @@
|
|
||||||
/* and fill it in */
|
|
||||||
dst_ptr = icc_data;
|
|
||||||
for (seq_no = first; seq_no < last; seq_no++) {
|
|
||||||
- JOCTET FAR *src_ptr = icc_markers[seq_no]->data + ICC_OVERHEAD_LEN;
|
|
||||||
+ JOCTET *src_ptr = icc_markers[seq_no]->data + ICC_OVERHEAD_LEN;
|
|
||||||
unsigned int length =
|
|
||||||
icc_markers[seq_no]->data_length - ICC_OVERHEAD_LEN;
|
|
||||||
|
|
Loading…
Reference in new issue