i8
changed/i8/java-11-openjdk-portable-11.0.23.0.9-2.el8
parent
faffa2f13c
commit
2a018b9dc4
@ -1,2 +1,2 @@
|
|||||||
SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
||||||
SOURCES/openjdk-jdk11u-jdk-11.0.22+7.tar.xz
|
SOURCES/openjdk-jdk11u-jdk-11.0.23+9.tar.xz
|
||||||
|
@ -1,2 +1,2 @@
|
|||||||
c8281ee37b77d535c9c1af86609a531958ff7b34 SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
c8281ee37b77d535c9c1af86609a531958ff7b34 SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
||||||
7694237019564cbd5568e24ffae9754308d13b29 SOURCES/openjdk-jdk11u-jdk-11.0.22+7.tar.xz
|
db99bc0a0912f824db1043d18b199c154d57bb5b SOURCES/openjdk-jdk11u-jdk-11.0.23+9.tar.xz
|
||||||
|
@ -1,39 +0,0 @@
|
|||||||
OpenJDK 11 is a Long-Term Support (LTS) release of the Java platform.
|
|
||||||
|
|
||||||
For a list of major changes from OpenJDK 8 (java-1.8.0-openjdk), see
|
|
||||||
the upstream release page for OpenJDK 11 and the preceding interim
|
|
||||||
releases:
|
|
||||||
|
|
||||||
* 9: https://openjdk.org/projects/jdk9/
|
|
||||||
* 10: https://openjdk.java.net/projects/jdk/10/
|
|
||||||
* 11: https://openjdk.java.net/projects/jdk/11/
|
|
||||||
|
|
||||||
# Rebuilding the OpenJDK package
|
|
||||||
|
|
||||||
The OpenJDK packages are now created from a single build which is then
|
|
||||||
packaged for different major versions of Red Hat Enterprise Linux
|
|
||||||
(RHEL). This allows the OpenJDK team to focus their efforts on the
|
|
||||||
development and testing of this single build, rather than having
|
|
||||||
multiple builds which only differ by the platform they were built on.
|
|
||||||
|
|
||||||
This does make rebuilding the package slightly more complicated than a
|
|
||||||
normal package. Modifications should be made to the
|
|
||||||
`java-11-openjdk-portable.specfile` file, which can be found with this
|
|
||||||
README file in the source RPM or installed in the documentation tree
|
|
||||||
by the `java-11-openjdk-headless` RPM.
|
|
||||||
|
|
||||||
Once the modified `java-11-openjdk-portable` RPMs are built, they
|
|
||||||
should be installed and will produce a number of tarballs in the
|
|
||||||
`/usr/lib/jvm` directory. The `java-11-openjdk` RPMs can then be
|
|
||||||
built, which will use these tarballs to create the usual RPMs found in
|
|
||||||
RHEL. The `java-11-openjdk-portable` RPMs can be uninstalled once the
|
|
||||||
desired final RPMs are produced.
|
|
||||||
|
|
||||||
Note that the `java-11-openjdk.spec` file has a hard requirement on
|
|
||||||
the exact version of java-11-openjdk-portable to use, so this will
|
|
||||||
need to be modified if the version or rpmrelease values are changed in
|
|
||||||
`java-11-openjdk-portable.specfile`.
|
|
||||||
|
|
||||||
To reduce the number of RPMs involved, the `fastdebug` and `slowdebug`
|
|
||||||
builds may be disabled using `--without fastdebug` and `--without
|
|
||||||
slowdebug`.
|
|
File diff suppressed because it is too large
Load Diff
@ -1,10 +0,0 @@
|
|||||||
[Desktop Entry]
|
|
||||||
Name=OpenJDK @JAVA_VER@ for @target_cpu@ Monitoring & Management Console (@OPENJDK_VER@)
|
|
||||||
Comment=Monitor and manage OpenJDK applications
|
|
||||||
Exec=_SDKBINDIR_/jconsole
|
|
||||||
Icon=java-@JAVA_VER@-@JAVA_VENDOR@
|
|
||||||
Terminal=false
|
|
||||||
Type=Application
|
|
||||||
StartupWMClass=sun-tools-jconsole-JConsole
|
|
||||||
Categories=Development;Profiling;Java;
|
|
||||||
Version=1.0
|
|
@ -1,50 +0,0 @@
|
|||||||
commit 50074a04e62f91faa080b831d9ce343396ead252
|
|
||||||
Author: Andrew John Hughes <andrew@openjdk.org>
|
|
||||||
Date: Tue Sep 5 20:48:42 2023 +0000
|
|
||||||
|
|
||||||
8312489: Increase jdk.jar.maxSignatureFileSize default which is too low for JARs such as WhiteSource/Mend unified agent jar
|
|
||||||
|
|
||||||
Backport-of: e47a84f23dd2608c6f5748093eefe301fb5bf750
|
|
||||||
|
|
||||||
diff --git a/src/java.base/share/classes/java/util/jar/JarFile.java b/src/java.base/share/classes/java/util/jar/JarFile.java
|
|
||||||
index cb7e308e0d..cce897c0d3 100644
|
|
||||||
--- a/src/java.base/share/classes/java/util/jar/JarFile.java
|
|
||||||
+++ b/src/java.base/share/classes/java/util/jar/JarFile.java
|
|
||||||
@@ -809,7 +809,9 @@ class JarFile extends ZipFile {
|
|
||||||
throw new IOException("Unsupported size: " + uncompressedSize +
|
|
||||||
" for JarEntry " + ze.getName() +
|
|
||||||
". Allowed max size: " +
|
|
||||||
- SignatureFileVerifier.MAX_SIG_FILE_SIZE + " bytes");
|
|
||||||
+ SignatureFileVerifier.MAX_SIG_FILE_SIZE + " bytes. " +
|
|
||||||
+ "You can use the jdk.jar.maxSignatureFileSize " +
|
|
||||||
+ "system property to increase the default value.");
|
|
||||||
}
|
|
||||||
int len = (int)uncompressedSize;
|
|
||||||
int bytesRead;
|
|
||||||
diff --git a/src/java.base/share/classes/sun/security/util/SignatureFileVerifier.java b/src/java.base/share/classes/sun/security/util/SignatureFileVerifier.java
|
|
||||||
index cb477fc134..a766b8249f 100644
|
|
||||||
--- a/src/java.base/share/classes/sun/security/util/SignatureFileVerifier.java
|
|
||||||
+++ b/src/java.base/share/classes/sun/security/util/SignatureFileVerifier.java
|
|
||||||
@@ -852,16 +852,16 @@ public class SignatureFileVerifier {
|
|
||||||
* the maximum allowed number of bytes for the signature-related files
|
|
||||||
* in a JAR file.
|
|
||||||
*/
|
|
||||||
- Integer tmp = GetIntegerAction.privilegedGetProperty(
|
|
||||||
- "jdk.jar.maxSignatureFileSize", 8000000);
|
|
||||||
+ int tmp = GetIntegerAction.privilegedGetProperty(
|
|
||||||
+ "jdk.jar.maxSignatureFileSize", 16000000);
|
|
||||||
if (tmp < 0 || tmp > MAX_ARRAY_SIZE) {
|
|
||||||
if (debug != null) {
|
|
||||||
- debug.println("Default signature file size 8000000 bytes " +
|
|
||||||
- "is used as the specified size for the " +
|
|
||||||
- "jdk.jar.maxSignatureFileSize system property " +
|
|
||||||
+ debug.println("The default signature file size of 16000000 bytes " +
|
|
||||||
+ "will be used for the jdk.jar.maxSignatureFileSize " +
|
|
||||||
+ "system property since the specified value " +
|
|
||||||
"is out of range: " + tmp);
|
|
||||||
}
|
|
||||||
- tmp = 8000000;
|
|
||||||
+ tmp = 16000000;
|
|
||||||
}
|
|
||||||
return tmp;
|
|
||||||
}
|
|
Loading…
Reference in new issue