parent
786bb43e85
commit
42336cd81d
@ -0,0 +1 @@
|
|||||||
|
/dekkers-libilbc-upstream-1.1.1-9-g88cd161.tar.gz
|
@ -0,0 +1,25 @@
|
|||||||
|
From ce97babde0629458ca6ef8cba278b933379053d0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||||
|
Date: Thu, 2 Aug 2012 14:08:02 +0400
|
||||||
|
Subject: [PATCH 1/3] Don't build silently
|
||||||
|
|
||||||
|
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||||
|
---
|
||||||
|
configure.ac | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index e19706f..1717034 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -5,7 +5,6 @@ AC_INIT([libilbc], [1.1.1], [])
|
||||||
|
AC_CONFIG_AUX_DIR(.)
|
||||||
|
AC_CONFIG_MACRO_DIR([m4])
|
||||||
|
AM_INIT_AUTOMAKE([tar-ustar dist-xz])
|
||||||
|
-m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
|
||||||
|
AC_CONFIG_HEADERS([config.h])
|
||||||
|
|
||||||
|
# Cross compiling support
|
||||||
|
--
|
||||||
|
1.7.11.2
|
||||||
|
|
@ -0,0 +1,26 @@
|
|||||||
|
From d4026f841ee2bef5faa6301f445f670f12434a4a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||||
|
Date: Thu, 2 Aug 2012 14:29:17 +0400
|
||||||
|
Subject: [PATCH 2/3] No dist-xz for EL5
|
||||||
|
|
||||||
|
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||||
|
---
|
||||||
|
configure.ac | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 1717034..30c38fc 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -4,7 +4,7 @@
|
||||||
|
AC_INIT([libilbc], [1.1.1], [])
|
||||||
|
AC_CONFIG_AUX_DIR(.)
|
||||||
|
AC_CONFIG_MACRO_DIR([m4])
|
||||||
|
-AM_INIT_AUTOMAKE([tar-ustar dist-xz])
|
||||||
|
+AM_INIT_AUTOMAKE([tar-ustar dist-bzip2 no-dist-gzip])
|
||||||
|
AC_CONFIG_HEADERS([config.h])
|
||||||
|
|
||||||
|
# Cross compiling support
|
||||||
|
--
|
||||||
|
1.7.11.2
|
||||||
|
|
@ -0,0 +1,28 @@
|
|||||||
|
From 6c707358b629691338e04403a9f53ab1b0aac7f8 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Lemenkov <lemenkov@gmail.com>
|
||||||
|
Date: Thu, 2 Aug 2012 14:38:18 +0400
|
||||||
|
Subject: [PATCH 3/3] Suppress warning about unused parameter(s)
|
||||||
|
|
||||||
|
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
|
||||||
|
---
|
||||||
|
signal_processing/filter_ar.c | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/signal_processing/filter_ar.c b/signal_processing/filter_ar.c
|
||||||
|
index 24e83a6..9228736 100644
|
||||||
|
--- a/signal_processing/filter_ar.c
|
||||||
|
+++ b/signal_processing/filter_ar.c
|
||||||
|
@@ -29,6 +29,10 @@ int WebRtcSpl_FilterAR(G_CONST WebRtc_Word16* a,
|
||||||
|
WebRtc_Word16* filtered_low,
|
||||||
|
int filtered_low_length)
|
||||||
|
{
|
||||||
|
+
|
||||||
|
+ (void) state_low_length;
|
||||||
|
+ (void) filtered_low_length;
|
||||||
|
+
|
||||||
|
WebRtc_Word32 o;
|
||||||
|
WebRtc_Word32 oLOW;
|
||||||
|
int i, j, stop;
|
||||||
|
--
|
||||||
|
1.7.11.2
|
||||||
|
|
@ -0,0 +1,106 @@
|
|||||||
|
Name: ilbc
|
||||||
|
Summary: Internet Low Bitrate Codec
|
||||||
|
Version: 1.1.1
|
||||||
|
Release: 3%{?dist}
|
||||||
|
License: BSD
|
||||||
|
Group: Development/Libraries
|
||||||
|
# wget --content-disposition https://github.com/dekkers/libilbc/tarball/88cd161
|
||||||
|
Source0: dekkers-libilbc-upstream-1.1.1-9-g88cd161.tar.gz
|
||||||
|
# Fedora/EPEL-specific
|
||||||
|
Patch1: %{name}-0001-Don-t-build-silently.patch
|
||||||
|
# Fedora/EPEL-specific
|
||||||
|
Patch2: %{name}-0002-No-dist-xz-for-EL5.patch
|
||||||
|
# Fedora/EPEL-specific
|
||||||
|
Patch3: ilbc-0003-Suppress-warning-about-unused-parameter-s.patch
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: automake
|
||||||
|
BuildRequires: libtool
|
||||||
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
|
|
||||||
|
%description
|
||||||
|
iLBC (internet Low Bitrate Codec) is a FREE speech codec suitable for
|
||||||
|
robust voice communication over IP. The codec is designed for narrow
|
||||||
|
band speech and results in a payload bit rate of 13.33 kbit/s with an
|
||||||
|
encoding frame length of 30 ms and 15.20 kbps with an encoding length
|
||||||
|
of 20 ms. The iLBC codec enables graceful speech quality degradation in
|
||||||
|
the case of lost frames, which occurs in connection with lost or
|
||||||
|
delayed IP packets.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: development files for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Additional header files for development with %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n dekkers-libilbc-88cd161
|
||||||
|
%patch1 -p1 -b .fedora_specific
|
||||||
|
%patch2 -p1 -b .epel5_specific
|
||||||
|
%patch3 -p1 -b .epel5_specific
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
autoreconf -ivf
|
||||||
|
%{configure} --disable-static --with-pic
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
make install DESTDIR=%{buildroot}
|
||||||
|
rm -f %{buildroot}%{_libdir}/libilbc.la
|
||||||
|
# Required for compatibility with a very old apps
|
||||||
|
cd %{buildroot}%{_libdir}/pkgconfig && ln -s libilbc.pc ilbc.pc
|
||||||
|
|
||||||
|
# Make compat symlinks
|
||||||
|
cd %{buildroot}%{_includedir}
|
||||||
|
ln -s ilbc.h iLBC_decode.h
|
||||||
|
ln -s ilbc.h iLBC_define.h
|
||||||
|
ln -s ilbc.h iLBC_encode.h
|
||||||
|
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc COPYING README
|
||||||
|
%{_libdir}/lib%{name}.so.*
|
||||||
|
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_includedir}/ilbc.h
|
||||||
|
# Compat symlinks
|
||||||
|
%{_includedir}/iLBC_decode.h
|
||||||
|
%{_includedir}/iLBC_define.h
|
||||||
|
%{_includedir}/iLBC_encode.h
|
||||||
|
%{_libdir}/pkgconfig/ilbc.pc
|
||||||
|
%{_libdir}/pkgconfig/libilbc.pc
|
||||||
|
%{_libdir}/lib%{name}.so
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Sep 12 2012 Peter Lemenkov <lemenkov@gmail.com> - 1.1.1-3
|
||||||
|
- Added licensing info
|
||||||
|
|
||||||
|
* Wed Aug 15 2012 Peter Lemenkov <lemenkov@gmail.com> - 1.1.1-2
|
||||||
|
- Add compat symlinks for old apps
|
||||||
|
|
||||||
|
* Wed May 9 2012 Peter Lemenkov <lemenkov@gmail.com> - 1.1.1-1
|
||||||
|
- Ver. 1.1.1
|
||||||
|
|
||||||
|
* Thu Oct 20 2011 Peter Lemenkov <lemenkov@gmail.com> - 0-0.1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue