- Update to 1.8.2

- Add patch to compile H5detect without optimization - make detection of
    datatype characteristics more robust - esp. long double
- Update signal patch
- Drop destdir patch fixed upstream
- Drop scaleoffset patch
- Re-add -fno-strict-aliasing
- Keep settings file needed for -showconfig (bug #481032)
- Wrapper script needs to pass arguments (bug #481032)
epel9
Orion Poplawski 16 years ago
parent 95418c4346
commit 5690b849c9

@ -1 +1 @@
hdf5-1.8.1.tar.gz hdf5-1.8.2.tar.gz

@ -7,4 +7,4 @@ case $ARCH in
* ) BITS=32;; * ) BITS=32;;
esac esac
exec $0-${BITS} exec $0-${BITS} "$@"

@ -1,61 +0,0 @@
--- hdf5-1.8.0/tools/misc/Makefile.in.destdir 2008-02-12 19:38:48.000000000 -0700
+++ hdf5-1.8.0/tools/misc/Makefile.in 2008-02-28 14:19:35.000000000 -0700
@@ -731,9 +731,9 @@
@$(top_srcdir)/bin/makehelp
install-exec-local:
- @$(INSTALL) h5cc $(bindir)/$(H5CC_NAME)
+ @$(INSTALL) h5cc $(DESTDIR)$(bindir)/$(H5CC_NAME)
uninstall-local:
- @$(RM) $(bindir)/$(H5CC_NAME)
+ @$(RM) $(DESTDIR)$(bindir)/$(H5CC_NAME)
# How to build h5redeploy script
h5redeploy: h5redeploy.in
--- hdf5-1.8.0/fortran/src/Makefile.in.destdir 2008-02-12 19:39:01.000000000 -0700
+++ hdf5-1.8.0/fortran/src/Makefile.in 2008-02-28 15:02:08.000000000 -0700
@@ -821,20 +821,20 @@
install-data-local:
@if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
- $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(includedir)/. ; \
+ $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(DESTDIR)$(includedir)/. ; \
fi
uninstall-local:
@if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
- if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(includedir)/HDF5.$(F9XMODEXT)"; then \
- set -x; $(RM) $(includedir)/*.$(F9XMODEXT); \
+ if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(DESTDIR)$(includedir)/HDF5.$(F9XMODEXT)"; then \
+ set -x; $(RM) $(DESTDIR)$(includedir)/*.$(F9XMODEXT); \
fi; \
fi; \
- $(RM) $(bindir)/$(H5FC_NAME)
+ $(RM) $(DESTDIR)$(bindir)/$(H5FC_NAME)
# Also install and uninstall (uninstall-local above) h5fc script
install-exec-local:
- @$(INSTALL) h5fc $(bindir)/$(H5FC_NAME)
+ @$(INSTALL) h5fc $(DESTDIR)$(bindir)/$(H5FC_NAME)
#Specify what Automake needs to create: first the H5fort_type_defines.h
# header, then H5match_types which includes that header, then
--- hdf5-1.8.0/hl/fortran/src/Makefile.in.destdir 2008-02-12 19:38:56.000000000 -0700
+++ hdf5-1.8.0/hl/fortran/src/Makefile.in 2008-02-28 15:26:42.000000000 -0700
@@ -681,13 +681,13 @@
install-data-local:
@if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
- $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(includedir)/. ; \
+ $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(DESTDIR)$(includedir)/. ; \
fi
uninstall-local:
@if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
- if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(includedir)/HDF5.$(F9XMODEXT)"; then \
- set -x; $(RM) $(includedir)/*.$(F9XMODEXT); \
+ if test -f "$(DESTDIR)$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(DESTDIR)$(includedir)/HDF5.$(F9XMODEXT)"; then \
+ set -x; $(RM) $(DESTDIR)$(includedir)/*.$(F9XMODEXT); \
fi; \
fi

@ -1,15 +0,0 @@
--- hdf5-1.8.0-snap5/test/dsets.c.scaleoffset 2008-05-01 18:27:56.000000000 -0600
+++ hdf5-1.8.0-snap5/test/dsets.c 2008-05-05 14:47:15.000000000 -0600
@@ -6458,10 +6458,11 @@
nerrors += (test_nbit_compound_3(file) < 0 ? 1 : 0);
nerrors += (test_scaleoffset_int(file) < 0 ? 1 : 0);
nerrors += (test_scaleoffset_int_2(file) < 0 ? 1 : 0);
+ /* fails
nerrors += (test_scaleoffset_float(file) < 0 ? 1 : 0);
nerrors += (test_scaleoffset_float_2(file) < 0 ? 1 : 0);
nerrors += (test_scaleoffset_double(file) < 0 ? 1 : 0);
- nerrors += (test_scaleoffset_double_2(file) < 0 ? 1 : 0);
+ nerrors += (test_scaleoffset_double_2(file) < 0 ? 1 : 0); */
nerrors += (test_multiopen (file) < 0 ? 1 : 0);
nerrors += (test_types(file) < 0 ? 1 : 0);
nerrors += (test_userblock_offset(my_fapl) < 0 ? 1 : 0);

@ -0,0 +1,43 @@
--- hdf5-1.8.2/src/Makefile.in.detect 2008-11-10 14:40:45.000000000 -0700
+++ hdf5-1.8.2/src/Makefile.in 2009-02-23 13:26:39.000000000 -0700
@@ -132,7 +132,7 @@
H5detect_OBJECTS = H5detect-H5detect.$(OBJEXT)
H5detect_LDADD = $(LDADD)
H5detect_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
- --mode=link $(CCLD) $(H5detect_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
+ --mode=link $(CCLD) $(CFLAGS) $(H5detect_CFLAGS) $(AM_LDFLAGS) \
$(LDFLAGS) -o $@
DEFAULT_INCLUDES = -I.@am__isrc@
depcomp = $(SHELL) $(top_srcdir)/bin/depcomp
@@ -408,7 +408,7 @@
LT_VERS_INTERFACE = 6
LT_VERS_REVISION = 1
LT_VERS_AGE = 0
-H5detect_CFLAGS = -g
+H5detect_CFLAGS = -g -O0
# Our main target, the HDF5 library
lib_LTLIBRARIES = libhdf5.la
@@ -860,18 +860,18 @@
@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<
H5detect-H5detect.o: H5detect.c
-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -MT H5detect-H5detect.o -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -MT H5detect-H5detect.o -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/H5detect-H5detect.Tpo $(DEPDIR)/H5detect-H5detect.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='H5detect.c' object='H5detect-H5detect.o' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
H5detect-H5detect.obj: H5detect.c
-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -MT H5detect-H5detect.obj -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -MT H5detect-H5detect.obj -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/H5detect-H5detect.Tpo $(DEPDIR)/H5detect-H5detect.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='H5detect.c' object='H5detect-H5detect.obj' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
mostlyclean-libtool:
-rm -f *.lo

@ -1,5 +1,5 @@
--- hdf5-1.8.0/src/H5detect.c.signal 2008-02-12 19:38:32.000000000 -0700 --- hdf5-1.8.2/src/H5detect.c.signal 2008-11-10 14:28:08.000000000 -0700
+++ hdf5-1.8.0/src/H5detect.c 2008-02-27 20:35:03.000000000 -0700 +++ hdf5-1.8.2/src/H5detect.c 2008-11-14 15:10:51.000000000 -0700
@@ -109,7 +109,7 @@ @@ -109,7 +109,7 @@
static void detect_C99_integers64(void); static void detect_C99_integers64(void);
static void detect_alignments(void); static void detect_alignments(void);
@ -9,7 +9,7 @@
/*------------------------------------------------------------------------- /*-------------------------------------------------------------------------
@@ -366,7 +366,7 @@ @@ -368,7 +368,7 @@
void (*_handler2)(int) = signal(SIGSEGV, sigsegv_handler); \ void (*_handler2)(int) = signal(SIGSEGV, sigsegv_handler); \
\ \
_buf = (char*)malloc(sizeof(TYPE) + align_g[NELMTS(align_g) - 1]); \ _buf = (char*)malloc(sizeof(TYPE) + align_g[NELMTS(align_g) - 1]); \
@ -18,7 +18,7 @@
if(_ano < NELMTS(align_g)) { \ if(_ano < NELMTS(align_g)) { \
*((TYPE*)(_buf+align_g[_ano])) = _val; /*possible SIGBUS or SEGSEGV*/ \ *((TYPE*)(_buf+align_g[_ano])) = _val; /*possible SIGBUS or SEGSEGV*/ \
_val2 = *((TYPE*)(_buf+align_g[_ano])); /*possible SIGBUS or SEGSEGV*/ \ _val2 = *((TYPE*)(_buf+align_g[_ano])); /*possible SIGBUS or SEGSEGV*/ \
@@ -383,7 +383,7 @@ @@ -385,7 +385,7 @@
memcpy(_buf+align_g[_ano]+(INFO.offset/8),((char *)&_val)+(INFO.offset/8),(size_t)(INFO.precision/8)); \ memcpy(_buf+align_g[_ano]+(INFO.offset/8),((char *)&_val)+(INFO.offset/8),(size_t)(INFO.precision/8)); \
_val2 = *((TYPE*)(_buf+align_g[_ano])); \ _val2 = *((TYPE*)(_buf+align_g[_ano])); \
if(_val!=_val2) \ if(_val!=_val2) \
@ -27,7 +27,7 @@
/* End Cray Check */ \ /* End Cray Check */ \
(INFO.align)=align_g[_ano]; \ (INFO.align)=align_g[_ano]; \
} else { \ } else { \
@@ -454,7 +454,7 @@ @@ -456,7 +456,7 @@
* it's not nearly as nice to work with, it does the job for * it's not nearly as nice to work with, it does the job for
* this simple stuff. * this simple stuff.
* *
@ -36,7 +36,7 @@
* *
* Programmer: Robb Matzke * Programmer: Robb Matzke
* Thursday, March 18, 1999 * Thursday, March 18, 1999
@@ -467,7 +467,7 @@ @@ -469,7 +469,7 @@
sigsegv_handler(int UNUSED signo) sigsegv_handler(int UNUSED signo)
{ {
signal(SIGSEGV, sigsegv_handler); signal(SIGSEGV, sigsegv_handler);
@ -45,7 +45,7 @@
} }
@@ -479,7 +479,7 @@ @@ -481,7 +481,7 @@
* it's not nearly as nice to work with, it does the job for * it's not nearly as nice to work with, it does the job for
* this simple stuff. * this simple stuff.
* *
@ -54,7 +54,7 @@
* *
* Programmer: Robb Matzke * Programmer: Robb Matzke
* Thursday, March 18, 1999 * Thursday, March 18, 1999
@@ -492,7 +492,7 @@ @@ -494,7 +494,7 @@
sigbus_handler(int UNUSED signo) sigbus_handler(int UNUSED signo)
{ {
signal(SIGBUS, sigbus_handler); signal(SIGBUS, sigbus_handler);

@ -1,6 +1,6 @@
Name: hdf5 Name: hdf5
Version: 1.8.1 Version: 1.8.2
Release: 3%{?dist} Release: 1%{?dist}
Summary: A general purpose library and file format for storing scientific data Summary: A general purpose library and file format for storing scientific data
License: BSD License: BSD
Group: System Environment/Libraries Group: System Environment/Libraries
@ -8,10 +8,9 @@ URL: http://www.hdfgroup.org/HDF5/
Source0: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.gz Source0: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.gz
#Source0: ftp://ftp.hdfgroup.uiuc.edu/pub/outgoing/hdf5/snapshots/v18/hdf5-1.8.1-rc1.tar.gz #Source0: ftp://ftp.hdfgroup.uiuc.edu/pub/outgoing/hdf5/snapshots/v18/hdf5-1.8.1-rc1.tar.gz
Source1: h5comp Source1: h5comp
Patch1: hdf5-1.8.0-signal.patch Patch1: hdf5-1.8.2-signal.patch
Patch2: hdf5-1.8.0-destdir.patch Patch2: hdf5-1.8.2-detect.patch
Patch3: hdf5-1.8.0-multiarch.patch Patch3: hdf5-1.8.0-multiarch.patch
Patch4: hdf5-1.8.0-scaleoffset.patch
Patch5: hdf5-1.8.0-longdouble.patch Patch5: hdf5-1.8.0-longdouble.patch
Patch6: hdf5-1.8.1-filter-as-option.patch Patch6: hdf5-1.8.1-filter-as-option.patch
Patch10: hdf5-1.6.5-open.patch Patch10: hdf5-1.6.5-open.patch
@ -49,9 +48,8 @@ HDF5 static libraries.
%prep %prep
%setup -q %setup -q
%patch1 -p1 -b .signal %patch1 -p1 -b .signal
%patch2 -p1 -b .destdir %patch2 -p1 -b .detect
%patch3 -p1 -b .multiarch %patch3 -p1 -b .multiarch
%patch4 -p1 -b .scaleoffset
%ifarch ppc64 %ifarch ppc64
%patch5 -p1 -b .longdouble %patch5 -p1 -b .longdouble
%endif %endif
@ -63,6 +61,7 @@ HDF5 static libraries.
export CC=gcc export CC=gcc
export CXX=g++ export CXX=g++
export F9X=gfortran export F9X=gfortran
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
# Must turn of production mode to preserve -g during compile # Must turn of production mode to preserve -g during compile
%configure --enable-production=no --enable-debug=no \ %configure --enable-production=no --enable-debug=no \
--enable-cxx --enable-fortran \ --enable-cxx --enable-fortran \
@ -81,7 +80,7 @@ make
%install %install
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
make install DESTDIR=${RPM_BUILD_ROOT} make install DESTDIR=${RPM_BUILD_ROOT}
rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la $RPM_BUILD_ROOT/%{_libdir}/*.settings rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
#Fortran modules #Fortran modules
mkdir -p ${RPM_BUILD_ROOT}%{_fmoddir} mkdir -p ${RPM_BUILD_ROOT}%{_fmoddir}
mv ${RPM_BUILD_ROOT}%{_includedir}/*.mod ${RPM_BUILD_ROOT}%{_fmoddir} mv ${RPM_BUILD_ROOT}%{_includedir}/*.mod ${RPM_BUILD_ROOT}%{_fmoddir}
@ -135,7 +134,6 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/h5jam %{_bindir}/h5jam
%{_bindir}/h5ls %{_bindir}/h5ls
%{_bindir}/h5mkgrp %{_bindir}/h5mkgrp
%{_bindir}/h5perf
%{_bindir}/h5perf_serial %{_bindir}/h5perf_serial
%{_bindir}/h5repack %{_bindir}/h5repack
%{_bindir}/h5repart %{_bindir}/h5repart
@ -154,6 +152,7 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/h5redeploy %{_bindir}/h5redeploy
%{_includedir}/*.h %{_includedir}/*.h
%{_libdir}/*.so %{_libdir}/*.so
%{_libdir}/*.settings
%{_fmoddir}/*.mod %{_fmoddir}/*.mod
%files static %files static
@ -162,6 +161,17 @@ rm -rf $RPM_BUILD_ROOT
%changelog %changelog
* Mon Feb 23 2009 Orion Poplawski <orion@cora.nwra.com> 1.8.2-1
- Update to 1.8.2
- Add patch to compile H5detect without optimization - make detection
of datatype characteristics more robust - esp. long double
- Update signal patch
- Drop destdir patch fixed upstream
- Drop scaleoffset patch
- Re-add -fno-strict-aliasing
- Keep settings file needed for -showconfig (bug #481032)
- Wrapper script needs to pass arguments (bug #481032)
* Wed Oct 8 2008 Orion Poplawski <orion@cora.nwra.com> 1.8.1-3 * Wed Oct 8 2008 Orion Poplawski <orion@cora.nwra.com> 1.8.1-3
- Add sparc64 to 64-bit conditionals - Add sparc64 to 64-bit conditionals

@ -1 +1 @@
193a4ea1a2b1c6d34bcb357db7d112a6 hdf5-1.8.1.tar.gz af92ef65ef495dbd205131574ad4eee1 hdf5-1.8.2.tar.gz

Loading…
Cancel
Save