- Rebase arm, ppc, and s390 patches - Add destdir, examplesdir patches to fix installation of examplesepel9
parent
21f0493147
commit
d0def9a165
@ -1,76 +0,0 @@
|
|||||||
diff -up hdf-4.2.9/hdf/src/df24ff.f.declaration hdf-4.2.9/hdf/src/df24ff.f
|
|
||||||
--- hdf-4.2.9/hdf/src/df24ff.f.declaration 2013-02-07 21:44:52.000000000 -0700
|
|
||||||
+++ hdf-4.2.9/hdf/src/df24ff.f 2013-02-15 16:48:08.490664851 -0700
|
|
||||||
@@ -117,7 +117,7 @@ C---------------------------------------
|
|
||||||
|
|
||||||
integer function d2rref(name, ref)
|
|
||||||
character*(*) name
|
|
||||||
- integer ref
|
|
||||||
+ integer ref, d2irref
|
|
||||||
|
|
||||||
d2rref = d2irref(name, ref, len(name))
|
|
||||||
return
|
|
||||||
@@ -136,6 +136,7 @@ C---------------------------------------
|
|
||||||
|
|
||||||
integer function d2nimg(name)
|
|
||||||
character*(*) name
|
|
||||||
+ integer d2inimg
|
|
||||||
|
|
||||||
d2nimg = d2inimg(name, len(name))
|
|
||||||
return
|
|
||||||
@@ -230,7 +231,7 @@ C---------------------------------------
|
|
||||||
|
|
||||||
integer function df24readref(name, ref)
|
|
||||||
character*(*) name
|
|
||||||
- integer ref
|
|
||||||
+ integer ref, d2irref
|
|
||||||
|
|
||||||
df24readref = d2irref(name, ref, len(name))
|
|
||||||
return
|
|
||||||
diff -up hdf-4.2.9/hdf/src/dfufp2iff.f.declaration hdf-4.2.9/hdf/src/dfufp2iff.f
|
|
||||||
--- hdf-4.2.9/hdf/src/dfufp2iff.f.declaration 2013-02-07 21:44:52.000000000 -0700
|
|
||||||
+++ hdf-4.2.9/hdf/src/dfufp2iff.f 2013-02-15 16:53:28.367159528 -0700
|
|
||||||
@@ -49,7 +49,7 @@ C---------------------------------------
|
|
||||||
real max, min, hscale, vscale, data
|
|
||||||
character*(*) palette
|
|
||||||
character*(*) outfile
|
|
||||||
- integer ctmethod, hres, vres, compress
|
|
||||||
+ integer ctmethod, hres, vres, compress, duif2i
|
|
||||||
|
|
||||||
duf2im = duif2i(hdim,vdim,max,min,hscale,vscale,data,palette,
|
|
||||||
* outfile,ctmethod,hres,vres,compress, len(outfile))
|
|
||||||
@@ -85,7 +85,7 @@ C---------------------------------------
|
|
||||||
real max, min, hscale, vscale, data
|
|
||||||
character*(*) palette
|
|
||||||
character*(*) outfile
|
|
||||||
- integer ctmethod, hres, vres, compress
|
|
||||||
+ integer ctmethod, hres, vres, compress, duif2i
|
|
||||||
|
|
||||||
dfufptoimage =
|
|
||||||
* duif2i(hdim,vdim,max,min,hscale,vscale,data,palette,
|
|
||||||
diff -up hdf-4.2.9/hdf/src/vg.c.declaration hdf-4.2.9/hdf/src/vg.c
|
|
||||||
--- hdf-4.2.9/hdf/src/vg.c.declaration 2013-02-07 21:44:52.000000000 -0700
|
|
||||||
+++ hdf-4.2.9/hdf/src/vg.c 2013-02-15 16:44:05.731947549 -0700
|
|
||||||
@@ -81,6 +81,7 @@ PRIVATE int32 matchnocase
|
|
||||||
(char *strx, char *stry);
|
|
||||||
#endif /* VDATA_FIELDS_ALL_UPPER */
|
|
||||||
|
|
||||||
+
|
|
||||||
#ifdef VDATA_FIELDS_ALL_UPPER
|
|
||||||
/*-----------------------------------------------------------------
|
|
||||||
NAME
|
|
||||||
@@ -116,6 +117,14 @@ matchnocase(char *strx, /* IN: first str
|
|
||||||
} /* matchnocase */
|
|
||||||
#endif /* VDATA_FIELDS_ALL_UPPER */
|
|
||||||
|
|
||||||
+/* Forward declarations */
|
|
||||||
+intn
|
|
||||||
+VSIgetvdatas(int32 id,
|
|
||||||
+ const char *vsclass,
|
|
||||||
+ const uintn start_vd,
|
|
||||||
+ const uintn n_vds,
|
|
||||||
+ uint16 *refarray);
|
|
||||||
+
|
|
||||||
/* ------------------------------------------------------------------
|
|
||||||
NAME
|
|
||||||
VSelts -- get number of elements in a vdata
|
|
@ -0,0 +1,66 @@
|
|||||||
|
diff -up hdf-4.2.10/config/examples.am.destdir hdf-4.2.10/config/examples.am
|
||||||
|
--- hdf-4.2.10/config/examples.am.destdir 2014-02-09 19:28:50.000000000 -0700
|
||||||
|
+++ hdf-4.2.10/config/examples.am 2014-02-14 10:02:35.039386643 -0700
|
||||||
|
@@ -45,7 +45,7 @@ CLEANFILES=$(EXAMPLE_PROG)
|
||||||
|
|
||||||
|
# How to create EXAMPLEDIR if it doesn't already exist
|
||||||
|
$(EXAMPLEDIR):
|
||||||
|
- mkdir -p $@
|
||||||
|
+ mkdir -p $(DESTDIR)$@
|
||||||
|
|
||||||
|
# Install and uninstall rules. We install the source files, not the
|
||||||
|
# example programs themselves.
|
||||||
|
@@ -57,39 +57,39 @@ uninstall-local:
|
||||||
|
install-examples: $(EXAMPLEDIR)
|
||||||
|
@for f in X $(INSTALL_FILES); do \
|
||||||
|
if test $$f != X; then \
|
||||||
|
- (set -x; $(INSTALL) $(srcdir)/$$f $(EXAMPLEDIR)/. || exit 1); \
|
||||||
|
- chmod a-x $(EXAMPLEDIR)/$$f; \
|
||||||
|
+ (set -x; $(INSTALL) $(srcdir)/$$f $(DESTDIR)$(EXAMPLEDIR)/. || exit 1); \
|
||||||
|
+ chmod a-x $(DESTDIR)$(EXAMPLEDIR)/$$f; \
|
||||||
|
fi; \
|
||||||
|
done
|
||||||
|
@for f in X $(INSTALL_SCRIPT_FILES); do \
|
||||||
|
if test $$f != X; then \
|
||||||
|
- (set -x; $(INSTALL) $(srcdir)/$$f $(EXAMPLEDIR)/. || exit 1); \
|
||||||
|
+ (set -x; $(INSTALL) $(srcdir)/$$f $(DESTDIR)$(EXAMPLEDIR)/. || exit 1); \
|
||||||
|
fi; \
|
||||||
|
done
|
||||||
|
@for f in X $(INSTALL_TOP_FILES); do \
|
||||||
|
if test $$f != X; then \
|
||||||
|
- (set -x; $(INSTALL) $(srcdir)/$$f $(EXAMPLETOPDIR)/. || exit 1); \
|
||||||
|
- chmod a-x $(EXAMPLETOPDIR)/$$f; \
|
||||||
|
+ (set -x; $(INSTALL) $(srcdir)/$$f $(DESTDIR)$(EXAMPLETOPDIR)/. || exit 1); \
|
||||||
|
+ chmod a-x $(DESTDIR)$(EXAMPLETOPDIR)/$$f; \
|
||||||
|
fi; \
|
||||||
|
done
|
||||||
|
@for f in X $(INSTALL_TOP_SCRIPT_FILES); do \
|
||||||
|
if test $$f != X; then \
|
||||||
|
- (set -x; $(INSTALL) $(srcdir)/$$f $(EXAMPLETOPDIR)/. || exit 1); \
|
||||||
|
+ (set -x; $(INSTALL) $(srcdir)/$$f $(DESTDIR)$(EXAMPLETOPDIR)/. || exit 1); \
|
||||||
|
fi; \
|
||||||
|
done
|
||||||
|
|
||||||
|
uninstall-examples:
|
||||||
|
- @if test -n "$(INSTALL_FILES)" -a -d $(EXAMPLEDIR); then \
|
||||||
|
- set -x; cd $(EXAMPLEDIR) && $(RM) $(INSTALL_FILES); \
|
||||||
|
+ @if test -n "$(INSTALL_FILES)" -a -d $(DESTDIR)$(EXAMPLEDIR); then \
|
||||||
|
+ set -x; cd $(DESTDIR)$(EXAMPLEDIR) && $(RM) $(INSTALL_FILES); \
|
||||||
|
fi
|
||||||
|
- @if test -n "$(INSTALL_SCRIPT_FILES)" -a -d $(EXAMPLEDIR); then \
|
||||||
|
- set -x; cd $(EXAMPLEDIR) && $(RM) $(INSTALL_SCRIPT_FILES); \
|
||||||
|
+ @if test -n "$(INSTALL_SCRIPT_FILES)" -a -d $(DESTDIR)$(EXAMPLEDIR); then \
|
||||||
|
+ set -x; cd $(DESTDIR)$(EXAMPLEDIR) && $(RM) $(INSTALL_SCRIPT_FILES); \
|
||||||
|
fi
|
||||||
|
- @if test -n "$(INSTALL_TOP_FILES)" -a -d $(EXAMPLETOPDIR); then \
|
||||||
|
- set -x; cd $(EXAMPLETOPDIR) && $(RM) $(INSTALL_TOP_FILES); \
|
||||||
|
+ @if test -n "$(INSTALL_TOP_FILES)" -a -d $(DESTDIR)$(EXAMPLETOPDIR); then \
|
||||||
|
+ set -x; cd $$(DESTDIR)(EXAMPLETOPDIR) && $(RM) $(INSTALL_TOP_FILES); \
|
||||||
|
fi
|
||||||
|
- @if test -n "$(INSTALL_TOP_SCRIPT_FILES)" -a -d $(EXAMPLETOPDIR); then \
|
||||||
|
- set -x; cd $(EXAMPLETOPDIR) && $(RM) $(INSTALL_TOP_SCRIPT_FILES); \
|
||||||
|
+ @if test -n "$(INSTALL_TOP_SCRIPT_FILES)" -a -d $(DESTDIR)$(EXAMPLETOPDIR); then \
|
||||||
|
+ set -x; cd $(DESTDIR)$(EXAMPLETOPDIR) && $(RM) $(INSTALL_TOP_SCRIPT_FILES); \
|
||||||
|
fi
|
||||||
|
|
||||||
|
installcheck-local:
|
@ -0,0 +1,50 @@
|
|||||||
|
diff -up hdf-4.2.10/hdf/examples/Makefile.am.examplesdir hdf-4.2.10/hdf/examples/Makefile.am
|
||||||
|
--- hdf-4.2.10/hdf/examples/Makefile.am.examplesdir 2014-02-09 19:28:50.000000000 -0700
|
||||||
|
+++ hdf-4.2.10/hdf/examples/Makefile.am 2014-02-14 10:10:17.854023687 -0700
|
||||||
|
@@ -46,8 +46,8 @@ INSTALL_TOP_SCRIPT_FILES = run-all-ex.sh
|
||||||
|
INSTALL_TOP_FILES = README
|
||||||
|
|
||||||
|
# Where to install example files
|
||||||
|
-EXAMPLEDIR=$(prefix)/examples/c
|
||||||
|
-EXAMPLETOPDIR=$(prefix)/examples
|
||||||
|
+EXAMPLEDIR=$(docdir)/examples/c
|
||||||
|
+EXAMPLETOPDIR=$(docdir)/examples
|
||||||
|
|
||||||
|
# How to build C programs using h4cc
|
||||||
|
$(EXTRA_PROG): $(H4CC)
|
||||||
|
diff -up hdf-4.2.10/hdf/fortran/examples/Makefile.am.examplesdir hdf-4.2.10/hdf/fortran/examples/Makefile.am
|
||||||
|
--- hdf-4.2.10/hdf/fortran/examples/Makefile.am.examplesdir 2014-02-09 19:28:49.000000000 -0700
|
||||||
|
+++ hdf-4.2.10/hdf/fortran/examples/Makefile.am 2014-02-14 10:10:30.082961395 -0700
|
||||||
|
@@ -41,7 +41,7 @@ INSTALL_FILES= VD_read_from_vdata.f VD_r
|
||||||
|
INSTALL_SCRIPT_FILES = run-fortran-ex.sh
|
||||||
|
|
||||||
|
# Where to install Fortran example files
|
||||||
|
-EXAMPLEDIR=$(prefix)/examples/fortran
|
||||||
|
+EXAMPLEDIR=$(docdir)/examples/fortran
|
||||||
|
|
||||||
|
# How to build Fortran programs using h4fc
|
||||||
|
$(EXTRA_PROG): $(H4FC)
|
||||||
|
diff -up hdf-4.2.10/mfhdf/examples/Makefile.am.examplesdir hdf-4.2.10/mfhdf/examples/Makefile.am
|
||||||
|
--- hdf-4.2.10/mfhdf/examples/Makefile.am.examplesdir 2014-02-09 19:28:45.000000000 -0700
|
||||||
|
+++ hdf-4.2.10/mfhdf/examples/Makefile.am 2014-02-14 10:09:41.465209051 -0700
|
||||||
|
@@ -23,7 +23,7 @@ INSTALL_FILES = SD_create_sds.c SD_write
|
||||||
|
SD_get_info.c SD_find_sds_by_name.c SD_set_get_dim_info.c \
|
||||||
|
SD_dimscale_vs_sds.c SD_set_attr.c SD_get_attr.c SD_chunking_example.c
|
||||||
|
|
||||||
|
-EXAMPLEDIR=$(prefix)/examples/c
|
||||||
|
+EXAMPLEDIR=$(docdir)/examples/c
|
||||||
|
|
||||||
|
# How to build programs using h4cc
|
||||||
|
$(EXTRA_PROG): $(H4CC)
|
||||||
|
diff -up hdf-4.2.10/mfhdf/fortran/examples/Makefile.am.examplesdir hdf-4.2.10/mfhdf/fortran/examples/Makefile.am
|
||||||
|
--- hdf-4.2.10/mfhdf/fortran/examples/Makefile.am.examplesdir 2014-02-09 19:28:44.000000000 -0700
|
||||||
|
+++ hdf-4.2.10/mfhdf/fortran/examples/Makefile.am 2014-02-14 10:09:52.818151212 -0700
|
||||||
|
@@ -24,7 +24,7 @@ INSTALL_FILES=SD_create_sds.f SD_write_t
|
||||||
|
SD_set_attr.f SD_get_attr.f SD_compress_sds.f SD_chunking_example.f
|
||||||
|
|
||||||
|
# Where to install example files
|
||||||
|
-EXAMPLEDIR=$(prefix)/examples/fortran
|
||||||
|
+EXAMPLEDIR=$(docdir)/examples/fortran
|
||||||
|
|
||||||
|
# How to build Fortran programs using h4fc
|
||||||
|
$(EXTRA_PROG): $(H4FC)
|
File diff suppressed because it is too large
Load Diff
@ -1,35 +0,0 @@
|
|||||||
diff -up hdf-4.2.9/hdf/test/sdmms.c.wrap hdf-4.2.9/hdf/test/sdmms.c
|
|
||||||
--- hdf-4.2.9/hdf/test/sdmms.c.wrap 2013-02-07 21:44:52.000000000 -0700
|
|
||||||
+++ hdf-4.2.9/hdf/test/sdmms.c 2013-02-16 20:33:39.118623828 -0700
|
|
||||||
@@ -63,9 +63,10 @@ static int32 ical5;
|
|
||||||
void
|
|
||||||
test_sdmms(void)
|
|
||||||
{
|
|
||||||
- int i, j, err, err1, err2, ret;
|
|
||||||
- intn rank;
|
|
||||||
- int32 dims[2];
|
|
||||||
+ uint32 i, j;
|
|
||||||
+ int err, err1, err2, ret;
|
|
||||||
+ intn rank;
|
|
||||||
+ int32 dims[2];
|
|
||||||
|
|
||||||
rank = 2;
|
|
||||||
dims[0] = 10;
|
|
||||||
@@ -87,7 +88,7 @@ test_sdmms(void)
|
|
||||||
ui16[i][j] = (uint16) ((i * 6000) + j); /* range: 0 ~ 60000 */
|
|
||||||
|
|
||||||
i32[i][j] = (int32) ((i * 60000) - 300000 + j); /* range: 0 ~ 2-billion */
|
|
||||||
- ui32[i][j] = (uint32) ((i * 400000000) + j); /* range: 0 ~ 4-billion */
|
|
||||||
+ ui32[i][j] = (uint32) ((i * 400000000U) + j); /* range: 0 ~ 4-billion */
|
|
||||||
}
|
|
||||||
|
|
||||||
f32scale[i] = (float32) ((i * 40) + j); /* range: 0 ~ 4-billion */
|
|
||||||
@@ -99,7 +100,7 @@ test_sdmms(void)
|
|
||||||
ui16scale[i] = (uint16) ((i * 6000) + j); /* range: 0 ~ 60000 */
|
|
||||||
|
|
||||||
i32scale[i] = (int32) ((i * 60000) - 300000 + j); /* range: 0 ~ 2-billion */
|
|
||||||
- ui32scale[i] = (uint32) ((i * 400000000) + j); /* range: 0 ~ 4-billion */
|
|
||||||
+ ui32scale[i] = (uint32) ((i * 400000000U) + j); /* range: 0 ~ 4-billion */
|
|
||||||
}
|
|
||||||
|
|
||||||
cal1 = (float64) 10.0;
|
|
Loading…
Reference in new issue