parent
0321d9f7f9
commit
1f3d6c7598
@ -1 +1,2 @@
|
||||
gst-plugins-bad-1.4.5.tar.xz
|
||||
gst-plugins-bad-1.6.1.tar.xz
|
||||
|
@ -1,35 +0,0 @@
|
||||
From bde0f119097117cf0256e450af4267a47782260b Mon Sep 17 00:00:00 2001
|
||||
From: Wim Taymans <wtaymans@redhat.com>
|
||||
Date: Wed, 13 May 2015 16:23:26 +0200
|
||||
Subject: fix faad2 version check
|
||||
|
||||
On fedora 22, the output of cpp inserts extra debug comments, which
|
||||
makes our regexp for the faad2 version check fail. This in turn causes
|
||||
it to compile with the wrong arguments passed which then causes stack
|
||||
corruption and crashes.
|
||||
|
||||
Fix this by only checking for the version (which should be by itself on
|
||||
a single line). This is potentially less safe, it might be possible that
|
||||
a similar string would appear in a later version in the header file.
|
||||
|
||||
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=748571
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 4e2823e..c56295e 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2050,9 +2050,9 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
|
||||
AC_MSG_CHECKING([Checking FAAD2 version in $faad_hdr])
|
||||
for minor in 10 9 8 7 6 5 0; do
|
||||
if test x$faad2_minor_version = "x"; then
|
||||
- AC_EGREP_CPP([GST_CHECK_FAAD_VERSION \"2\.$minor\"], [
|
||||
+ AC_EGREP_CPP([\"2\.$minor\"$], [
|
||||
#include <$faad_hdr>
|
||||
- GST_CHECK_FAAD_VERSION FAAD2_VERSION
|
||||
+ FAAD2_VERSION
|
||||
], [
|
||||
faad2_minor_version=$minor
|
||||
])
|
||||
--
|
||||
cgit v0.10.2
|
||||
|
Loading…
Reference in new issue