* Sat May 16 2015 Hans de Goede <j.w.r.degoede@gmail.com> - 1.4.5-2

- Add a patch from upstream fixing a faad2 crash which crashes firefox (rf3636)
el8
Hans de Goede 10 years ago
parent 73e5413dab
commit 0321d9f7f9

@ -0,0 +1,35 @@
From bde0f119097117cf0256e450af4267a47782260b Mon Sep 17 00:00:00 2001
From: Wim Taymans <wtaymans@redhat.com>
Date: Wed, 13 May 2015 16:23:26 +0200
Subject: fix faad2 version check
On fedora 22, the output of cpp inserts extra debug comments, which
makes our regexp for the faad2 version check fail. This in turn causes
it to compile with the wrong arguments passed which then causes stack
corruption and crashes.
Fix this by only checking for the version (which should be by itself on
a single line). This is potentially less safe, it might be possible that
a similar string would appear in a later version in the header file.
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=748571
diff --git a/configure.ac b/configure.ac
index 4e2823e..c56295e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2050,9 +2050,9 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
AC_MSG_CHECKING([Checking FAAD2 version in $faad_hdr])
for minor in 10 9 8 7 6 5 0; do
if test x$faad2_minor_version = "x"; then
- AC_EGREP_CPP([GST_CHECK_FAAD_VERSION \"2\.$minor\"], [
+ AC_EGREP_CPP([\"2\.$minor\"$], [
#include <$faad_hdr>
- GST_CHECK_FAAD_VERSION FAAD2_VERSION
+ FAAD2_VERSION
], [
faad2_minor_version=$minor
])
--
cgit v0.10.2

@ -5,11 +5,13 @@
Summary: GStreamer 1.0 streaming media framework "bad" plug-ins
Name: gstreamer1-plugins-bad-freeworld
Version: 1.4.5
Release: 1%{?dist}
Release: 2%{?dist}
License: LGPLv2+
Group: Applications/Multimedia
URL: http://gstreamer.freedesktop.org/
Source0: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
# From upstream git
Patch1: 0001-fix-faad2-version-check.patch
BuildRequires: gstreamer1-devel >= 1.4.0
BuildRequires: gstreamer1-plugins-base-devel >= 1.4.0
BuildRequires: check
@ -28,6 +30,8 @@ BuildRequires: vo-amrwbenc-devel
#BuildRequires: vo-aacenc-devel
BuildRequires: libmpg123-devel
BuildRequires: libusbx-devel
# For autoreconf
BuildRequires: libtool
%description
GStreamer is a streaming media framework, based on graphs of elements which
@ -39,6 +43,9 @@ well enough, or the code is not of good enough quality.
%prep
%setup -q -n gst-plugins-bad-%{version}
%patch1 -p1
# For patch1
autoreconf -ivf
%build
@ -91,6 +98,9 @@ rm $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/*.la
%changelog
* Sat May 16 2015 Hans de Goede <j.w.r.degoede@gmail.com> - 1.4.5-2
- Add a patch from upstream fixing a faad2 crash which crashes firefox (rf3636)
* Sat May 16 2015 Hans de Goede <j.w.r.degoede@gmail.com> - 1.4.5-1
- Rebase to new upstream release 1.4.5

Loading…
Cancel
Save