parent
5108de67f7
commit
d7c16ff76f
@ -1,2 +1,3 @@
|
||||
/grantlee-5.0.0.tar.gz
|
||||
/grantlee-5.1.0.tar.gz
|
||||
/grantlee-5.2.0.tar.gz
|
||||
|
@ -1,40 +0,0 @@
|
||||
diff -up grantlee-5.1.0/CMakeLists.txt.orig grantlee-5.1.0/CMakeLists.txt
|
||||
--- grantlee-5.1.0/CMakeLists.txt.orig 2016-04-19 01:33:17.000000000 -0500
|
||||
+++ grantlee-5.1.0/CMakeLists.txt 2016-04-19 06:44:06.371122149 -0500
|
||||
@@ -100,7 +100,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define
|
||||
set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
|
||||
set( PLUGIN_INSTALL_DIR ${LIB_INSTALL_DIR}/grantlee/${Grantlee5_MAJOR_MINOR_VERSION_STRING} )
|
||||
set( BIN_INSTALL_DIR bin )
|
||||
-set( INCLUDE_INSTALL_DIR include )
|
||||
+set( INCLUDE_INSTALL_DIR include/Grantlee5 )
|
||||
set( DATA_INSTALL_DIR share/apps )
|
||||
|
||||
# set up RPATH/install_name_dir
|
||||
diff -up grantlee-5.1.0/templates/lib/CMakeLists.txt.orig grantlee-5.1.0/templates/lib/CMakeLists.txt
|
||||
--- grantlee-5.1.0/templates/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
|
||||
+++ grantlee-5.1.0/templates/lib/CMakeLists.txt 2016-04-19 06:44:55.763336264 -0500
|
||||
@@ -107,6 +107,10 @@ if (Qt5Script_FOUND)
|
||||
|
||||
target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
|
||||
target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
|
||||
+ target_include_directories(Grantlee_Templates
|
||||
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
|
||||
+ )
|
||||
+
|
||||
target_link_libraries(Grantlee_Templates
|
||||
LINK_PRIVATE Qt5::Script
|
||||
)
|
||||
diff -up grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig grantlee-5.1.0/textdocument/lib/CMakeLists.txt
|
||||
--- grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
|
||||
+++ grantlee-5.1.0/textdocument/lib/CMakeLists.txt 2016-04-19 06:45:56.268598553 -0500
|
||||
@@ -43,6 +43,10 @@ if (CMAKE_GENERATOR MATCHES "Visual Stud
|
||||
endforeach()
|
||||
endif()
|
||||
|
||||
+target_include_directories(Grantlee_TextDocument
|
||||
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
|
||||
+)
|
||||
+
|
||||
target_link_libraries(Grantlee_TextDocument
|
||||
LINK_PUBLIC Qt5::Gui
|
||||
)
|
@ -0,0 +1,82 @@
|
||||
From 2ce2cb510a39ee42619745a98b14e32744d1bf75 Mon Sep 17 00:00:00 2001
|
||||
From: Troy Dawson <tdawson@redhat.com>
|
||||
Date: Tue, 28 Jan 2020 13:19:10 -0800
|
||||
Subject: [PATCH] install headers into versioned directory
|
||||
|
||||
---
|
||||
CMakeLists.txt | 1 +
|
||||
templates/lib/CMakeLists.txt | 8 ++++++--
|
||||
textdocument/lib/CMakeLists.txt | 8 ++++++--
|
||||
3 files changed, 13 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 20edcdc..8df3dd6 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -80,6 +80,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define suffix of library directory name (eg. '6
|
||||
|
||||
set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
|
||||
set( PLUGIN_INSTALL_DIR ${LIB_INSTALL_DIR}/grantlee/${Grantlee5_MAJOR_MINOR_VERSION_STRING} )
|
||||
+set( INCLUDE_INSTALL_DIR include/Grantlee5 )
|
||||
|
||||
# set up RPATH/install_name_dir
|
||||
set( CMAKE_INSTALL_NAME_DIR ${CMAKE_INSTALL_PREFIX}/${LIB_INSTALL_DIR})
|
||||
diff --git a/templates/lib/CMakeLists.txt b/templates/lib/CMakeLists.txt
|
||||
index 5058481..ec1fd3a 100644
|
||||
--- a/templates/lib/CMakeLists.txt
|
||||
+++ b/templates/lib/CMakeLists.txt
|
||||
@@ -101,6 +101,10 @@ if (Qt5Qml_FOUND)
|
||||
|
||||
target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
|
||||
target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
|
||||
+ target_include_directories(Grantlee_Templates
|
||||
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
|
||||
+ )
|
||||
+
|
||||
target_link_libraries(Grantlee_Templates
|
||||
PRIVATE Qt5::Qml
|
||||
)
|
||||
@@ -152,10 +156,10 @@ install(FILES
|
||||
token.h
|
||||
util.h
|
||||
variable.h
|
||||
- DESTINATION include/grantlee COMPONENT Templates
|
||||
+ DESTINATION ${INCLUDE_INSTALL_DIR}/grantlee COMPONENT Templates
|
||||
)
|
||||
|
||||
install(FILES
|
||||
grantlee_templates.h
|
||||
- DESTINATION include COMPONENT Templates
|
||||
+ DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT Templates
|
||||
)
|
||||
diff --git a/textdocument/lib/CMakeLists.txt b/textdocument/lib/CMakeLists.txt
|
||||
index 2c5a96f..bf56052 100644
|
||||
--- a/textdocument/lib/CMakeLists.txt
|
||||
+++ b/textdocument/lib/CMakeLists.txt
|
||||
@@ -35,6 +35,10 @@ if (CMAKE_GENERATOR MATCHES "Visual Studio")
|
||||
endforeach()
|
||||
endif()
|
||||
|
||||
+target_include_directories(Grantlee_TextDocument
|
||||
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
|
||||
+)
|
||||
+
|
||||
target_link_libraries(Grantlee_TextDocument
|
||||
PUBLIC Qt5::Gui
|
||||
)
|
||||
@@ -59,10 +63,10 @@ install(FILES
|
||||
texthtmlbuilder.h
|
||||
mediawikimarkupbuilder.h
|
||||
${CMAKE_CURRENT_BINARY_DIR}/grantlee_textdocument_export.h
|
||||
- DESTINATION include/grantlee COMPONENT TextDocument
|
||||
+ DESTINATION ${INCLUDE_INSTALL_DIR}/grantlee COMPONENT TextDocument
|
||||
)
|
||||
|
||||
install(FILES
|
||||
grantlee_textdocument.h
|
||||
- DESTINATION include COMPONENT TextDocument
|
||||
+ DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT TextDocument
|
||||
)
|
||||
--
|
||||
2.24.1
|
||||
|
Loading…
Reference in new issue