Update to 5.2.0

epel9
Troy Dawson 5 years ago
parent 5108de67f7
commit d7c16ff76f

1
.gitignore vendored

@ -1,2 +1,3 @@
/grantlee-5.0.0.tar.gz /grantlee-5.0.0.tar.gz
/grantlee-5.1.0.tar.gz /grantlee-5.1.0.tar.gz
/grantlee-5.2.0.tar.gz

@ -1,40 +0,0 @@
diff -up grantlee-5.1.0/CMakeLists.txt.orig grantlee-5.1.0/CMakeLists.txt
--- grantlee-5.1.0/CMakeLists.txt.orig 2016-04-19 01:33:17.000000000 -0500
+++ grantlee-5.1.0/CMakeLists.txt 2016-04-19 06:44:06.371122149 -0500
@@ -100,7 +100,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define
set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
set( PLUGIN_INSTALL_DIR ${LIB_INSTALL_DIR}/grantlee/${Grantlee5_MAJOR_MINOR_VERSION_STRING} )
set( BIN_INSTALL_DIR bin )
-set( INCLUDE_INSTALL_DIR include )
+set( INCLUDE_INSTALL_DIR include/Grantlee5 )
set( DATA_INSTALL_DIR share/apps )
# set up RPATH/install_name_dir
diff -up grantlee-5.1.0/templates/lib/CMakeLists.txt.orig grantlee-5.1.0/templates/lib/CMakeLists.txt
--- grantlee-5.1.0/templates/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
+++ grantlee-5.1.0/templates/lib/CMakeLists.txt 2016-04-19 06:44:55.763336264 -0500
@@ -107,6 +107,10 @@ if (Qt5Script_FOUND)
target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
+ target_include_directories(Grantlee_Templates
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
+ )
+
target_link_libraries(Grantlee_Templates
LINK_PRIVATE Qt5::Script
)
diff -up grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig grantlee-5.1.0/textdocument/lib/CMakeLists.txt
--- grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
+++ grantlee-5.1.0/textdocument/lib/CMakeLists.txt 2016-04-19 06:45:56.268598553 -0500
@@ -43,6 +43,10 @@ if (CMAKE_GENERATOR MATCHES "Visual Stud
endforeach()
endif()
+target_include_directories(Grantlee_TextDocument
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
+)
+
target_link_libraries(Grantlee_TextDocument
LINK_PUBLIC Qt5::Gui
)

@ -0,0 +1,82 @@
From 2ce2cb510a39ee42619745a98b14e32744d1bf75 Mon Sep 17 00:00:00 2001
From: Troy Dawson <tdawson@redhat.com>
Date: Tue, 28 Jan 2020 13:19:10 -0800
Subject: [PATCH] install headers into versioned directory
---
CMakeLists.txt | 1 +
templates/lib/CMakeLists.txt | 8 ++++++--
textdocument/lib/CMakeLists.txt | 8 ++++++--
3 files changed, 13 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 20edcdc..8df3dd6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,6 +80,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define suffix of library directory name (eg. '6
set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
set( PLUGIN_INSTALL_DIR ${LIB_INSTALL_DIR}/grantlee/${Grantlee5_MAJOR_MINOR_VERSION_STRING} )
+set( INCLUDE_INSTALL_DIR include/Grantlee5 )
# set up RPATH/install_name_dir
set( CMAKE_INSTALL_NAME_DIR ${CMAKE_INSTALL_PREFIX}/${LIB_INSTALL_DIR})
diff --git a/templates/lib/CMakeLists.txt b/templates/lib/CMakeLists.txt
index 5058481..ec1fd3a 100644
--- a/templates/lib/CMakeLists.txt
+++ b/templates/lib/CMakeLists.txt
@@ -101,6 +101,10 @@ if (Qt5Qml_FOUND)
target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
+ target_include_directories(Grantlee_Templates
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
+ )
+
target_link_libraries(Grantlee_Templates
PRIVATE Qt5::Qml
)
@@ -152,10 +156,10 @@ install(FILES
token.h
util.h
variable.h
- DESTINATION include/grantlee COMPONENT Templates
+ DESTINATION ${INCLUDE_INSTALL_DIR}/grantlee COMPONENT Templates
)
install(FILES
grantlee_templates.h
- DESTINATION include COMPONENT Templates
+ DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT Templates
)
diff --git a/textdocument/lib/CMakeLists.txt b/textdocument/lib/CMakeLists.txt
index 2c5a96f..bf56052 100644
--- a/textdocument/lib/CMakeLists.txt
+++ b/textdocument/lib/CMakeLists.txt
@@ -35,6 +35,10 @@ if (CMAKE_GENERATOR MATCHES "Visual Studio")
endforeach()
endif()
+target_include_directories(Grantlee_TextDocument
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
+)
+
target_link_libraries(Grantlee_TextDocument
PUBLIC Qt5::Gui
)
@@ -59,10 +63,10 @@ install(FILES
texthtmlbuilder.h
mediawikimarkupbuilder.h
${CMAKE_CURRENT_BINARY_DIR}/grantlee_textdocument_export.h
- DESTINATION include/grantlee COMPONENT TextDocument
+ DESTINATION ${INCLUDE_INSTALL_DIR}/grantlee COMPONENT TextDocument
)
install(FILES
grantlee_textdocument.h
- DESTINATION include COMPONENT TextDocument
+ DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT TextDocument
)
--
2.24.1

@ -3,8 +3,8 @@
Name: grantlee-qt5 Name: grantlee-qt5
Summary: Qt5 string template engine based on the Django template system Summary: Qt5 string template engine based on the Django template system
Version: 5.1.0 Version: 5.2.0
Release: 12%{?dist} Release: 1%{?dist}
License: LGPLv2+ License: LGPLv2+
URL: https://github.com/steveire/grantlee URL: https://github.com/steveire/grantlee
@ -12,7 +12,7 @@ Source0: http://downloads.grantlee.org/grantlee-%{version}%{?pre:-%{pre}}.tar.gz
%global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d) %global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
Source1: macros.grantlee5 Source1: macros.grantlee5
%global grantlee5_plugins 5.1 %global grantlee5_plugins 5.2
%global grantlee5_plugindir %{_libdir}/grantlee/%{grantlee5_plugins}/ %global grantlee5_plugindir %{_libdir}/grantlee/%{grantlee5_plugins}/
Provides: %{name}(%{grantlee5_plugins}) = %{version}-%{release} Provides: %{name}(%{grantlee5_plugins}) = %{version}-%{release}
@ -20,7 +20,7 @@ Provides: %{name}(%{grantlee5_plugins}) = %{version}-%{release}
# Install headers into a versioned directory to be parallel-installable # Install headers into a versioned directory to be parallel-installable
# based on: # based on:
# https://github.com/steveire/grantlee/pull/1 # https://github.com/steveire/grantlee/pull/1
Patch1: grantlee-5.1.0-install_headers_into_versioned_directory.patch Patch1: grantlee-5.2.0-install_headers_into_versioned_directory.patch
BuildRequires: cmake >= 2.8.12 BuildRequires: cmake >= 2.8.12
BuildRequires: gcc-c++ BuildRequires: gcc-c++
@ -71,7 +71,6 @@ format for easy browsing.
%prep %prep
%autosetup -n grantlee-%{version} -p1 %autosetup -n grantlee-%{version} -p1
%build %build
mkdir %{_target_platform} mkdir %{_target_platform}
pushd %{_target_platform} pushd %{_target_platform}
@ -136,6 +135,9 @@ xvfb-run -a make test -C %{_target_platform} ||:
%changelog %changelog
* Tue Jan 28 2020 Troy Dawson <tdawson@redhat.com> - 5.2.0-1
- Update to 5.2.0
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.1.0-12 * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.1.0-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
57989ae9f7c113e682ef1713a6f1e92a grantlee-5.1.0.tar.gz SHA512 (grantlee-5.2.0.tar.gz) = 94b53d103aa775e6d45357d44d5634a5214d12ea7178d251fda30c5a88ddc2682ae44501ee8b7dc475793b84fa0998eb0bc13eea3f2e10ab29b1489db6ea60bd

Loading…
Cancel
Save