|
|
|
@ -1,13 +1,13 @@
|
|
|
|
|
From 2ce2cb510a39ee42619745a98b14e32744d1bf75 Mon Sep 17 00:00:00 2001
|
|
|
|
|
From 9dfa187569e4c9c4e72ace60c051cbfa79434d77 Mon Sep 17 00:00:00 2001
|
|
|
|
|
From: Troy Dawson <tdawson@redhat.com>
|
|
|
|
|
Date: Tue, 28 Jan 2020 13:19:10 -0800
|
|
|
|
|
Date: Fri, 14 Feb 2020 13:43:27 -0800
|
|
|
|
|
Subject: [PATCH] install headers into versioned directory
|
|
|
|
|
|
|
|
|
|
---
|
|
|
|
|
CMakeLists.txt | 1 +
|
|
|
|
|
templates/lib/CMakeLists.txt | 8 ++++++--
|
|
|
|
|
templates/lib/CMakeLists.txt | 6 ++++--
|
|
|
|
|
textdocument/lib/CMakeLists.txt | 8 ++++++--
|
|
|
|
|
3 files changed, 13 insertions(+), 4 deletions(-)
|
|
|
|
|
3 files changed, 11 insertions(+), 4 deletions(-)
|
|
|
|
|
|
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
|
|
|
index 20edcdc..8df3dd6 100644
|
|
|
|
@ -22,21 +22,19 @@ index 20edcdc..8df3dd6 100644
|
|
|
|
|
# set up RPATH/install_name_dir
|
|
|
|
|
set( CMAKE_INSTALL_NAME_DIR ${CMAKE_INSTALL_PREFIX}/${LIB_INSTALL_DIR})
|
|
|
|
|
diff --git a/templates/lib/CMakeLists.txt b/templates/lib/CMakeLists.txt
|
|
|
|
|
index 5058481..ec1fd3a 100644
|
|
|
|
|
index 5058481..c4262f3 100644
|
|
|
|
|
--- a/templates/lib/CMakeLists.txt
|
|
|
|
|
+++ b/templates/lib/CMakeLists.txt
|
|
|
|
|
@@ -101,6 +101,10 @@ if (Qt5Qml_FOUND)
|
|
|
|
|
@@ -106,6 +106,8 @@ if (Qt5Qml_FOUND)
|
|
|
|
|
)
|
|
|
|
|
endif()
|
|
|
|
|
|
|
|
|
|
target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
|
|
|
|
|
target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
|
|
|
|
|
+ target_include_directories(Grantlee_Templates
|
|
|
|
|
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
|
|
|
|
|
+ )
|
|
|
|
|
+target_include_directories(Grantlee_Templates INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>")
|
|
|
|
|
+
|
|
|
|
|
target_link_libraries(Grantlee_Templates
|
|
|
|
|
PRIVATE Qt5::Qml
|
|
|
|
|
)
|
|
|
|
|
@@ -152,10 +156,10 @@ install(FILES
|
|
|
|
|
if (BUILD_TESTS)
|
|
|
|
|
set(GRANTLEE_TESTS_EXPORT "GRANTLEE_TEMPLATES_EXPORT")
|
|
|
|
|
endif()
|
|
|
|
|
@@ -152,10 +154,10 @@ install(FILES
|
|
|
|
|
token.h
|
|
|
|
|
util.h
|
|
|
|
|
variable.h
|
|
|
|
|