- update cvs backport with ssl http fix

f38
Alexander Larsson 20 years ago
parent b0660cfe77
commit 8f65f7ad7a

@ -1,44 +1,29 @@
+2004-10-05 Alexander Larsson <alexl@redhat.com>
+
+ * libgnomevfs/gnome-vfs-mime-handlers.c (gnome_vfs_mime_get_default_action_type):
+ Temporary workaround to make show_url handle folders. This needs
+ rethinking.
+
+2004-09-27 Ray Strode <rstrode@redhat.com>
+ * libgnomevfs/eggdesktopentries.c
+ (egg_desktop_entries_get_locale_encoding):
+ swap if and else clauses to prevent needlessly
+ misallocating gigabytes of memory (Spotted
+ by Nicholas Miell, bug 153759).
+
+2004-09-27 Ray Strode <rstrode@redhat.com>
+ * libgnomevfs/eggdesktopentries.c
+ (egg_find_file_in_data_dirs): use g_error_new
+ instead g_set_error.
+ (egg_find_file_in_data_dir): get rid of the
+ secondary error cruft.
+ (egg_desktop_entries_free): free
+ entries->default_group_name
+ (egg_desktop_entries_get_locale_country):
+ swap if and else clauses to prevent needlessly
+ misallocating gigabytes of memory (Spotted
+ by Nicholas Miell, bug 153759).
+
+2004-09-22 Alexander Larsson <alexl@redhat.com>
+
+ * libgnomevfs/gnome-vfs-unix-mounts.[ch]:
+ * libgnomevfs/gnome-vfs-volume-monitor-daemon.c:
+ Try to reuse children when getting dev_t by stating.
+ Fixes bug 151026. Patch from Morten Welinder.
+
+ * configure.in:
+ Post release version bump.
+
+=== gnome-vfs 2.8.1 ===
+
2004-09-21 Alexander Larsson <alexl@redhat.com>
Index: imported/neon/ne_gnomevfs.c
===================================================================
RCS file: /cvs/gnome/gnome-vfs/imported/neon/ne_gnomevfs.c,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -p -r1.4 -r1.5
--- imported/neon/ne_gnomevfs.c 21 Sep 2004 08:10:19 -0000 1.4
+++ imported/neon/ne_gnomevfs.c 5 Oct 2004 15:47:10 -0000 1.5
@@ -252,7 +252,7 @@ ne_sock_connect (ne_socket *sock, const
return NE_SOCK_ERROR;
sock->socket = gnome_vfs_inet_connection_to_socket (sock->connection);
- sock->socket_buffer = gnome_vfs_inet_connection_to_socket_buffer (sock->connection);
+ sock->socket_buffer = gnome_vfs_socket_buffer_new (sock->socket);
return 0;
}
@@ -425,8 +425,6 @@ ne_sock_close (ne_socket *sock)
GnomeVFSCancellation *cancellation;
peek_cancellation (cancellation);
-
- gnome_vfs_socket_free (sock->socket);
* NEWS:
if (sock->socket_buffer) {
gnome_vfs_socket_buffer_flush (sock->socket_buffer,
Index: libgnomevfs/eggdesktopentries.c
===================================================================
RCS file: /cvs/gnome/gnome-vfs/libgnomevfs/eggdesktopentries.c,v

@ -10,7 +10,7 @@
Summary: The GNOME virtual file-system libraries.
Name: gnome-vfs2
Version: 2.8.1
Release: 6
Release: 7
License: LGPL
Group: System Environment/Libraries
Source: gnome-vfs-%{version}.tar.bz2
@ -255,6 +255,9 @@ done
%config %{_sysconfdir}/gnome-vfs-2.0/modules/smb-module.conf
%changelog
* Tue Oct 5 2004 Alexander Larsson <alexl@redhat.com> - 2.8.1-7
- update cvs backport with ssl http fix
* Tue Oct 5 2004 Alexander Larsson <alexl@redhat.com> - 2.8.1-6
- Add cvs-backport patch with various fixed from HEAD, including
a partial fix for #134627

Loading…
Cancel
Save