|
|
@ -1,44 +1,29 @@
|
|
|
|
+2004-10-05 Alexander Larsson <alexl@redhat.com>
|
|
|
|
Index: imported/neon/ne_gnomevfs.c
|
|
|
|
+
|
|
|
|
===================================================================
|
|
|
|
+ * libgnomevfs/gnome-vfs-mime-handlers.c (gnome_vfs_mime_get_default_action_type):
|
|
|
|
RCS file: /cvs/gnome/gnome-vfs/imported/neon/ne_gnomevfs.c,v
|
|
|
|
+ Temporary workaround to make show_url handle folders. This needs
|
|
|
|
retrieving revision 1.4
|
|
|
|
+ rethinking.
|
|
|
|
retrieving revision 1.5
|
|
|
|
+
|
|
|
|
diff -u -p -r1.4 -r1.5
|
|
|
|
+2004-09-27 Ray Strode <rstrode@redhat.com>
|
|
|
|
--- imported/neon/ne_gnomevfs.c 21 Sep 2004 08:10:19 -0000 1.4
|
|
|
|
+ * libgnomevfs/eggdesktopentries.c
|
|
|
|
+++ imported/neon/ne_gnomevfs.c 5 Oct 2004 15:47:10 -0000 1.5
|
|
|
|
+ (egg_desktop_entries_get_locale_encoding):
|
|
|
|
@@ -252,7 +252,7 @@ ne_sock_connect (ne_socket *sock, const
|
|
|
|
+ swap if and else clauses to prevent needlessly
|
|
|
|
return NE_SOCK_ERROR;
|
|
|
|
+ misallocating gigabytes of memory (Spotted
|
|
|
|
|
|
|
|
+ by Nicholas Miell, bug 153759).
|
|
|
|
sock->socket = gnome_vfs_inet_connection_to_socket (sock->connection);
|
|
|
|
+
|
|
|
|
- sock->socket_buffer = gnome_vfs_inet_connection_to_socket_buffer (sock->connection);
|
|
|
|
+2004-09-27 Ray Strode <rstrode@redhat.com>
|
|
|
|
+ sock->socket_buffer = gnome_vfs_socket_buffer_new (sock->socket);
|
|
|
|
+ * libgnomevfs/eggdesktopentries.c
|
|
|
|
|
|
|
|
+ (egg_find_file_in_data_dirs): use g_error_new
|
|
|
|
return 0;
|
|
|
|
+ instead g_set_error.
|
|
|
|
}
|
|
|
|
+ (egg_find_file_in_data_dir): get rid of the
|
|
|
|
@@ -425,8 +425,6 @@ ne_sock_close (ne_socket *sock)
|
|
|
|
+ secondary error cruft.
|
|
|
|
GnomeVFSCancellation *cancellation;
|
|
|
|
+ (egg_desktop_entries_free): free
|
|
|
|
|
|
|
|
+ entries->default_group_name
|
|
|
|
peek_cancellation (cancellation);
|
|
|
|
+ (egg_desktop_entries_get_locale_country):
|
|
|
|
-
|
|
|
|
+ swap if and else clauses to prevent needlessly
|
|
|
|
- gnome_vfs_socket_free (sock->socket);
|
|
|
|
+ misallocating gigabytes of memory (Spotted
|
|
|
|
|
|
|
|
+ by Nicholas Miell, bug 153759).
|
|
|
|
|
|
|
|
+
|
|
|
|
|
|
|
|
+2004-09-22 Alexander Larsson <alexl@redhat.com>
|
|
|
|
|
|
|
|
+
|
|
|
|
|
|
|
|
+ * libgnomevfs/gnome-vfs-unix-mounts.[ch]:
|
|
|
|
|
|
|
|
+ * libgnomevfs/gnome-vfs-volume-monitor-daemon.c:
|
|
|
|
|
|
|
|
+ Try to reuse children when getting dev_t by stating.
|
|
|
|
|
|
|
|
+ Fixes bug 151026. Patch from Morten Welinder.
|
|
|
|
|
|
|
|
+
|
|
|
|
|
|
|
|
+ * configure.in:
|
|
|
|
|
|
|
|
+ Post release version bump.
|
|
|
|
|
|
|
|
+
|
|
|
|
|
|
|
|
+=== gnome-vfs 2.8.1 ===
|
|
|
|
|
|
|
|
+
|
|
|
|
|
|
|
|
2004-09-21 Alexander Larsson <alexl@redhat.com>
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
* NEWS:
|
|
|
|
if (sock->socket_buffer) {
|
|
|
|
|
|
|
|
gnome_vfs_socket_buffer_flush (sock->socket_buffer,
|
|
|
|
Index: libgnomevfs/eggdesktopentries.c
|
|
|
|
Index: libgnomevfs/eggdesktopentries.c
|
|
|
|
===================================================================
|
|
|
|
===================================================================
|
|
|
|
RCS file: /cvs/gnome/gnome-vfs/libgnomevfs/eggdesktopentries.c,v
|
|
|
|
RCS file: /cvs/gnome/gnome-vfs/libgnomevfs/eggdesktopentries.c,v
|
|
|
|