Build the mime.cache handling code

f38
Matthias Clasen 17 years ago
parent 875a8de5e7
commit 8c99950805

@ -0,0 +1,12 @@
diff -up gnome-vfs-2.20.1/configure.in.mime-cache gnome-vfs-2.20.1/configure.in
--- gnome-vfs-2.20.1/configure.in.mime-cache 2007-12-03 00:45:24.000000000 -0500
+++ gnome-vfs-2.20.1/configure.in 2007-12-03 00:41:43.000000000 -0500
@@ -158,7 +158,7 @@ AC_SEARCH_LIBS(setsockopt, socket)
AC_SEARCH_LIBS(login_tty, util, [AC_DEFINE([HAVE_LOGIN_TTY],[],[Whether login_tty is available])])
AC_FUNC_ALLOCA
-AC_CHECK_FUNCS(getdtablesize open64 lseek64 statfs statvfs seteuid setegid setresuid setresgid readdir_r mbrtowc inet_pton getdelim sysctlbyname poll posix_fadvise fchmod atoll)
+AC_CHECK_FUNCS(getdtablesize open64 lseek64 statfs statvfs seteuid setegid setresuid setresgid readdir_r mbrtowc inet_pton getdelim sysctlbyname poll posix_fadvise fchmod atoll mmap)
AC_CHECK_MEMBERS([struct stat.st_blksize, struct stat.st_rdev])
AC_STRUCT_ST_BLOCKS

@ -14,7 +14,7 @@
Summary: The GNOME virtual file-system libraries Summary: The GNOME virtual file-system libraries
Name: gnome-vfs2 Name: gnome-vfs2
Version: 2.20.1 Version: 2.20.1
Release: 1%{?dist} Release: 2%{?dist}
License: LGPLv2 and LGPL+ and GPL+ License: LGPLv2 and LGPL+ and GPL+
# the daemon and the library are LGPLv2 # the daemon and the library are LGPLv2
# the modules are LGPL+ and GPL+ # the modules are LGPL+ and GPL+
@ -75,6 +75,9 @@ Patch8: gnome-vfs-2.16.0-no-dbus.patch
# http://bugzilla.gnome.org/show_bug.cgi?id=427958 # http://bugzilla.gnome.org/show_bug.cgi?id=427958
Patch9: glob-leak.patch Patch9: glob-leak.patch
# http://bugzilla.gnome.org/show_bug.cgi?id=501160
Patch10: gnome-vfs-mime-cache.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=333041 # https://bugzilla.redhat.com/show_bug.cgi?id=333041
# https://bugzilla.redhat.com/show_bug.cgi?id=335241 # https://bugzilla.redhat.com/show_bug.cgi?id=335241
Patch300: gnome-vfs-2.20.0-ignore-certain-mountpoints.patch Patch300: gnome-vfs-2.20.0-ignore-certain-mountpoints.patch
@ -131,9 +134,14 @@ shares (SMB) to applications using GNOME VFS.
%patch8 -p1 -b .no-dbus %patch8 -p1 -b .no-dbus
%patch9 -p1 -b .glob-leak %patch9 -p1 -b .glob-leak
%patch10 -p1 -b .mime-cache
%patch300 -p1 -b .ignore-certain-mount-points %patch300 -p1 -b .ignore-certain-mount-points
# for patch 10
autoheader
autoconf
%build %build
if pkg-config openssl ; then if pkg-config openssl ; then
@ -235,6 +243,9 @@ fi
%config %{_sysconfdir}/gnome-vfs-2.0/modules/smb-module.conf %config %{_sysconfdir}/gnome-vfs-2.0/modules/smb-module.conf
%changelog %changelog
* Mon Dec 3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.1-2
- Build the mime.cache handling code
* Mon Nov 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.1-1 * Mon Nov 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.1-1
- Update to 2.20.1 (fixes a dns-sd crash) - Update to 2.20.1 (fixes a dns-sd crash)

Loading…
Cancel
Save