initial package (rhbz#2178635)

f38
Dominik 'Rathann' Mierzejewski 2 years ago
parent 6f076df277
commit 644b0301f6

1
.gitignore vendored

@ -0,0 +1 @@
/gnome-shell-extension-dash-to-panel-*.tar.gz

@ -0,0 +1,29 @@
diff -up dash-to-panel-55/Makefile.orig dash-to-panel-55/Makefile
--- dash-to-panel-55/Makefile.orig 2023-03-09 16:32:54.000000000 +0100
+++ dash-to-panel-55/Makefile 2023-03-15 13:42:54.227368912 +0100
@@ -10,9 +10,12 @@ EXTRA_IMAGES = highlight_stacked_bg.svg
TOLOCALIZE = prefs.js appIcons.js
MSGSRC = $(wildcard po/*.po)
ifeq ($(strip $(DESTDIR)),)
+ INSTALLTYPE = local
INSTALLBASE = $(HOME)/.local/share/gnome-shell/extensions
else
+ INSTALLTYPE = system
INSTALLBASE = $(DESTDIR)/usr/share/gnome-shell/extensions
+ SHARE_PREFIX = $(DESTDIR)/usr/share
endif
INSTALLNAME = dash-to-panel@jderose9.github.com
@@ -71,6 +74,12 @@ install-local: _build
rm -rf $(INSTALLBASE)/$(INSTALLNAME)
mkdir -p $(INSTALLBASE)/$(INSTALLNAME)
cp -r ./_build/* $(INSTALLBASE)/$(INSTALLNAME)/
+ifeq ($(INSTALLTYPE),system)
+ rm -r $(INSTALLBASE)/$(INSTALLNAME)/schemas $(INSTALLBASE)/$(INSTALLNAME)/locale
+ mkdir -p $(SHARE_PREFIX)/glib-2.0/schemas $(SHARE_PREFIX)/locale
+ cp -r ./schemas/*gschema.* $(SHARE_PREFIX)/glib-2.0/schemas
+ cp -r ./_build/locale/* $(SHARE_PREFIX)/locale
+endif
-rm -fR _build
echo done

@ -0,0 +1,52 @@
%global ename dash-to-panel
%global extdir %{_datadir}/gnome-shell/extensions/dash-to-panel@jderose9.github.com
Name: gnome-shell-extension-%{ename}
Version: 55
Release: 2%{?dist}
Summary: Integrated icon taskbar and status panel for Gnome Shell
License: GPL-2.0-or-later
URL: https://github.com/home-sweet-gnome/dash-to-panel
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
# correct install paths
Patch0: %{name}-system-install-paths.patch
BuildArch: noarch
BuildRequires: gettext
BuildRequires: make
BuildRequires: %{_bindir}/glib-compile-schemas
Requires: clutter
Requires: gnome-shell >= 42
%description
Dash to Panel is an icon taskbar for Gnome Shell. This extension moves the dash
into the gnome main panel so that the application launchers and system tray are
combined into a single panel, similar to that found in KDE Plasma and Windows
7+. A separate dock is no longer needed for easy access to running and favorited
applications.
%prep
%autosetup -n %{ename}-%{version} -p1
%build
%make_build VERSION=%{version}
%install
%make_install VERSION=%{version}
rm -v %{buildroot}%{extdir}/{COPYING,README.md}
%find_lang %{ename}
%files -f %{ename}.lang
%license COPYING
%doc README.md
%{extdir}/
%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.%{ename}.gschema.xml
%changelog
* Wed Mar 15 2023 Dominik Mierzejewski <dominik@greysector.net> - 55-2
- correct run-time dependencies
- add explicit slash to extdir
- add missing comment
* Wed Mar 15 2023 Dominik Mierzejewski <dominik@greysector.net> - 55-1
- intial package

@ -0,0 +1 @@
SHA512 (gnome-shell-extension-dash-to-panel-55.tar.gz) = a3aa47c6c881a2adc1498a84b1592e0d4b0782bfbc59e9d1a08916ccc75304625d875c3ba59908a2bcacd386941ec3ffe9d0c4f842d77b85b4073e327b6803c0
Loading…
Cancel
Save