parent
8c17cebecd
commit
31b04b4ffc
@ -1,50 +0,0 @@
|
|||||||
From 1a6737f4a26c38f3c703d84263d0a0779a607359 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
|
||||||
Date: Wed, 21 Apr 2021 14:49:36 +0200
|
|
||||||
Subject: [PATCH] build: Set rpath on executable
|
|
||||||
|
|
||||||
---
|
|
||||||
meson.build | 1 +
|
|
||||||
src/meson.build | 1 +
|
|
||||||
tests/meson.build | 1 +
|
|
||||||
3 files changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/meson.build b/meson.build
|
|
||||||
index 9d7bda1..9148eb9 100644
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -75,6 +75,7 @@ top_srcdir = meson.current_source_dir()
|
|
||||||
builddir = meson.current_build_dir()
|
|
||||||
|
|
||||||
prefix = get_option('prefix')
|
|
||||||
+libdir = join_paths(prefix, get_option('libdir'))
|
|
||||||
libexecdir = join_paths(prefix, get_option('libexecdir'))
|
|
||||||
datadir = join_paths(prefix, get_option('datadir'))
|
|
||||||
schemadir = join_paths(datadir, 'glib-2.0', 'schemas')
|
|
||||||
diff --git a/src/meson.build b/src/meson.build
|
|
||||||
index 843746d..3757afb 100644
|
|
||||||
--- a/src/meson.build
|
|
||||||
+++ b/src/meson.build
|
|
||||||
@@ -100,6 +100,7 @@ executable('gnome-remote-desktop-daemon',
|
|
||||||
daemon_sources,
|
|
||||||
dependencies: deps,
|
|
||||||
include_directories: [configinc],
|
|
||||||
+ install_rpath: join_paths(libdir, 'gnome-remote-desktop'),
|
|
||||||
install: true,
|
|
||||||
install_dir: libexecdir)
|
|
||||||
|
|
||||||
diff --git a/tests/meson.build b/tests/meson.build
|
|
||||||
index 978ae23..ab74a28 100644
|
|
||||||
--- a/tests/meson.build
|
|
||||||
+++ b/tests/meson.build
|
|
||||||
@@ -5,6 +5,7 @@ if have_vnc
|
|
||||||
dependencies: [glib_dep,
|
|
||||||
libvncclient_dep],
|
|
||||||
include_directories: [configinc],
|
|
||||||
+ install_rpath: join_paths(libdir, 'gnome-remote-desktop'),
|
|
||||||
install: false)
|
|
||||||
|
|
||||||
test_runner = find_program('vnc-test-runner.sh')
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
@ -0,0 +1,47 @@
|
|||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index 0b6228a..20fec85 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -495,7 +495,7 @@ if(WIN32)
|
||||||
|
endif(WITH_TIGHTVNC_FILETRANSFER)
|
||||||
|
endif(WIN32)
|
||||||
|
|
||||||
|
-target_link_libraries(vncclient
|
||||||
|
+target_link_libraries(vncclient PUBLIC
|
||||||
|
${ADDITIONAL_LIBS}
|
||||||
|
${ZLIB_LIBRARIES}
|
||||||
|
${LZO_LIBRARIES}
|
||||||
|
@@ -504,7 +504,7 @@ target_link_libraries(vncclient
|
||||||
|
${GNUTLS_LIBRARIES}
|
||||||
|
${OPENSSL_LIBRARIES}
|
||||||
|
)
|
||||||
|
-target_link_libraries(vncserver
|
||||||
|
+target_link_libraries(vncserver PUBLIC
|
||||||
|
${ADDITIONAL_LIBS}
|
||||||
|
${ZLIB_LIBRARIES}
|
||||||
|
${LZO_LIBRARIES}
|
||||||
|
diff --git a/libvncclient.pc.cmakein b/libvncclient.pc.cmakein
|
||||||
|
index ceeda39..f131dca 100644
|
||||||
|
--- a/libvncclient.pc.cmakein
|
||||||
|
+++ b/libvncclient.pc.cmakein
|
||||||
|
@@ -8,7 +8,6 @@ Description: A library for easy implementation of a VNC client.
|
||||||
|
Version: @LibVNCServer_VERSION@
|
||||||
|
Requires:
|
||||||
|
Requires.private:
|
||||||
|
-Libs: -L${libdir} -lvncclient
|
||||||
|
-Libs.private: @PRIVATE_LIBS@
|
||||||
|
+Libs: -L${libdir} -lvncclient @PRIVATE_LIBS@
|
||||||
|
Cflags: -I${includedir}
|
||||||
|
|
||||||
|
diff --git a/libvncserver.pc.cmakein b/libvncserver.pc.cmakein
|
||||||
|
index 33ec668..5ae98c9 100644
|
||||||
|
--- a/libvncserver.pc.cmakein
|
||||||
|
+++ b/libvncserver.pc.cmakein
|
||||||
|
@@ -8,6 +8,5 @@ Description: A library for easy implementation of a VNC server.
|
||||||
|
Version: @LibVNCServer_VERSION@
|
||||||
|
Requires:
|
||||||
|
Requires.private:
|
||||||
|
-Libs: -L${libdir} -lvncserver
|
||||||
|
-Libs.private: @PRIVATE_LIBS@
|
||||||
|
+Libs: -L${libdir} -lvncserver @PRIVATE_LIBS@
|
||||||
|
Cflags: -I${includedir}
|
Loading…
Reference in new issue