parent
4ab645e5f6
commit
cd30408af3
@ -0,0 +1,38 @@
|
|||||||
|
diff -up gnome-icon-theme-2.30.2.1/Makefile.am.scalable gnome-icon-theme-2.30.2.1/Makefile.am
|
||||||
|
--- gnome-icon-theme-2.30.2.1/Makefile.am.scalable 2010-05-24 11:18:44.273706947 -0400
|
||||||
|
+++ gnome-icon-theme-2.30.2.1/Makefile.am 2010-05-24 11:18:47.682470322 -0400
|
||||||
|
@@ -5,7 +5,7 @@ SUBDIRS = po $(SVGSRCDIR)
|
||||||
|
theme_in_files = index.theme.in.in
|
||||||
|
theme_DATA = $(theme_in_files:.theme.in.in=.theme)
|
||||||
|
|
||||||
|
-THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done | sed -e "s/,$$//g")
|
||||||
|
+THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/devices,scalable/emblems,scalable/mimetypes,scalable/places,scalable/status")
|
||||||
|
|
||||||
|
render: Makefile
|
||||||
|
($(am__cd) $(SVGSRCDIR) && $(MAKE) $(AM_MAKEFLAGS) render) \
|
||||||
|
@@ -16,7 +16,11 @@ render: Makefile
|
||||||
|
sed -e "s|\@THEME_DIRS\@|$$dirs|g" < $< > $@; \
|
||||||
|
for dir in `echo $$dirs | sed -e "s/,/ /g"`; do \
|
||||||
|
sizefull="`dirname $$dir`"; \
|
||||||
|
- size="`echo $$sizefull | sed -e 's/x.*$$//g'`"; \
|
||||||
|
+ if test "$$sizefull" = "scalable"; then \
|
||||||
|
+ size="16"; \
|
||||||
|
+ else \
|
||||||
|
+ size="`echo $$sizefull | sed -e 's/x.*$$//g'`"; \
|
||||||
|
+ fi; \
|
||||||
|
context="`basename $$dir`"; \
|
||||||
|
echo "[$$dir]" >> $@; \
|
||||||
|
if test "$$context" = "actions"; then \
|
||||||
|
@@ -53,7 +57,11 @@ render: Makefile
|
||||||
|
echo "Context=Status" >> $@; \
|
||||||
|
fi; \
|
||||||
|
echo "Size=$$size" >> $@; \
|
||||||
|
- if test "$$size" = "256"; then \
|
||||||
|
+ if test "$$sizefull" = "scalable"; then \
|
||||||
|
+ echo "MinSize=16" >> $@; \
|
||||||
|
+ echo "MaxSize=256" >> $@; \
|
||||||
|
+ echo "Type=Scalable" >> $@; \
|
||||||
|
+ elif test "$$size" = "256"; then \
|
||||||
|
echo "MinSize=56" >> $@; \
|
||||||
|
echo "MaxSize=512" >> $@; \
|
||||||
|
echo "Type=Scalable" >> $@; \
|
Loading…
Reference in new issue