parent
fcf7fa2993
commit
5e74a37615
@ -1,33 +0,0 @@
|
|||||||
--- gnome-commander-1.2.8.15/src/dict.h.gcc47 2011-11-08 08:26:25.000000000 +0900
|
|
||||||
+++ gnome-commander-1.2.8.15/src/dict.h 2012-01-05 11:26:39.649243923 +0900
|
|
||||||
@@ -55,8 +55,8 @@
|
|
||||||
template <typename KEY, typename VAL>
|
|
||||||
inline void DICT<KEY,VAL>::add(const KEY k, const VAL &v)
|
|
||||||
{
|
|
||||||
- std::pair<typename KEY_COLL::iterator,bool> k_pos = k_coll.insert(make_pair(k,(const VAL *) NULL));
|
|
||||||
- std::pair<typename VAL_COLL::iterator,bool> v_pos = v_coll.insert(make_pair(v,(const KEY *) NULL));
|
|
||||||
+ std::pair<typename KEY_COLL::iterator,bool> k_pos = k_coll.insert(std::make_pair(k,(const VAL *) NULL));
|
|
||||||
+ std::pair<typename VAL_COLL::iterator,bool> v_pos = v_coll.insert(std::make_pair(v,(const KEY *) NULL));
|
|
||||||
|
|
||||||
if (k_pos.second)
|
|
||||||
k_pos.first->second = &v_pos.first->first;
|
|
||||||
--- gnome-commander-1.2.8.15/src/gnome-cmd-user-actions.cc.gcc47 2011-12-07 04:10:28.000000000 +0900
|
|
||||||
+++ gnome-commander-1.2.8.15/src/gnome-cmd-user-actions.cc 2013-01-20 03:36:16.000000000 +0900
|
|
||||||
@@ -1124,7 +1124,7 @@
|
|
||||||
|
|
||||||
without_c_param:
|
|
||||||
|
|
||||||
- char *argv[4];
|
|
||||||
+ const char *argv[4];
|
|
||||||
int i = 0;
|
|
||||||
|
|
||||||
argv[i++] = su;
|
|
||||||
@@ -1135,7 +1135,7 @@
|
|
||||||
|
|
||||||
GError *error = NULL;
|
|
||||||
|
|
||||||
- if (!g_spawn_async (NULL, argv, NULL, GSpawnFlags (G_SPAWN_STDOUT_TO_DEV_NULL | G_SPAWN_STDERR_TO_DEV_NULL), NULL, NULL, NULL, &error))
|
|
||||||
+ if (!g_spawn_async (NULL, (char **)argv, NULL, GSpawnFlags (G_SPAWN_STDOUT_TO_DEV_NULL | G_SPAWN_STDERR_TO_DEV_NULL), NULL, NULL, NULL, &error))
|
|
||||||
gnome_cmd_error_message (_("Unable to start GNOME Commander in root mode."), error);
|
|
||||||
|
|
||||||
g_free (su);
|
|
@ -1,10 +0,0 @@
|
|||||||
--- gnome-commander-1.2.8.15/src/tags/gnome-cmd-tags-doc.cc.newgsf 2011-12-07 04:10:29.000000000 +0900
|
|
||||||
+++ gnome-commander-1.2.8.15/src/tags/gnome-cmd-tags-doc.cc 2013-07-01 17:49:04.126488384 +0900
|
|
||||||
@@ -48,6 +48,7 @@
|
|
||||||
#include <gsf/gsf-msole-utils.h>
|
|
||||||
#include <gsf/gsf-opendoc-utils.h>
|
|
||||||
#include <gsf/gsf-utils.h>
|
|
||||||
+#include <gsf/gsf-doc-meta-data.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
using namespace std;
|
|
@ -1,46 +0,0 @@
|
|||||||
--- gnome-commander-1.2.8.15/configure.in.poppler 2011-12-07 04:10:27.000000000 +0900
|
|
||||||
+++ gnome-commander-1.2.8.15/configure.in 2013-08-23 18:24:54.383027945 +0900
|
|
||||||
@@ -239,6 +239,13 @@
|
|
||||||
if pkg-config --max-version=0.11.2 poppler; then
|
|
||||||
AC_DEFINE(POPPLER_HAS_GET_PDF_VERSION, 1, [Define to 1 if poppler has support for PDFDoc::getPDFVersion()])
|
|
||||||
fi
|
|
||||||
+ if pkg-config --atleast-version=0.19.0 poppler; then
|
|
||||||
+ AC_DEFINE(POPPLER_HAS_SET_ERROR_CALLBACK, 1, [Define to 1 if poppler has support for setErrorCallback()])
|
|
||||||
+ fi
|
|
||||||
+ if pkg-config --atleast-version=0.24.0 poppler; then
|
|
||||||
+ AC_DEFINE(POPPLER_HAS_GOFFSET_ARGUMENT_FOR_SET_ERROR_CALLBACK, 1,
|
|
||||||
+ [Define to 1 if poppler uses Goffset for the 3rd argument of setErrorCallback])
|
|
||||||
+ fi
|
|
||||||
fi
|
|
||||||
if test "x$have_pdf" = "xyes"; then
|
|
||||||
AC_DEFINE(HAVE_PDF, 1, [Define to 1 if you have PDF support])
|
|
||||||
--- gnome-commander-1.2.8.15/src/tags/gnome-cmd-tags-poppler.cc.poppler 2011-12-07 04:10:29.000000000 +0900
|
|
||||||
+++ gnome-commander-1.2.8.15/src/tags/gnome-cmd-tags-poppler.cc 2013-08-23 18:32:03.618636877 +0900
|
|
||||||
@@ -40,8 +40,13 @@
|
|
||||||
#ifdef HAVE_PDF
|
|
||||||
static regex_t rxDate;
|
|
||||||
static gboolean rxDate_OK;
|
|
||||||
-
|
|
||||||
+#if defined(POPPLER_HAS_GOFFSET_ARGUMENT_FOR_SET_ERROR_CALLBACK)
|
|
||||||
+static void noErrorReporting(void *, ErrorCategory, Goffset pos, char *msg)
|
|
||||||
+#elif defined(POPPLER_HAS_SET_ERROR_CALLBACK)
|
|
||||||
+static void noErrorReporting(void *, ErrorCategory, int pos, char *msg)
|
|
||||||
+#else
|
|
||||||
static void noErrorReporting(int pos, char *msg, va_list args)
|
|
||||||
+#endif
|
|
||||||
{
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
@@ -52,8 +57,12 @@
|
|
||||||
#ifdef HAVE_PDF
|
|
||||||
rxDate_OK = regcomp (&rxDate, "^(D:)?([12][019][0-9][0-9]([01][0-9]([0-3][0-9]([012][0-9]([0-5][0-9]([0-5][0-9])?)?)?)?)?)", REG_EXTENDED)==0;
|
|
||||||
|
|
||||||
+#if defined(POPPLER_HAS_GOFFSET_ARGUMENT_FOR_SET_ERROR_CALLBACK) || defined(POPPLER_HAS_SET_ERROR_CALLBACK)
|
|
||||||
+ setErrorCallback(noErrorReporting, NULL);
|
|
||||||
+#else
|
|
||||||
setErrorFunction(noErrorReporting);
|
|
||||||
#endif
|
|
||||||
+#endif
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in new issue