Update to glm-0.9.3.4 and work around problems

f41
Joonas Sarajärvi 13 years ago
parent 9d5634a79e
commit cc1df445a7

1
.gitignore vendored

@ -1 +1,2 @@
/glm-0.9.3.2.zip
/glm-0.9.3.4.zip

@ -0,0 +1,15 @@
diff -ru glm-0.9.3.2-orig/glm/gtx/integer.inl glm-0.9.3.2/glm/gtx/integer.inl
--- glm-0.9.3.2-orig/glm/gtx/integer.inl 2012-09-02 21:53:24.298350117 +0300
+++ glm-0.9.3.2/glm/gtx/integer.inl 2012-09-02 21:54:42.435203223 +0300
@@ -60,10 +60,8 @@
template <typename T>
GLM_FUNC_QUALIFIER T operator() (T const & Value) const
{
-#if(GLM_COMPILER & GLM_COMPILER_VC)
+#if(GLM_COMPILER & (GLM_COMPILER_VC | GLM_COMPILER_GCC))
return Value <= T(1) ? T(0) : T(32) - nlz(Value - T(1));
-#elif(GLM_COMPILER & GLM_COMPILER_GCC)
- return Value <= T(1) ? T(0) : nlz(Value - T(1)) + 1;
#else
return T(32) - nlz(Value - T(1));
#endif

@ -2,13 +2,14 @@
%global debug_package %{nil}
Name: glm
Version: 0.9.3.2
Release: 3%{?dist}
Version: 0.9.3.4
Release: 1%{?dist}
Summary: C++ mathematics library for graphics programming
License: MIT
URL: http://glm.g-truc.net/
Source0: http://downloads.sourceforge.net/ogl-math/%{name}-%{version}/%{name}-%{version}.zip
Patch0: glm-no-gcc-integer-log2.patch
BuildRequires: cmake
%description
@ -54,7 +55,6 @@ a programming manual for the %{name}-devel package.
# When updating this package, take care to check if -c is
# needed for the particular version.
%setup -q
# Remove some unnecessary binary files shipped in upstream
# sources
rm -r doc/build/
@ -62,23 +62,21 @@ rm -r doc/build/
# A couple of files had CRLF line-ends in them.
sed -i 's/\r//' copying.txt
sed -i 's/\r//' readme.txt
sed -i 's/\r//' doc/api-0.9.3/tabs.css
sed -i 's/\r//' doc/api-0.9.3/doxygen.css
sed -i 's/\r//' doc/api-0.9.3/jquery.js
sed -i 's/\r//' doc/html/tabs.css
sed -i 's/\r//' doc/html/doxygen.css
%patch0 -p1
%build
mkdir build
cd build
%{cmake} -DGLM_TEST_MODE=ON ..
%{cmake} -DGLM_TEST_ENABLE=ON ..
make %{?_smp_mflags}
%check
cd build
# Remove the -E ^test-gtx_integer$ option when issue at
# https://github.com/Groovounet/glm/issues/12
# is resolved.
ctest -E ^test-gtx_integer$ --output-on-failure
ctest %{_smp_mflags} --output-on-failure
%install
cd build
@ -93,9 +91,13 @@ find $RPM_BUILD_ROOT -name CMakeLists.txt -exec rm -f {} ';'
%files doc
%doc doc/%{name}-0.9.3.pdf
%doc doc/api-0.9.3
%doc doc/html/
%changelog
* Sun Sep 02 2012 Joonas Sarajärvi <muep@iki.fi> - 0.9.3.4-1
- Update to a new upstream version
- Work around problems in glm::log2 for integers
* Sat Sep 01 2012 Joonas Sarajärvi <muep@iki.fi> - 0.9.3.2-3
- Skip gtx_integer test that is known as broken

@ -1 +1 @@
777793237f9612f825505f9e5ca04e30 glm-0.9.3.2.zip
a0cea0871bd39f2d628c12f1181faffb glm-0.9.3.4.zip

Loading…
Cancel
Save