|
|
|
@ -1,6 +1,6 @@
|
|
|
|
|
diff -up glew-1.5.2/config/Makefile.linux.jx glew-1.5.2/config/Makefile.linux
|
|
|
|
|
--- glew-1.5.2/config/Makefile.linux.jx 2009-12-31 12:06:19.000000000 -0500
|
|
|
|
|
+++ glew-1.5.2/config/Makefile.linux 2010-02-02 10:16:40.000000000 -0500
|
|
|
|
|
diff -up glew-1.5.4/config/Makefile.linux.make glew-1.5.4/config/Makefile.linux
|
|
|
|
|
--- glew-1.5.4/config/Makefile.linux.make 2010-04-28 08:16:36.000000000 +1000
|
|
|
|
|
+++ glew-1.5.4/config/Makefile.linux 2010-05-29 18:12:26.000000000 +1000
|
|
|
|
|
@@ -7,14 +7,8 @@ endif
|
|
|
|
|
PICFLAG = -fPIC
|
|
|
|
|
LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME)
|
|
|
|
@ -18,9 +18,9 @@ diff -up glew-1.5.2/config/Makefile.linux.jx glew-1.5.2/config/Makefile.linux
|
|
|
|
|
LDFLAGS.STATIC = -Wl,-Bstatic
|
|
|
|
|
LDFLAGS.DYNAMIC = -Wl,-Bdynamic
|
|
|
|
|
NAME = GLEW
|
|
|
|
|
diff -up glew-1.5.2/Makefile.jx glew-1.5.2/Makefile
|
|
|
|
|
--- glew-1.5.2/Makefile.jx 2009-12-31 12:06:19.000000000 -0500
|
|
|
|
|
+++ glew-1.5.2/Makefile 2010-02-02 10:21:23.000000000 -0500
|
|
|
|
|
diff -up glew-1.5.4/Makefile.make glew-1.5.4/Makefile
|
|
|
|
|
--- glew-1.5.4/Makefile.make 2010-04-28 08:16:36.000000000 +1000
|
|
|
|
|
+++ glew-1.5.4/Makefile 2010-05-29 18:19:11.000000000 +1000
|
|
|
|
|
@@ -41,9 +41,9 @@ $(error "Platform '$(SYSTEM)' not suppor
|
|
|
|
|
endif
|
|
|
|
|
|
|
|
|
@ -52,7 +52,14 @@ diff -up glew-1.5.2/Makefile.jx glew-1.5.2/Makefile
|
|
|
|
|
|
|
|
|
|
%.o: %.c
|
|
|
|
|
$(CC) -c $(CFLAGS) -o $@ $<
|
|
|
|
|
@@ -122,7 +122,7 @@ ifeq ($(patsubst mingw%,mingw,$(SYSTEM))
|
|
|
|
|
@@ -125,13 +125,14 @@ install: all
|
|
|
|
|
$(INSTALL) -d -m 0755 $(BINDIR)
|
|
|
|
|
$(INSTALL) -d -m 0755 $(INCDIR)
|
|
|
|
|
$(INSTALL) -d -m 0755 $(LIBDIR)
|
|
|
|
|
+ $(INSTALL) -d -m 0755 $(LIBDIR)/pkgconfig
|
|
|
|
|
# runtime
|
|
|
|
|
ifeq ($(patsubst mingw%,mingw,$(SYSTEM)), mingw)
|
|
|
|
|
$(STRIP) -x lib/$(LIB.SHARED)
|
|
|
|
|
$(INSTALL) -m 0644 lib/$(LIB.SHARED) $(BINDIR)/
|
|
|
|
|
else
|
|
|
|
|
$(STRIP) -x lib/$(LIB.SHARED)
|
|
|
|
@ -61,7 +68,7 @@ diff -up glew-1.5.2/Makefile.jx glew-1.5.2/Makefile
|
|
|
|
|
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.SONAME)
|
|
|
|
|
endif
|
|
|
|
|
# development files
|
|
|
|
|
@@ -137,7 +137,7 @@ else
|
|
|
|
|
@@ -147,7 +148,7 @@ else
|
|
|
|
|
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.DEVLNK)
|
|
|
|
|
endif
|
|
|
|
|
# utilities
|
|
|
|
|