reduce cpus for post %install scripts for armv7hlepel9
parent
86b21a1199
commit
23a07931cf
@ -0,0 +1,39 @@
|
||||
From 296f25fa5f0fce033b529547e0658076e26f4cda Mon Sep 17 00:00:00 2001
|
||||
From: Adam Sandberg Ericsson <adam@sandbergericsson.se>
|
||||
Date: Wed, 28 Apr 2021 20:11:52 +0100
|
||||
Subject: [PATCH] rts: export allocateWrite, freeWrite and markExec #19763
|
||||
|
||||
(cherry picked from commit 2d2985a79eec3d6ae9aee96b264c97c2b158f196)
|
||||
---
|
||||
rts/RtsSymbols.c | 10 ++++++++++
|
||||
1 file changed, 10 insertions(+)
|
||||
|
||||
diff --git a/rts/RtsSymbols.c b/rts/RtsSymbols.c
|
||||
index 9ca696c27c4..d5b8cc5fece 100644
|
||||
--- a/rts/RtsSymbols.c
|
||||
+++ b/rts/RtsSymbols.c
|
||||
@@ -539,11 +539,21 @@
|
||||
#define RTS_PROF_SYMBOLS /* empty */
|
||||
#endif
|
||||
|
||||
+#if RTS_LINKER_USE_MMAP
|
||||
+#define RTS_LINKER_USE_MMAP_SYMBOLS \
|
||||
+ SymI_HasProto(allocateWrite) \
|
||||
+ SymI_HasProto(freeWrite) \
|
||||
+ SymI_HasProto(markExec)
|
||||
+#else
|
||||
+#define RTS_LINKER_USE_MMAP_SYMBOLS /* empty */
|
||||
+#endif
|
||||
+
|
||||
#define RTS_SYMBOLS \
|
||||
Maybe_Stable_Names \
|
||||
RTS_TICKY_SYMBOLS \
|
||||
RTS_PROF_SYMBOLS \
|
||||
RTS_LIBDW_SYMBOLS \
|
||||
+ RTS_LINKER_USE_MMAP_SYMBOLS \
|
||||
SymI_HasProto(StgReturn) \
|
||||
SymI_HasProto(stg_gc_noregs) \
|
||||
SymI_HasProto(stg_ret_v_info) \
|
||||
--
|
||||
GitLab
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- ghc-8.10.2/configure.ac~ 2020-08-04 05:51:52.000000000 +0800
|
||||
+++ ghc-8.10.2/configure.ac 2020-08-11 18:57:45.074836178 +0800
|
||||
@@ -673,7 +673,7 @@
|
||||
# tools we are looking for. In the past, GHC supported a number of
|
||||
# versions of LLVM simultaneously, but that stopped working around
|
||||
# 3.5/3.6 release of LLVM.
|
||||
-LlvmVersion=9
|
||||
+LlvmVersion=10
|
||||
AC_SUBST([LlvmVersion])
|
||||
sUPPORTED_LLVM_VERSION=$(echo \($LlvmVersion\) | sed 's/\./,/')
|
||||
AC_DEFINE_UNQUOTED([sUPPORTED_LLVM_VERSION], ${sUPPORTED_LLVM_VERSION}, [The supported LLVM version number])
|
@ -1,2 +1,2 @@
|
||||
SHA512 (ghc-8.10.4-src.tar.xz) = 9bb078cb72535a352243b83b671c871392564efd09e478549f27ae58fc6f46e337a0782f5500d26d5704ad96eace22e77bb36031a1fe9b7e175f265b0b9c028b
|
||||
SHA512 (ghc-8.10.4-src.tar.xz.sig) = af7dea2adfe120fb35aba203381062c0d6bb0fd76e675ed016019014954a82a58e1a8509b523ffc826ab4ca717a4e00d30280ac9bc1b2e120af6aecbb314897b
|
||||
SHA512 (ghc-8.10.5-src.tar.xz.sig) = c9d1abf8f4065c1935be877b4978638130307afbfef988ac16d7c972e502b71056a5e5acc1b54b903d8f939a0f2e3ec4ad953cdc7a9ce21024f398ce84cfb2da
|
||||
SHA512 (ghc-8.10.5-src.tar.xz) = b5f39be0accd5c1cecf1cc326ba3142f561d2ac93e9abf366fe46307d7c0712aac244836e659e1a4d9d0fb98299ea96edc8e8a06f3a81b528b14914b94057ffe
|
||||
|
Loading…
Reference in new issue