Reverting "revert ld.gold to armv7 only; static ghc progs for aarch64" This reverts commit bc51500a32c12e58b0cdc8a50b0d551c8da177d8.epel9
parent
e8a98a8b8a
commit
03c151c41a
@ -0,0 +1,42 @@
|
|||||||
|
armv7 by nomeata: https://ghc.haskell.org/trac/ghc/ticket/8976#comment:12
|
||||||
|
arm64 backport of https://ghc.haskell.org/trac/ghc/ticket/9673#comment:28 (erikd)
|
||||||
|
|
||||||
|
--- ghc-7.8.4/aclocal.m4.24~ 2015-04-01 04:48:39.961193022 -0400
|
||||||
|
+++ ghc-7.8.4/aclocal.m4 2015-04-01 04:50:19.708203082 -0400
|
||||||
|
@@ -553,6 +553,14 @@
|
||||||
|
$3="$$3 -D_HPUX_SOURCE"
|
||||||
|
$5="$$5 -D_HPUX_SOURCE"
|
||||||
|
;;
|
||||||
|
+ arm*)
|
||||||
|
+ # On arm, link using gold
|
||||||
|
+ $3="$$3 -fuse-ld=gold"
|
||||||
|
+ ;;
|
||||||
|
+ aarch64)
|
||||||
|
+ # On arm, link using gold
|
||||||
|
+ $3="$$3 -fuse-ld=gold"
|
||||||
|
+ ;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
# If gcc knows about the stack protector, turn it off.
|
||||||
|
--- ghc-7.8.4/configure.ac~ 2014-12-22 14:08:24.000000000 -0500
|
||||||
|
+++ ghc-7.8.4/configure.ac 2015-04-22 00:08:54.646110535 -0400
|
||||||
|
@@ -587,7 +587,18 @@
|
||||||
|
dnl ** Which ld to use?
|
||||||
|
dnl --------------------------------------------------------------
|
||||||
|
FP_ARG_WITH_PATH_GNU_PROG([LD], [ld], [ld])
|
||||||
|
-LdCmd="$LD"
|
||||||
|
+case $target in
|
||||||
|
+arm*linux* | aarch64*linux*)
|
||||||
|
+ # Arm requires use of the binutils ld.gold linker.
|
||||||
|
+ # This case should catch at least arm-unknown-linux-gnueabihf and
|
||||||
|
+ # arm-linux-androideabi.
|
||||||
|
+ FP_ARG_WITH_PATH_GNU_PROG([LD_GOLD], [ld.gold], [ld.gold])
|
||||||
|
+ LdCmd="$LD_GOLD"
|
||||||
|
+ ;;
|
||||||
|
+*)
|
||||||
|
+ LdCmd="$LD"
|
||||||
|
+ ;;
|
||||||
|
+esac
|
||||||
|
AC_SUBST([LdCmd])
|
||||||
|
|
||||||
|
dnl ** Which nm to use?
|
@ -1,17 +0,0 @@
|
|||||||
Patch by nomeata: https://ghc.haskell.org/trac/ghc/ticket/8976#comment:12
|
|
||||||
|
|
||||||
Index: ghc-7.8.3.20141119/aclocal.m4
|
|
||||||
===================================================================
|
|
||||||
--- ghc-7.8.3.20141119.orig/aclocal.m4 2014-12-08 18:49:28.207171714 +0100
|
|
||||||
+++ ghc-7.8.3.20141119/aclocal.m4 2014-12-08 19:03:06.815522917 +0100
|
|
||||||
@@ -553,6 +553,10 @@
|
|
||||||
$3="$$3 -D_HPUX_SOURCE"
|
|
||||||
$5="$$5 -D_HPUX_SOURCE"
|
|
||||||
;;
|
|
||||||
+ arm*)
|
|
||||||
+ # On arm, link using gold
|
|
||||||
+ $3="$$3 -fuse-ld=gold"
|
|
||||||
+ ;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
# If gcc knows about the stack protector, turn it off.
|
|
Loading…
Reference in new issue