import gegl04-0.4.48-4.el10

i10ce changed/i10ce/gegl04-0.4.48-4.el10
Arkady L. Shane 1 month ago
parent 7cb803b6b2
commit 60efbdbc9b
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -1 +1 @@
055c28bb3c942f85b744201009ac8e02e4182624 SOURCES/gegl-0.4.34.tar.xz d051906c8339e1913a30a379ee5a86bf6e76ddf8 SOURCES/gegl-0.4.48.tar.xz

2
.gitignore vendored

@ -1 +1 @@
SOURCES/gegl-0.4.34.tar.xz SOURCES/gegl-0.4.48.tar.xz

@ -1,21 +0,0 @@
diff -up gegl-0.4.34/gegl/meson.build.orig gegl-0.4.34/gegl/meson.build
--- gegl-0.4.34/gegl/meson.build.orig 2022-11-04 14:51:55.429964084 +0100
+++ gegl-0.4.34/gegl/meson.build 2022-11-04 14:52:57.611332244 +0100
@@ -92,8 +92,7 @@ install_headers(gegl_headers,
gegl_ldflags = os_osx ? ['-framework', 'OpenCL'] : []
opencl_dep = declare_dependency(
- sources : [opencl_headers],
- link_with : [gegl_sources],
+ sources : [opencl_headers],
)
gegl_lib = library(api_name,
@@ -105,6 +104,7 @@ gegl_lib = library(api_name,
gio,
math,
gmodule,
+ opencl_dep,
],
c_args: gegl_cflags,
link_args: gegl_ldflags,

@ -1,20 +1,37 @@
## START: Set by rpmautospec
## (rpmautospec version 0.6.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 4;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
%global apiver 0.4 %global apiver 0.4
%if 0%{?rhel}
%bcond lensfun 0
%else
%bcond lensfun 1
%endif
# Disable docs until https://gitlab.gnome.org/GNOME/gegl/-/issues/363 is fixed
# Due to babl update
%bcond docs 0
Name: gegl04 Name: gegl04
Version: 0.4.34 Version: 0.4.48
Release: 2%{?dist} Release: %autorelease
Summary: Graph based image processing framework Summary: Graph based image processing framework
# The binary is under the GPL, while the libs are under LGPL. # The binary is under the GPL, while the libs are under LGPL.
# The main package only installs the libs, which makes the license: License: GPL-3.0-or-later AND LGPL-3.0-or-later
License: LGPLv3+ URL: https://www.gegl.org/
URL: http://www.gegl.org/
Source0: http://download.gimp.org/pub/gegl/%{apiver}/gegl-%{version}.tar.xz Source0: http://download.gimp.org/pub/gegl/%{apiver}/gegl-%{version}.tar.xz
Patch0: gegl04-openexr.patch Patch0: gegl04-openexr.patch
Patch1: gegl04-gtk.patch Patch1: gegl04-gtk.patch
# https://gitlab.gnome.org/GNOME/gegl/-/commit/54f760de6a0e14487ccfb033e270aa6a80ee66e2
Patch2: gegl04-meson.patch
BuildRequires: chrpath BuildRequires: chrpath
BuildRequires: enscript BuildRequires: enscript
@ -28,8 +45,9 @@ BuildRequires: perl-interpreter
BuildRequires: ruby BuildRequires: ruby
BuildRequires: suitesparse-devel BuildRequires: suitesparse-devel
BuildRequires: vala BuildRequires: vala
BuildRequires: asciidoc
BuildRequires: pkgconfig(babl) >= 0.1.78 BuildRequires: pkgconfig(babl-0.1) >= 0.1.100
BuildRequires: pkgconfig(cairo) >= 1.12.2 BuildRequires: pkgconfig(cairo) >= 1.12.2
BuildRequires: pkgconfig(exiv2) >= 0.25 BuildRequires: pkgconfig(exiv2) >= 0.25
BuildRequires: pkgconfig(gdk-pixbuf-2.0) >= 2.32.0 BuildRequires: pkgconfig(gdk-pixbuf-2.0) >= 2.32.0
@ -38,6 +56,9 @@ BuildRequires: pkgconfig(glib-2.0) >= 2.44.0
BuildRequires: pkgconfig(jasper) >= 1.900.1 BuildRequires: pkgconfig(jasper) >= 1.900.1
BuildRequires: pkgconfig(json-glib-1.0) BuildRequires: pkgconfig(json-glib-1.0)
BuildRequires: pkgconfig(lcms2) >= 2.8 BuildRequires: pkgconfig(lcms2) >= 2.8
%if %{with lensfun}
BuildRequires: pkgconfig(lensfun) >= 0.2.5
%endif
BuildRequires: pkgconfig(libraw) >= 0.15.4 BuildRequires: pkgconfig(libraw) >= 0.15.4
BuildRequires: pkgconfig(libpng) >= 1.6.0 BuildRequires: pkgconfig(libpng) >= 1.6.0
BuildRequires: pkgconfig(librsvg-2.0) >= 2.40.6 BuildRequires: pkgconfig(librsvg-2.0) >= 2.40.6
@ -91,6 +112,7 @@ The %{name}-devel package contains libraries and header files for
developing applications that use GEGL API version %{apiver}. developing applications that use GEGL API version %{apiver}.
%if %{with docs}
%package devel-docs %package devel-docs
Summary: Documentation files for developing with %{name} Summary: Documentation files for developing with %{name}
Requires: %{name}%{?_isa} = %{version}-%{release} Requires: %{name}%{?_isa} = %{version}-%{release}
@ -102,12 +124,12 @@ Conflicts: gegl-devel < 0.4
%description devel-docs %description devel-docs
The %{name}-devel-docs package contains documentation files for developing The %{name}-devel-docs package contains documentation files for developing
applications that use GEGL API version %{apiver}. applications that use GEGL API version %{apiver}.
%endif
%package tools %package tools
Summary: Command line tools for %{name} Summary: Command line tools for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release} Requires: %{name}%{?_isa} = %{version}-%{release}
License: GPLv3+
Obsoletes: gegl03-tools < 0.3.31 Obsoletes: gegl03-tools < 0.3.31
Conflicts: gegl < 0.4 Conflicts: gegl < 0.4
@ -121,7 +143,7 @@ GEGL library.
%build %build
%meson --auto-features=auto -Ddocs=true -Dgtk-doc=true %meson --auto-features=auto %{!?with_docs:-Ddocs=false -Dgtk-doc=false}%{?with_docs:-Ddocs=true -Dgtk-doc=true}
%meson_build %meson_build
@ -166,8 +188,10 @@ chrpath --delete %{buildroot}%{_libdir}/gegl-%{apiver}/*.so
%{_datadir}/vala/vapi/gegl-%{apiver}.deps %{_datadir}/vala/vapi/gegl-%{apiver}.deps
%{_datadir}/vala/vapi/gegl-%{apiver}.vapi %{_datadir}/vala/vapi/gegl-%{apiver}.vapi
%if %{with docs}
%files devel-docs %files devel-docs
%doc %{_datadir}/gtk-doc/ %doc %{_datadir}/gtk-doc/
%endif
%files tools %files tools
%license COPYING %license COPYING
@ -175,131 +199,101 @@ chrpath --delete %{buildroot}%{_libdir}/gegl-%{apiver}/*.so
%changelog %changelog
* Fri Nov 04 2022 Tomas Popela <tpopela@redhat.com> - 0.4.34-2 * Wed Jan 01 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.4.48-4
- Fix FTBFS for a possible Meson rebase - Rebuilt for MSVSphere 10
- Resolves: rhbz#2140107
* Wed Feb 02 2022 Josef Ridky <jridky@redhat.com> - 0.4.34-1
- New upstream release 0.4.34 (#2045018)
- Fix CVE-2021-45463
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.4.30-5
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688
* Wed Jun 30 2021 Josef Ridky <jridky@redhat.com> - 0.4.30-4
- Remove lensfun from buildrequires (#1975916)
* Fri Apr 16 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.4.30-3 ## START: Generated by rpmautospec
- Disable luajit on RHEL * Thu Jul 18 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.48-4
Resolves: #1950052 - Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 0.4.30-2
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
* Fri Apr 02 2021 Kalev Lember <klember@redhat.com> - 0.4.30-1
- Update to 0.4.30
* Thu Jan 28 2021 Josef Ridky <jridky@redhat.com> - 0.4.26-4 * Mon Jul 01 2024 Robert-André Mauchin <zebob.m@gmail.com> - 0.4.48-3
- Disable OpenEXR on RHEL - Disable docs to fix FTBFS
- Rebuilt for exiv2 0.28.2
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.26-3 * Mon Apr 22 2024 Josef Řídký <jridky@redhat.com> - 0.4.48-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild - Rebuild for new openexr
* Fri Jan 01 2021 Richard Shaw <hobbes1069@gmail.com> - 0.4.26-2 * Tue Feb 13 2024 Josef Řídký <jridky@redhat.com> - 0.4.48-1
- Rebuild for OpenEXR 2.5.3. - New upstream release 0.4.48 (#2263786)
* Mon Aug 24 2020 Josef Ridky <jridky@redhat.com> - 0.4.26-1 * Sun Feb 04 2024 Orion Poplawski <orion@nwra.com> - 0.4.46-6
- New upstream release 0.4.26 - Rebuild with suitesparse 7.6.0
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.24-2 * Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.46-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon Jun 15 2020 Josef Ridky <jridky@redhat.com> - 0.4.24-1 * Fri Jan 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.46-4
- New upstream release 0.4.24 - Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon May 11 2020 Gwyn Ciesla <gwync@protonmail.com> - 0.4.22-2 * Tue Nov 28 2023 Orion Poplawski <orion@nwra.com> - 0.4.46-3
- Rebuild for new LibRaw - Rebuild for jasper 4.1
* Wed Feb 19 2020 Josef Ridky <jridky@redhat.com> - 0.4.22-1 * Fri Nov 10 2023 Jiri Kucera <jkucera@redhat.com> - 0.4.46-2
- Update to 0.4.22 - Drop lensfun on RHEL
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.18-2 * Tue Aug 29 2023 Nils Philippsen <nils@tiptoe.de> - 0.4.46-1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild - New upstream release 0.4.46
* Mon Nov 04 2019 Kalev Lember <klember@redhat.com> - 0.4.18-1 * Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.44-3
- Update to 0.4.18 - Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
- Switch to meson build system
- Build against SDL2 instead of SDL 1
- Enable gexiv2 support
* Thu Sep 12 2019 Josef Ridky <jridky@redhat.com> -0.4.16-4 * Thu Mar 30 2023 David King <amigadave@amigadave.com> - 0.4.44-2
- Obsoletes gegl03 (#1751416) - Build against newer babl releases
* Tue Aug 27 2019 Kevin Fenzi <kevin@scrye.com> - 0.4.16-3 * Mon Mar 27 2023 Josef Řídký <jridky@redhat.com> - 0.4.44-1
- Rebuild for new libspiro - Resolves: #2142383 - new upstream release 0.4.44
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.16-2 * Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.38-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Mon Jun 10 2019 Kalev Lember <klember@redhat.com> - 0.4.16-1 * Tue Dec 20 2022 Gwyn Ciesla <gwync@protonmail.com> - 0.4.38-3
- Update to 0.4.16 - Patch for api change.
* Wed Apr 10 2019 Richard Shaw <hobbes1069@gmail.com> - 0.4.14-2 * Tue Dec 20 2022 Gwyn Ciesla <gwync@protonmail.com> - 0.4.38-2
- Rebuild for OpenEXR 2.3.0. - LibRaw rebuild
* Mon Mar 25 2019 Josef Ridky <jridky@redhat.com> - 0.4.14-1 * Mon Aug 01 2022 Josef Řídký <jridky@redhat.com> - 0.4.38-1
- version 0.4.14 - New upstream release 0.4.38
* Mon Feb 04 2019 Kalev Lember <klember@redhat.com> - 0.4.12-3 * Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.36-2
- Update BRs for vala packaging changes - Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.12-2 * Mon Mar 14 2022 Josef Řídký <jridky@redhat.com> - 0.4.36-1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild - New upstream release 0.4.36
* Sat Nov 10 2018 Nils Philippsen <nils@tiptoe.de> - 0.4.12-1 * Sun Feb 13 2022 Josef Řídký <jridky@redhat.com> - 0.4.34-4
- version 0.4.12 - Rebuilt for libjasper.so.6
* Fri Aug 24 2018 Debarshi Ray <rishi@fedoraproject.org> - 0.4.8-2 * Sun Feb 13 2022 Josef Řídký <jridky@redhat.com> - 0.4.34-3
- Drop the run-time requirement on ImageMagick - Rebuild for new jasper library
* Mon Aug 20 2018 Nils Philippsen <nils@tiptoe.de> - 0.4.8-1 * Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.34-2
- version 0.4.8 - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Thu Jul 19 2018 Christian Dersch <lupinix@fedoraproject.org> - 0.4.4-3 * Tue Jan 04 2022 Josef Řídký <jridky@redhat.com> - 0.4.34-1
- Rebuilt for LibRaw soname bump - Resolves: #2035384 - fix CVE-2021-45463
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.4-2 * Mon Oct 18 2021 Josef Řídký <jridky@redhat.com> - 0.4.32-1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild - New upstream release
* Thu Jul 05 2018 Nils Philippsen <nils@tiptoe.de> - 0.4.4-1 * Sat Aug 21 2021 Richard Shaw <hobbes1069@gmail.com> - 0.4.30-6
- version 0.4.4 - Rebuild for OpenEXR/Imath 3.1.
* Mon May 21 2018 Nils Philippsen <nils@tiptoe.de> - 0.4.2-2 * Mon Aug 02 2021 Richard Shaw <hobbes1069@gmail.com> - 0.4.30-5
- split off devel docs - Rebuild for OpenEXR 3.
- let gegl04-devel-docs explicitly conflict with old gegl-devel (#1577595)
* Mon May 21 2018 Nils Philippsen <nils@tiptoe.de> - 0.4.2-1 * Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.30-4
- version 0.4.2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed May 02 2018 Nils Philippsen <nils@tiptoe.de> - 0.4.0-2 * Sun Jun 06 2021 Richard Shaw <hobbes1069@gmail.com> - 0.4.30-3
- don't require asciidoc for building - Add missing openexr header to support future openexr 3.0 build.
- always install unversioned executables
* Sat Apr 28 2018 Nils Philippsen <nils@tiptoe.de> - 0.4.0-1 * Thu Apr 15 2021 Debarshi Ray <debarshir@gnome.org> - 0.4.30-2
- import into Fedora dist-git - Disable luajit on RHEL
* Fri Apr 27 2018 Nils Philippsen <nils@tiptoe.de> - 0.4.0-0.4
- own all created directories
- remove rpaths
* Fri Apr 27 2018 Nils Philippsen <nils@tiptoe.de> - 0.4.0-0.3
- use %%ldconfig_scriptlets macro
* Fri Apr 27 2018 Nils Philippsen <nils@tiptoe.de> - 0.4.0-0.2 * Fri Apr 02 2021 Kalev Lember <klember@redhat.com> - 0.4.30-1
- add tools subpackage - Update to 0.4.30
- tidy up remains of 0.3
- add back gtk-doc documentation
* Fri Apr 27 2018 Nils Philippsen <nils@tiptoe.de> - 0.4.0-0.1 * Thu Jan 28 2021 Josef Řídký <jridky@redhat.com> - 0.4.26-4
- initial import - RPMAUTOSPEC: unresolvable merge
## END: Generated by rpmautospec

Loading…
Cancel
Save