Remove Python 2 subpackage (#1627322)

epel9
Miro Hrončok 7 years ago
parent 88a3f0fe1c
commit 25c07a4c73

@ -1,13 +0,0 @@
--- gdcm-2.4.0.orig/Wrapping/Python/CMakeLists.txt 2013-10-16 10:28:54.000000000 +0200
+++ gdcm-2.4.0/Wrapping/Python/CMakeLists.txt 2013-10-21 10:08:42.803226233 +0200
@@ -44,8 +44,8 @@
${CMAKE_CURRENT_SOURCE_DIR}
)
-find_package(PythonInterp REQUIRED)
-find_package(PythonLibs REQUIRED)
+find_package(PythonInterp 2.7 REQUIRED)
+find_package(PythonLibs 2.7 REQUIRED)
# TODO Need to check consistency python interp and python libs...
mark_as_advanced(PYTHON_LIBRARY PYTHON_INCLUDE_PATH)
# Lamest excuse ever:

@ -1,6 +1,6 @@
Name: gdcm
Version: 2.8.4
Release: 10%{?dist}
Release: 11%{?dist}
Summary: Grassroots DiCoM is a C++ library to parse DICOM medical files
License: BSD
URL: http://gdcm.sourceforge.net/wiki/index.php/Main_Page
@ -12,7 +12,6 @@ Patch2: gdcm-2.4.0-install2libarch.patch
Patch3: gdcm-2.4.0-no-versioned-dir.patch
# From http://public.kitware.com/pipermail/vtkusers/2013-February/127377.html
#Patch4: gdcm-0005-support-vtk6.patch
Patch5: gdcm-2.4.0-find-python27.patch
Patch6: gdcm-2.6-fix-cmake-config-paths.patch
Patch7: gdcm-2.8.4-fix-manpage-gen.patch
Patch8: gdcm-2.8.4-fix-poppler.patch
@ -35,7 +34,6 @@ BuildRequires: openssl-devel
BuildRequires: pkgconfig(libopenjp2)
#BuildRequires: /usr/bin/pdflatex
BuildRequires: poppler-devel
BuildRequires: python2-devel
BuildRequires: python3-devel
BuildRequires: swig
BuildRequires: json-c-devel
@ -88,22 +86,9 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
%description examples
GDCM examples
%package -n python2-gdcm
Summary: Python binding for GDCM
%{?python_provide:%python_provide python2-gdcm}
# Remove before F30
Provides: %{name}-python = %{version}-%{release}
Provides: %{name}-python%{?_isa} = %{version}-%{release}
Obsoletes: %{name}-python < %{version}-%{release}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description -n python2-gdcm
You should install the gdcm-python package if you would like to
used this library with python
%package -n python3-gdcm
Summary: Python binding for GDCM
%{?python_provide:%python_provide python2-gdcm}
%{?python_provide:%python_provide python3-gdcm}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description -n python3-gdcm
@ -142,56 +127,7 @@ rm -rf Utilities/wxWidgets
# Needed for testing:
#rm -rf Utilities/gdcmmd5
# prepare python3 build
rm -rf %{py3dir}
cp -a . %{py3dir}
# apply patch after copying files for python3 build
%patch5 -p 1
%build
# build python3 build
pushd %{py3dir}
mkdir -p %{_target_platform}
pushd %{_target_platform}
%cmake .. \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DGDCM_INSTALL_PACKAGE_DIR=%{_libdir}/cmake/%{name} \
-DGDCM_INSTALL_INCLUDE_DIR=%{_includedir}/%{name} \
-DGDCM_INSTALL_DOC_DIR=%{_docdir}/%{name} \
-DGDCM_INSTALL_MAN_DIR=%{_mandir} \
-DGDCM_INSTALL_LIB_DIR=%{_libdir} \
-DGDCM_BUILD_TESTING:BOOL=OFF \
-DGDCM_DATA_ROOT=../gdcmData/ \
-DGDCM_BUILD_EXAMPLES:BOOL=OFF \
-DGDCM_DOCUMENTATION:BOOL=OFF \
-DGDCM_WRAP_PYTHON:BOOL=ON \
-DPYTHON_EXECUTABLE=%{__python3} \
-DGDCM_INSTALL_PYTHONMODULE_DIR=%{python3_sitearch} \
-DGDCM_WRAP_JAVA:BOOL=OFF \
-DGDCM_BUILD_SHARED_LIBS:BOOL=ON \
-DGDCM_BUILD_APPLICATIONS:BOOL=OFF \
-DCMAKE_BUILD_TYPE:STRING="RelWithDebInfo" \
-DGDCM_USE_VTK:BOOL=OFF \
-DGDCM_USE_SYSTEM_CHARLS:BOOL=ON \
-DGDCM_USE_SYSTEM_EXPAT:BOOL=ON \
-DGDCM_USE_SYSTEM_OPENJPEG:BOOL=ON \
-DGDCM_USE_SYSTEM_ZLIB:BOOL=ON \
-DGDCM_USE_SYSTEM_UUID:BOOL=ON \
-DGDCM_USE_SYSTEM_LJPEG:BOOL=OFF \
-DGDCM_USE_SYSTEM_OPENSSL:BOOL=ON \
-DGDCM_USE_JPEGLS:BOOL=ON \
-DGDCM_USE_SYSTEM_LIBXML2:BOOL=OFF \
-DGDCM_USE_SYSTEM_JSON:BOOL=OFF \
-DGDCM_USE_SYSTEM_POPPLER:BOOL=OFF
popd
%make_build -C %{_target_platform}
popd
# end python3
mkdir -p %{_target_platform}
pushd %{_target_platform}
@ -208,8 +144,8 @@ pushd %{_target_platform}
-DGDCM_DOCUMENTATION:BOOL=ON \
-DGDCM_PDF_DOCUMENTATION:BOOL=OFF \
-DGDCM_WRAP_PYTHON:BOOL=ON \
-DPYTHON_EXECUTABLE=%{__python2} \
-DGDCM_INSTALL_PYTHONMODULE_DIR=%{python2_sitearch} \
-DPYTHON_EXECUTABLE=%{__python3} \
-DGDCM_INSTALL_PYTHONMODULE_DIR=%{python3_sitearch} \
-DGDCM_WRAP_JAVA:BOOL=OFF \
-DGDCM_BUILD_SHARED_LIBS:BOOL=ON \
-DGDCM_BUILD_APPLICATIONS:BOOL=ON \
@ -236,13 +172,8 @@ popd
%make_build -C %{_target_platform}
%install
# install python3 build
pushd %{py3dir}
make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
install -d $RPM_BUILD_ROOT%{python3_sitearch}
popd
make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
## Cleaning Example dir from cmake cache files + remove 0-length files
find %{_builddir}/%{?buildsubdir}/Examples -depth -name CMakeFiles | xargs rm -rf
@ -256,10 +187,6 @@ cp -r %{_builddir}/%{?buildsubdir}/Examples $RPM_BUILD_ROOT%{_datadir}/%{name}/
# 11,40,48,49,107-109,111-114,130-135,146,149,,151-154,157,194,216,219
make test -C %{_target_platform} || exit 0
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%doc AUTHORS Copyright.txt README.Copyright.txt README.txt
%{_libdir}/*.so.*
@ -282,16 +209,15 @@ make test -C %{_target_platform} || exit 0
%files examples
%{_datadir}/%{name}/Examples/
%files -n python2-gdcm
%{python2_sitearch}/%{name}*.py*
%{python2_sitearch}/_%{name}swig.so
%files -n python3-gdcm
%{python3_sitearch}/%{name}*.py
%{python3_sitearch}/_%{name}swig.so
%{python3_sitearch}/__pycache__/%{name}*
%changelog
* Mon Sep 17 2018 Miro Hrončok <mhroncok@redhat.com> - 2.8.4-11
- Remove Python 2 subpackage (#1627322)
* Tue Aug 14 2018 Marek Kasik <mkasik@redhat.com> - 2.8.4-10
- Rebuild for poppler-0.67.0

Loading…
Cancel
Save