Rebuild for poppler-0.67.0

epel9
Marek Kasik 7 years ago
parent 6fa4502468
commit 88a3f0fe1c

@ -0,0 +1,40 @@
--- gdcm-2.8.4/Applications/Cxx/gdcminfo.cxx
+++ gdcm-2.8.4/Applications/Cxx/gdcminfo.cxx
@@ -188,7 +188,7 @@ static int checkdeflated(const char *nam
static std::string getInfoDate(Dict *infoDict, const char *key)
{
Object obj;
- char *s;
+ const char *s;
int year, mon, day, hour, min, sec, n;
struct tm tmStruct;
//char buf[256];
@@ -255,7 +255,7 @@ static std::string getInfoDate(Dict *inf
static std::string getInfoString(Dict *infoDict, const char *key, UnicodeMap *uMap)
{
Object obj;
- GooString *s1;
+ const GooString *s1;
GBool isUnicode;
Unicode u;
char buf[8];
--- gdcm-2.8.4/Applications/Cxx/gdcmpdf.cxx
+++ gdcm-2.8.4/Applications/Cxx/gdcmpdf.cxx
@@ -37,7 +37,7 @@
static std::string getInfoDate(Dict *infoDict, const char *key)
{
Object obj;
- char *s;
+ const char *s;
int year, mon, day, hour, min, sec, n;
struct tm tmStruct;
//char buf[256];
@@ -104,7 +104,7 @@ static std::string getInfoDate(Dict *inf
static std::string getInfoString(Dict *infoDict, const char *key, UnicodeMap *uMap, GBool & unicode)
{
Object obj;
- GooString *s1;
+ const GooString *s1;
GBool isUnicode = gFalse;
Unicode u;
char buf[8];

@ -1,6 +1,6 @@
Name: gdcm
Version: 2.8.4
Release: 9%{?dist}
Release: 10%{?dist}
Summary: Grassroots DiCoM is a C++ library to parse DICOM medical files
License: BSD
URL: http://gdcm.sourceforge.net/wiki/index.php/Main_Page
@ -16,6 +16,7 @@ Patch5: gdcm-2.4.0-find-python27.patch
Patch6: gdcm-2.6-fix-cmake-config-paths.patch
Patch7: gdcm-2.8.4-fix-manpage-gen.patch
Patch8: gdcm-2.8.4-fix-poppler.patch
Patch9: gdcm-2.8.4-poppler-0.67.0.patch
BuildRequires: CharLS-devel >= 1.0
BuildRequires: cmake
@ -118,6 +119,7 @@ used this library with python
%patch6 -p 1
%patch7 -p 1
%patch8 -p 1
%patch9 -p 1
# Fix cmake command
sed -i.backup 's/add_dependency/add_dependencies/' Utilities/doxygen/CMakeLists.txt
@ -290,6 +292,9 @@ make test -C %{_target_platform} || exit 0
%{python3_sitearch}/__pycache__/%{name}*
%changelog
* Tue Aug 14 2018 Marek Kasik <mkasik@redhat.com> - 2.8.4-10
- Rebuild for poppler-0.67.0
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.4-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

Loading…
Cancel
Save