Rebuild for poppler-0.73.0

epel9
Marek Kasik 6 years ago
parent 25c07a4c73
commit 2396fa5a37

@ -0,0 +1,99 @@
--- gdcm-2.8.4/Applications/Cxx/gdcminfo.cxx
+++ gdcm-2.8.4/Applications/Cxx/gdcminfo.cxx
@@ -200,7 +200,7 @@ static std::string getInfoDate(Dict *inf
if (infoDict->lookup((char*)key, &obj)->isString())
#endif
{
- s = obj.getString()->getCString();
+ s = obj.getString()->c_str();
if (s[0] == 'D' && s[1] == ':')
{
s += 2;
@@ -256,7 +256,7 @@ static std::string getInfoString(Dict *i
{
Object obj;
const GooString *s1;
- GBool isUnicode;
+ bool isUnicode;
Unicode u;
char buf[8];
int i, n;
@@ -272,12 +272,12 @@ static std::string getInfoString(Dict *i
if ((s1->getChar(0) & 0xff) == 0xfe &&
(s1->getChar(1) & 0xff) == 0xff)
{
- isUnicode = gTrue;
+ isUnicode = true;
i = 2;
}
else
{
- isUnicode = gFalse;
+ isUnicode = false;
i = 0;
}
while (i < obj.getString()->getLength())
@@ -523,10 +523,10 @@ static int ProcessOneFile( std::string c
int pages = doc->getNumPages();
const char *encrypted = doc->isEncrypted() ? "yes" : "no";
// printf("yes (print:%s copy:%s change:%s addNotes:%s)\n",
- // doc->okToPrint(gTrue) ? "yes" : "no",
- // doc->okToCopy(gTrue) ? "yes" : "no",
- // doc->okToChange(gTrue) ? "yes" : "no",
- // doc->okToAddNotes(gTrue) ? "yes" : "no");
+ // doc->okToPrint(true) ? "yes" : "no",
+ // doc->okToCopy(true) ? "yes" : "no",
+ // doc->okToChange(true) ? "yes" : "no",
+ // doc->okToAddNotes(true) ? "yes" : "no");
// print linearization info
const char *optimized = doc->isLinearized() ? "yes" : "no";
--- gdcm-2.8.4/Applications/Cxx/gdcmpdf.cxx
+++ gdcm-2.8.4/Applications/Cxx/gdcmpdf.cxx
@@ -49,7 +49,7 @@ static std::string getInfoDate(Dict *inf
if (infoDict->lookup((char*)key, &obj)->isString())
#endif
{
- s = obj.getString()->getCString();
+ s = obj.getString()->c_str();
if (s[0] == 'D' && s[1] == ':')
{
s += 2;
@@ -101,11 +101,11 @@ static std::string getInfoDate(Dict *inf
return out;
}
-static std::string getInfoString(Dict *infoDict, const char *key, UnicodeMap *uMap, GBool & unicode)
+static std::string getInfoString(Dict *infoDict, const char *key, UnicodeMap *uMap, bool & unicode)
{
Object obj;
const GooString *s1;
- GBool isUnicode = gFalse;
+ bool isUnicode = false;
Unicode u;
char buf[8];
int i, n;
@@ -121,12 +121,12 @@ static std::string getInfoString(Dict *i
if ((s1->getChar(0) & 0xff) == 0xfe &&
(s1->getChar(1) & 0xff) == 0xff)
{
- isUnicode = gTrue;
+ isUnicode = true;
i = 2;
}
else
{
- isUnicode = gFalse;
+ isUnicode = false;
i = 0;
}
while (i < obj.getString()->getLength())
@@ -397,7 +397,7 @@ http://msdn.microsoft.com/en-us/library/
std::string creationdate;
std::string moddate;
- GBool isUnicode = gFalse;
+ bool isUnicode = false;
if (doc->isOk())
{
#ifdef LIBPOPPLER_NEW_OBJECT_API

@ -1,6 +1,6 @@
Name: gdcm
Version: 2.8.4
Release: 11%{?dist}
Release: 12%{?dist}
Summary: Grassroots DiCoM is a C++ library to parse DICOM medical files
License: BSD
URL: http://gdcm.sourceforge.net/wiki/index.php/Main_Page
@ -16,6 +16,7 @@ Patch6: gdcm-2.6-fix-cmake-config-paths.patch
Patch7: gdcm-2.8.4-fix-manpage-gen.patch
Patch8: gdcm-2.8.4-fix-poppler.patch
Patch9: gdcm-2.8.4-poppler-0.67.0.patch
Patch10: gdcm-2.8.4-poppler-0.73.0.patch
BuildRequires: CharLS-devel >= 1.0
BuildRequires: cmake
@ -105,6 +106,7 @@ used this library with python
%patch7 -p 1
%patch8 -p 1
%patch9 -p 1
%patch10 -p 1
# Fix cmake command
sed -i.backup 's/add_dependency/add_dependencies/' Utilities/doxygen/CMakeLists.txt
@ -215,6 +217,9 @@ make test -C %{_target_platform} || exit 0
%{python3_sitearch}/__pycache__/%{name}*
%changelog
* Fri Jan 25 2019 Marek Kasik <mkasik@redhat.com> - 2.8.4-12
- Rebuild for poppler-0.73.0
* Mon Sep 17 2018 Miro Hrončok <mhroncok@redhat.com> - 2.8.4-11
- Remove Python 2 subpackage (#1627322)

Loading…
Cancel
Save