commit
1c583ed1b1
@ -0,0 +1 @@
|
|||||||
|
3efc2253564a2ca8be0a5cf9aba3e4b5f544ee22 SOURCES/elfutils-0.182.tar.bz2
|
@ -0,0 +1 @@
|
|||||||
|
SOURCES/elfutils-0.182.tar.bz2
|
@ -0,0 +1,43 @@
|
|||||||
|
commit f172a31c56405750114924eba0786999bccc501f
|
||||||
|
Author: Mark Wielaard <mark@klomp.org>
|
||||||
|
Date: Mon Nov 2 15:20:54 2020 +0100
|
||||||
|
|
||||||
|
tests: Create bogus R/nothing.rpm with cyclic symlink.
|
||||||
|
|
||||||
|
We used to try to trigger an error during debuginfod scanning using
|
||||||
|
a chmod 000 file. But this doesn't always result in an error. Create
|
||||||
|
a cyclic symlink instead, which always results in a failure to open/read.
|
||||||
|
|
||||||
|
Signed-off-by: Mark Wielaard <mark@klomp.org>
|
||||||
|
|
||||||
|
diff --git a/tests/ChangeLog b/tests/ChangeLog
|
||||||
|
index 57fc4c8e..2f8b75c3 100644
|
||||||
|
--- a/tests/ChangeLog
|
||||||
|
+++ b/tests/ChangeLog
|
||||||
|
@@ -1,3 +1,8 @@
|
||||||
|
+2020-11-02 Mark Wielaard <mark@klomp.org>
|
||||||
|
+
|
||||||
|
+ * run-debuginfod-find.sh: Create bogus R/nothing.rpm with cyclic
|
||||||
|
+ symlink instead of chmod 000.
|
||||||
|
+
|
||||||
|
2020-10-31 Mark Wielaard <mark@klomp.org>
|
||||||
|
|
||||||
|
* dwfl-proc-attach.c (dlopen): New external function override.
|
||||||
|
diff --git a/tests/run-debuginfod-find.sh b/tests/run-debuginfod-find.sh
|
||||||
|
index 48dbc7d4..5af45667 100755
|
||||||
|
--- a/tests/run-debuginfod-find.sh
|
||||||
|
+++ b/tests/run-debuginfod-find.sh
|
||||||
|
@@ -95,9 +95,10 @@ wait_ready()
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
|
||||||
|
-# create a 000 empty .rpm file to evoke a metric-visible error
|
||||||
|
-touch R/nothing.rpm
|
||||||
|
-chmod 000 R/nothing.rpm
|
||||||
|
+# create a bogus .rpm file to evoke a metric-visible error
|
||||||
|
+# Use a cyclic symlink instead of chmod 000 to make sure even root
|
||||||
|
+# would see an error (running the testsuite under root is NOT encouraged).
|
||||||
|
+ln -s R/nothing.rpm R/nothing.rpm
|
||||||
|
|
||||||
|
env LD_LIBRARY_PATH=$ldpath DEBUGINFOD_URLS= ${abs_builddir}/../debuginfod/debuginfod $VERBOSE -F -R -d $DB -p $PORT1 -t0 -g0 --fdcache-fds 1 --fdcache-mbs 2 -Z .tar.xz -Z .tar.bz2=bzcat -v R F Z L > vlog4 2>&1 &
|
||||||
|
PID1=$!
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,52 @@
|
|||||||
|
diff --git a/debuginfod/Makefile.am b/debuginfod/Makefile.am
|
||||||
|
index 52ead30a..9d7ce408 100644
|
||||||
|
--- a/debuginfod/Makefile.am
|
||||||
|
+++ b/debuginfod/Makefile.am
|
||||||
|
@@ -34,7 +34,7 @@ AM_CPPFLAGS += -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
|
||||||
|
-I$(srcdir)/../libdw -I$(srcdir)/../libdwelf \
|
||||||
|
$(libmicrohttpd_CFLAGS) $(libcurl_CFLAGS) $(sqlite3_CFLAGS) \
|
||||||
|
$(libarchive_CFLAGS)
|
||||||
|
-VERSION = 1
|
||||||
|
+VERSION = dts.1
|
||||||
|
|
||||||
|
# Disable eu- prefixing for artifacts (binaries & man pages) in this
|
||||||
|
# directory, since they do not conflict with binutils tools.
|
||||||
|
diff --git a/libasm/Makefile.am b/libasm/Makefile.am
|
||||||
|
index a92b63ad..a92f06de 100644
|
||||||
|
--- a/libasm/Makefile.am
|
||||||
|
+++ b/libasm/Makefile.am
|
||||||
|
@@ -31,7 +31,7 @@ include $(top_srcdir)/config/eu.am
|
||||||
|
AM_CPPFLAGS += -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl -I$(top_srcdir)/libdw -I$(top_srcdir)/libdwelf
|
||||||
|
|
||||||
|
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
||||||
|
-VERSION = 1
|
||||||
|
+VERSION = dts.1
|
||||||
|
|
||||||
|
lib_LIBRARIES = libasm.a
|
||||||
|
noinst_LIBRARIES = libasm_pic.a
|
||||||
|
diff --git a/libdw/Makefile.am b/libdw/Makefile.am
|
||||||
|
index ef566399..c6493a08 100644
|
||||||
|
--- a/libdw/Makefile.am
|
||||||
|
+++ b/libdw/Makefile.am
|
||||||
|
@@ -32,7 +32,7 @@ if BUILD_STATIC
|
||||||
|
AM_CFLAGS += $(fpic_CFLAGS)
|
||||||
|
endif
|
||||||
|
AM_CPPFLAGS += -I$(srcdir)/../libelf -I$(srcdir)/../libdwelf -pthread
|
||||||
|
-VERSION = 1
|
||||||
|
+VERSION = dts.1
|
||||||
|
|
||||||
|
lib_LIBRARIES = libdw.a
|
||||||
|
noinst_LIBRARIES = libdw_pic.a
|
||||||
|
diff --git a/libelf/Makefile.am b/libelf/Makefile.am
|
||||||
|
index 51e86dc8..988d3ebe 100644
|
||||||
|
--- a/libelf/Makefile.am
|
||||||
|
+++ b/libelf/Makefile.am
|
||||||
|
@@ -32,7 +32,7 @@ if BUILD_STATIC
|
||||||
|
AM_CFLAGS += $(fpic_CFLAGS)
|
||||||
|
endif
|
||||||
|
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
||||||
|
-VERSION = 1
|
||||||
|
+VERSION = dts.1
|
||||||
|
|
||||||
|
lib_LIBRARIES = libelf.a
|
||||||
|
noinst_LIBRARIES = libelf_pic.a
|
@ -0,0 +1,5 @@
|
|||||||
|
/* GNU ld script
|
||||||
|
|
||||||
|
Libraries in Developer Toolset are linked in statically to allow
|
||||||
|
compiled binaries to run even when DTS is not installed. */
|
||||||
|
INPUT(libasm.ar)
|
@ -0,0 +1,5 @@
|
|||||||
|
/* GNU ld script
|
||||||
|
|
||||||
|
Libraries in Developer Toolset are linked in statically to allow
|
||||||
|
compiled binaries to run even when DTS is not installed. */
|
||||||
|
INPUT(libasm.ar)
|
@ -0,0 +1,7 @@
|
|||||||
|
/* GNU ld script
|
||||||
|
|
||||||
|
Static libraries in Developer Toolset are named .ar to prevent
|
||||||
|
brp-strip-static-archive from stripping them. But we still want
|
||||||
|
them to be found in cases like -static -lxyz, hence this linker
|
||||||
|
script. */
|
||||||
|
INPUT(libdebuginfod.ar)
|
@ -0,0 +1,6 @@
|
|||||||
|
/* GNU ld script
|
||||||
|
|
||||||
|
Libraries in Developer Toolset are linked in statically to allow
|
||||||
|
compiled binaries to run even when DTS is not installed. */
|
||||||
|
INPUT(libdebuginfod.ar)
|
||||||
|
INPUT(-lcurl)
|
@ -0,0 +1,7 @@
|
|||||||
|
/* GNU ld script
|
||||||
|
|
||||||
|
Static libraries in Developer Toolset are named .ar to prevent
|
||||||
|
brp-strip-static-archive from stripping them. But we still want
|
||||||
|
them to be found in cases like -static -lxyz, hence this linker
|
||||||
|
script. */
|
||||||
|
GROUP(libdw.ar -lpthread -ldl)
|
@ -0,0 +1,7 @@
|
|||||||
|
/* GNU ld script
|
||||||
|
|
||||||
|
Libraries in Developer Toolset are linked in statically to allow
|
||||||
|
compiled binaries to run even when DTS is not installed. */
|
||||||
|
GROUP(libdw.ar -lpthread -ldl)
|
||||||
|
INPUT(-lzstd -llzma -lbz2 -lz)
|
||||||
|
INPUT(-lelf)
|
@ -0,0 +1,7 @@
|
|||||||
|
/* GNU ld script
|
||||||
|
|
||||||
|
Static libraries in Developer Toolset are named .ar to prevent
|
||||||
|
brp-strip-static-archive from stripping them. But we still want
|
||||||
|
them to be found in cases like -static -lxyz, hence this linker
|
||||||
|
script. */
|
||||||
|
INPUT(libelf.ar)
|
@ -0,0 +1,6 @@
|
|||||||
|
/* GNU ld script
|
||||||
|
|
||||||
|
Libraries in Developer Toolset are linked in statically to allow
|
||||||
|
compiled binaries to run even when DTS is not installed. */
|
||||||
|
INPUT(libelf.ar)
|
||||||
|
INPUT(-lz)
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue