Update patch

i9ce-next changed/i9ce-next/gcc-epel-11.5.0-1.el9
Arkady L. Shane 2 months ago
parent b4ff29f00b
commit c04cdfe979
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -1,4 +1,4 @@
From 088d8e322811394203220663c3b9c925980d57a2 Mon Sep 17 00:00:00 2001 From 32a22401815f80b61fdb545c15a5fe2136337fa7 Mon Sep 17 00:00:00 2001
From: Marek Polacek <polacek@redhat.com> From: Marek Polacek <polacek@redhat.com>
Date: Tue, 1 Feb 2022 18:27:16 -0500 Date: Tue, 1 Feb 2022 18:27:16 -0500
Subject: [PATCH] configure: Implement --enable-host-pie Subject: [PATCH] configure: Implement --enable-host-pie
@ -64,27 +64,27 @@ zlib/ChangeLog:
(--enable-host-pie): New check. Set PICFLAG after this check. (--enable-host-pie): New check. Set PICFLAG after this check.
* configure: Regenerate. * configure: Regenerate.
--- ---
c++tools/Makefile.in | 11 ++++++--- c++tools/Makefile.in | 11 +++++---
c++tools/configure | 17 +++++++++++--- c++tools/configure | 17 +++++++++---
c++tools/configure.ac | 11 +++++++-- c++tools/configure.ac | 11 ++++++--
gcc/Makefile.in | 29 ++++++++++++++---------- gcc/Makefile.in | 29 ++++++++++++---------
gcc/configure | 47 +++++++++++++++++++++++++++------------ gcc/ada/gcc-interface/Makefile.in | 4 +--
gcc/configure.ac | 36 +++++++++++++++++++++--------- gcc/configure | 43 ++++++++++++++++++++++---------
gcc/d/Make-lang.in | 2 +- gcc/configure.ac | 36 +++++++++++++++++++-------
gcc/doc/install.texi | 16 +++++++++++-- gcc/doc/install.texi | 16 ++++++++++--
libcody/Makefile.in | 2 +- libcody/Makefile.in | 2 +-
libcody/configure | 30 ++++++++++++++++++++++++- libcody/configure | 30 ++++++++++++++++++++-
libcody/configure.ac | 26 ++++++++++++++++++++-- libcody/configure.ac | 26 +++++++++++++++++--
libcpp/configure | 22 +++++++++++++++++- libcpp/configure | 22 +++++++++++++++-
libcpp/configure.ac | 19 ++++++++++++++-- libcpp/configure.ac | 19 ++++++++++++--
libdecnumber/configure | 22 +++++++++++++++++- libdecnumber/configure | 22 +++++++++++++++-
libdecnumber/configure.ac | 19 ++++++++++++++-- libdecnumber/configure.ac | 19 ++++++++++++--
zlib/configure | 30 ++++++++++++++++++++----- zlib/configure | 26 ++++++++++++++++---
zlib/configure.ac | 21 ++++++++++++++--- zlib/configure.ac | 21 ++++++++++++---
17 files changed, 295 insertions(+), 65 deletions(-) 17 files changed, 292 insertions(+), 62 deletions(-)
diff --git a/c++tools/Makefile.in b/c++tools/Makefile.in diff --git a/c++tools/Makefile.in b/c++tools/Makefile.in
index d6a33613732..4d5a5b0522b 100644 index 970070620..a9391b153 100644
--- a/c++tools/Makefile.in --- a/c++tools/Makefile.in
+++ b/c++tools/Makefile.in +++ b/c++tools/Makefile.in
@@ -28,8 +28,9 @@ AUTOCONF := @AUTOCONF@ @@ -28,8 +28,9 @@ AUTOCONF := @AUTOCONF@
@ -117,10 +117,10 @@ index d6a33613732..4d5a5b0522b 100644
# copy to gcc dir so tests there can run # copy to gcc dir so tests there can run
all::../gcc/g++-mapper-server$(exeext) all::../gcc/g++-mapper-server$(exeext)
diff --git a/c++tools/configure b/c++tools/configure diff --git a/c++tools/configure b/c++tools/configure
index 742816e4253..88087009383 100755 index 742816e42..880870093 100755
--- a/c++tools/configure --- a/c++tools/configure
+++ b/c++tools/configure +++ b/c++tools/configure
@@ -630,7 +630,8 @@ CPP @@ -627,7 +627,8 @@ get_gcc_base_ver
EGREP EGREP
GREP GREP
CXXCPP CXXCPP
@ -170,7 +170,7 @@ index 742816e4253..88087009383 100755
# Check if O_CLOEXEC is defined by fcntl # Check if O_CLOEXEC is defined by fcntl
diff --git a/c++tools/configure.ac b/c++tools/configure.ac diff --git a/c++tools/configure.ac b/c++tools/configure.ac
index 6662b5ad7c9..1e42689f2eb 100644 index c89ac6a41..e77fbbd70 100644
--- a/c++tools/configure.ac --- a/c++tools/configure.ac
+++ b/c++tools/configure.ac +++ b/c++tools/configure.ac
@@ -102,8 +102,15 @@ fi @@ -102,8 +102,15 @@ fi
@ -192,7 +192,7 @@ index 6662b5ad7c9..1e42689f2eb 100644
# Check if O_CLOEXEC is defined by fcntl # Check if O_CLOEXEC is defined by fcntl
AC_CACHE_CHECK(for O_CLOEXEC, ac_cv_o_cloexec, [ AC_CACHE_CHECK(for O_CLOEXEC, ac_cv_o_cloexec, [
diff --git a/gcc/Makefile.in b/gcc/Makefile.in diff --git a/gcc/Makefile.in b/gcc/Makefile.in
index 31ff95500c9..151dbfa54ec 100644 index f9f9f377b..938eacb2d 100644
--- a/gcc/Makefile.in --- a/gcc/Makefile.in
+++ b/gcc/Makefile.in +++ b/gcc/Makefile.in
@@ -155,6 +155,9 @@ LDFLAGS = @LDFLAGS@ @@ -155,6 +155,9 @@ LDFLAGS = @LDFLAGS@
@ -230,7 +230,7 @@ index 31ff95500c9..151dbfa54ec 100644
# Like LINKER, but use a mutex for serializing front end links. # Like LINKER, but use a mutex for serializing front end links.
ifeq (@DO_LINK_MUTEX@,true) ifeq (@DO_LINK_MUTEX@,true)
@@ -1057,18 +1059,21 @@ ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS) @@ -1053,18 +1055,21 @@ ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS)
ALL_COMPILERFLAGS = $(ALL_CXXFLAGS) ALL_COMPILERFLAGS = $(ALL_CXXFLAGS)
# This is the variable to use when using $(LINKER). # This is the variable to use when using $(LINKER).
@ -257,8 +257,25 @@ index 31ff95500c9..151dbfa54ec 100644
BUILD_LIBIBERTY = $(build_libobjdir)/libiberty/libiberty.a BUILD_LIBIBERTY = $(build_libobjdir)/libiberty/libiberty.a
endif endif
diff --git a/gcc/ada/gcc-interface/Makefile.in b/gcc/ada/gcc-interface/Makefile.in
index 1f15652d2..ac72dff97 100644
--- a/gcc/ada/gcc-interface/Makefile.in
+++ b/gcc/ada/gcc-interface/Makefile.in
@@ -253,10 +253,10 @@ LIBDEPS = $(LIBINTL_DEP) $(LIBICONV_DEP) $(LIBBACKTRACE) $(LIBIBERTY)
TGT_LIB =
TOOLS_LIBS = ../link.o ../targext.o ../../ggc-none.o ../../libcommon-target.a \
../../libcommon.a ../../../libcpp/libcpp.a $(LIBGNAT) $(LIBINTL) $(LIBICONV) \
- ../$(LIBBACKTRACE) ../$(LIBIBERTY) $(SYSLIBS) $(TGT_LIB)
+ ../$(LIBBACKTRACE) ../$(LIBIBERTY) $(SYSLIBS) $(TGT_LIB) -no-pie
# Add -no-pie to TOOLS_LIBS since some of them are compiled with -fno-PIE.
-TOOLS_LIBS += @NO_PIE_FLAG@
+#TOOLS_LIBS += @NO_PIE_FLAG@
# Specify the directories to be searched for header files.
# Both . and srcdir are used, in that order,
diff --git a/gcc/configure b/gcc/configure diff --git a/gcc/configure b/gcc/configure
index 258b17a226e..bd4fe1fd6ca 100755 index d42dc78ca..36aac2e4f 100755
--- a/gcc/configure --- a/gcc/configure
+++ b/gcc/configure +++ b/gcc/configure
@@ -632,10 +632,10 @@ ac_includes_default="\ @@ -632,10 +632,10 @@ ac_includes_default="\
@ -275,7 +292,7 @@ index 258b17a226e..bd4fe1fd6ca 100755
enable_host_shared enable_host_shared
enable_plugin enable_plugin
pluginlibs pluginlibs
@@ -1025,6 +1025,7 @@ enable_link_serialization @@ -1021,6 +1021,7 @@ enable_link_serialization
enable_version_specific_runtime_libs enable_version_specific_runtime_libs
enable_plugin enable_plugin
enable_host_shared enable_host_shared
@ -283,7 +300,7 @@ index 258b17a226e..bd4fe1fd6ca 100755
enable_libquadmath_support enable_libquadmath_support
with_linker_hash_style with_linker_hash_style
with_diagnostics_color with_diagnostics_color
@@ -1787,6 +1788,7 @@ Optional Features: @@ -1783,6 +1784,7 @@ Optional Features:
in a compiler-specific directory in a compiler-specific directory
--enable-plugin enable plugin support --enable-plugin enable plugin support
--enable-host-shared build host code as shared libraries --enable-host-shared build host code as shared libraries
@ -291,7 +308,7 @@ index 258b17a226e..bd4fe1fd6ca 100755
--disable-libquadmath-support --disable-libquadmath-support
disable libquadmath support for Fortran disable libquadmath support for Fortran
--enable-default-pie enable Position Independent Executable as default --enable-default-pie enable Position Independent Executable as default
@@ -32221,13 +32223,17 @@ fi @@ -32341,13 +32343,17 @@ fi
# Enable --enable-host-shared # Enable --enable-host-shared
# Check whether --enable-host-shared was given. # Check whether --enable-host-shared was given.
if test "${enable_host_shared+set}" = set; then : if test "${enable_host_shared+set}" = set; then :
@ -312,7 +329,7 @@ index 258b17a226e..bd4fe1fd6ca 100755
# Check whether --enable-libquadmath-support was given. # Check whether --enable-libquadmath-support was given.
@@ -32381,10 +32387,6 @@ rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext @@ -32501,10 +32507,6 @@ rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
fi fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $gcc_cv_c_no_fpie" >&5 { $as_echo "$as_me:${as_lineno-$LINENO}: result: $gcc_cv_c_no_fpie" >&5
$as_echo "$gcc_cv_c_no_fpie" >&6; } $as_echo "$gcc_cv_c_no_fpie" >&6; }
@ -323,7 +340,7 @@ index 258b17a226e..bd4fe1fd6ca 100755
# Check if -no-pie works. # Check if -no-pie works.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for -no-pie option" >&5 { $as_echo "$as_me:${as_lineno-$LINENO}: checking for -no-pie option" >&5
@@ -32409,11 +32411,28 @@ rm -f core conftest.err conftest.$ac_objext \ @@ -32529,11 +32531,28 @@ rm -f core conftest.err conftest.$ac_objext \
fi fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $gcc_cv_no_pie" >&5 { $as_echo "$as_me:${as_lineno-$LINENO}: result: $gcc_cv_no_pie" >&5
$as_echo "$gcc_cv_no_pie" >&6; } $as_echo "$gcc_cv_no_pie" >&6; }
@ -355,10 +372,10 @@ index 258b17a226e..bd4fe1fd6ca 100755
# Check whether --enable-cet was given. # Check whether --enable-cet was given.
if test "${enable_cet+set}" = set; then : if test "${enable_cet+set}" = set; then :
diff --git a/gcc/configure.ac b/gcc/configure.ac diff --git a/gcc/configure.ac b/gcc/configure.ac
index 06750cee977..dca995aeec7 100644 index 2cc2def0c..c8bf3d9a5 100644
--- a/gcc/configure.ac --- a/gcc/configure.ac
+++ b/gcc/configure.ac +++ b/gcc/configure.ac
@@ -7488,11 +7488,14 @@ fi @@ -7564,11 +7564,14 @@ fi
# Enable --enable-host-shared # Enable --enable-host-shared
AC_ARG_ENABLE(host-shared, AC_ARG_ENABLE(host-shared,
[AS_HELP_STRING([--enable-host-shared], [AS_HELP_STRING([--enable-host-shared],
@ -376,7 +393,7 @@ index 06750cee977..dca995aeec7 100644
AC_ARG_ENABLE(libquadmath-support, AC_ARG_ENABLE(libquadmath-support,
[AS_HELP_STRING([--disable-libquadmath-support], [AS_HELP_STRING([--disable-libquadmath-support],
@@ -7614,10 +7617,6 @@ AC_CACHE_CHECK([for -fno-PIE option], @@ -7690,10 +7693,6 @@ AC_CACHE_CHECK([for -fno-PIE option],
[gcc_cv_c_no_fpie=yes], [gcc_cv_c_no_fpie=yes],
[gcc_cv_c_no_fpie=no]) [gcc_cv_c_no_fpie=no])
CXXFLAGS="$saved_CXXFLAGS"]) CXXFLAGS="$saved_CXXFLAGS"])
@ -387,7 +404,7 @@ index 06750cee977..dca995aeec7 100644
# Check if -no-pie works. # Check if -no-pie works.
AC_CACHE_CHECK([for -no-pie option], AC_CACHE_CHECK([for -no-pie option],
@@ -7628,10 +7627,27 @@ AC_CACHE_CHECK([for -no-pie option], @@ -7704,10 +7703,27 @@ AC_CACHE_CHECK([for -no-pie option],
[gcc_cv_no_pie=yes], [gcc_cv_no_pie=yes],
[gcc_cv_no_pie=no]) [gcc_cv_no_pie=no])
LDFLAGS="$saved_LDFLAGS"]) LDFLAGS="$saved_LDFLAGS"])
@ -419,10 +436,10 @@ index 06750cee977..dca995aeec7 100644
# Enable Intel CET on Intel CET enabled host if jit is enabled. # Enable Intel CET on Intel CET enabled host if jit is enabled.
GCC_CET_HOST_FLAGS(CET_HOST_FLAGS) GCC_CET_HOST_FLAGS(CET_HOST_FLAGS)
diff --git a/gcc/doc/install.texi b/gcc/doc/install.texi diff --git a/gcc/doc/install.texi b/gcc/doc/install.texi
index 93eae1f2582..be6985646b2 100644 index 68a0f2b04..8352e8f3a 100644
--- a/gcc/doc/install.texi --- a/gcc/doc/install.texi
+++ b/gcc/doc/install.texi +++ b/gcc/doc/install.texi
@@ -1021,14 +1021,26 @@ code. @@ -975,14 +975,26 @@ code.
@item --enable-host-shared @item --enable-host-shared
Specify that the @emph{host} code should be built into position-independent Specify that the @emph{host} code should be built into position-independent
@ -452,7 +469,7 @@ index 93eae1f2582..be6985646b2 100644
Specify that the compiler should assume that the Specify that the compiler should assume that the
assembler it finds is the GNU assembler. However, this does not modify assembler it finds is the GNU assembler. However, this does not modify
diff --git a/libcody/Makefile.in b/libcody/Makefile.in diff --git a/libcody/Makefile.in b/libcody/Makefile.in
index 7eaf8ace8ce..0ff1625a39f 100644 index b8b45a2e3..64394ea79 100644
--- a/libcody/Makefile.in --- a/libcody/Makefile.in
+++ b/libcody/Makefile.in +++ b/libcody/Makefile.in
@@ -31,7 +31,7 @@ endif @@ -31,7 +31,7 @@ endif
@ -465,7 +482,7 @@ index 7eaf8ace8ce..0ff1625a39f 100644
# Per-source & per-directory compile flags (warning: recursive) # Per-source & per-directory compile flags (warning: recursive)
diff --git a/libcody/configure b/libcody/configure diff --git a/libcody/configure b/libcody/configure
index da52a5cfca5..0e536c0ccb0 100755 index da52a5cfc..0e536c0cc 100755
--- a/libcody/configure --- a/libcody/configure
+++ b/libcody/configure +++ b/libcody/configure
@@ -591,7 +591,10 @@ configure_args @@ -591,7 +591,10 @@ configure_args
@ -532,7 +549,7 @@ index da52a5cfca5..0e536c0ccb0 100755
# Check whether --enable-exceptions was given. # Check whether --enable-exceptions was given.
diff --git a/libcody/configure.ac b/libcody/configure.ac diff --git a/libcody/configure.ac b/libcody/configure.ac
index 960191ecb72..14e8dd4a226 100644 index 960191ecb..14e8dd4a2 100644
--- a/libcody/configure.ac --- a/libcody/configure.ac
+++ b/libcody/configure.ac +++ b/libcody/configure.ac
@@ -63,9 +63,31 @@ fi @@ -63,9 +63,31 @@ fi
@ -570,7 +587,7 @@ index 960191ecb72..14e8dd4a226 100644
NMS_ENABLE_EXCEPTIONS NMS_ENABLE_EXCEPTIONS
diff --git a/libcpp/configure b/libcpp/configure diff --git a/libcpp/configure b/libcpp/configure
index 75145390215..85168273cd1 100755 index 7e28606f6..1dfec854f 100755
--- a/libcpp/configure --- a/libcpp/configure
+++ b/libcpp/configure +++ b/libcpp/configure
@@ -625,6 +625,8 @@ ac_includes_default="\ @@ -625,6 +625,8 @@ ac_includes_default="\
@ -582,7 +599,7 @@ index 75145390215..85168273cd1 100755
MAINT MAINT
USED_CATALOGS USED_CATALOGS
PACKAGE PACKAGE
@@ -738,6 +740,7 @@ enable_maintainer_mode @@ -737,6 +739,7 @@ enable_maintainer_mode
enable_checking enable_checking
enable_canonical_system_headers enable_canonical_system_headers
enable_host_shared enable_host_shared
@ -590,7 +607,7 @@ index 75145390215..85168273cd1 100755
enable_cet enable_cet
enable_valgrind_annotations enable_valgrind_annotations
' '
@@ -1379,6 +1382,7 @@ Optional Features: @@ -1378,6 +1381,7 @@ Optional Features:
--enable-canonical-system-headers --enable-canonical-system-headers
enable or disable system headers canonicalization enable or disable system headers canonicalization
--enable-host-shared build host code as shared libraries --enable-host-shared build host code as shared libraries
@ -598,7 +615,7 @@ index 75145390215..85168273cd1 100755
--enable-cet enable Intel CET in host libraries [default=auto] --enable-cet enable Intel CET in host libraries [default=auto]
--enable-valgrind-annotations --enable-valgrind-annotations
enable valgrind runtime interaction enable valgrind runtime interaction
@@ -7605,7 +7609,23 @@ esac @@ -7532,7 +7536,23 @@ esac
# Enable --enable-host-shared. # Enable --enable-host-shared.
# Check whether --enable-host-shared was given. # Check whether --enable-host-shared was given.
if test "${enable_host_shared+set}" = set; then : if test "${enable_host_shared+set}" = set; then :
@ -624,10 +641,10 @@ index 75145390215..85168273cd1 100755
PICFLAG= PICFLAG=
fi fi
diff --git a/libcpp/configure.ac b/libcpp/configure.ac diff --git a/libcpp/configure.ac b/libcpp/configure.ac
index 9b6042518e5..d25bf5f414f 100644 index 1efa96f7c..605cacb4c 100644
--- a/libcpp/configure.ac --- a/libcpp/configure.ac
+++ b/libcpp/configure.ac +++ b/libcpp/configure.ac
@@ -211,8 +211,23 @@ esac @@ -203,8 +203,23 @@ esac
# Enable --enable-host-shared. # Enable --enable-host-shared.
AC_ARG_ENABLE(host-shared, AC_ARG_ENABLE(host-shared,
[AS_HELP_STRING([--enable-host-shared], [AS_HELP_STRING([--enable-host-shared],
@ -654,7 +671,7 @@ index 9b6042518e5..d25bf5f414f 100644
# Enable Intel CET on Intel CET enabled host if jit is enabled. # Enable Intel CET on Intel CET enabled host if jit is enabled.
diff --git a/libdecnumber/configure b/libdecnumber/configure diff --git a/libdecnumber/configure b/libdecnumber/configure
index da5302f9315..d805fdeab5a 100755 index 6b62f8ba6..a76e50a49 100755
--- a/libdecnumber/configure --- a/libdecnumber/configure
+++ b/libdecnumber/configure +++ b/libdecnumber/configure
@@ -626,6 +626,8 @@ ac_subst_vars='LTLIBOBJS @@ -626,6 +626,8 @@ ac_subst_vars='LTLIBOBJS
@ -708,7 +725,7 @@ index da5302f9315..d805fdeab5a 100755
PICFLAG= PICFLAG=
fi fi
diff --git a/libdecnumber/configure.ac b/libdecnumber/configure.ac diff --git a/libdecnumber/configure.ac b/libdecnumber/configure.ac
index 0794031ec83..14f67f926d1 100644 index 16b9493dc..62fba75ec 100644
--- a/libdecnumber/configure.ac --- a/libdecnumber/configure.ac
+++ b/libdecnumber/configure.ac +++ b/libdecnumber/configure.ac
@@ -100,8 +100,23 @@ AC_C_BIGENDIAN @@ -100,8 +100,23 @@ AC_C_BIGENDIAN
@ -738,7 +755,7 @@ index 0794031ec83..14f67f926d1 100644
# Enable Intel CET on Intel CET enabled host if jit is enabled. # Enable Intel CET on Intel CET enabled host if jit is enabled.
diff --git a/zlib/configure b/zlib/configure diff --git a/zlib/configure b/zlib/configure
index f489f31bc70..0dfc1982844 100755 index f489f31bc..16cce7a3a 100755
--- a/zlib/configure --- a/zlib/configure
+++ b/zlib/configure +++ b/zlib/configure
@@ -635,6 +635,8 @@ am__EXEEXT_TRUE @@ -635,6 +635,8 @@ am__EXEEXT_TRUE
@ -810,7 +827,7 @@ index f489f31bc70..0dfc1982844 100755
cat >confcache <<\_ACEOF cat >confcache <<\_ACEOF
diff --git a/zlib/configure.ac b/zlib/configure.ac diff --git a/zlib/configure.ac b/zlib/configure.ac
index be1cfe29651..adf7aad4e51 100644 index be1cfe296..adf7aad4e 100644
--- a/zlib/configure.ac --- a/zlib/configure.ac
+++ b/zlib/configure.ac +++ b/zlib/configure.ac
@@ -122,11 +122,26 @@ else @@ -122,11 +122,26 @@ else
@ -843,8 +860,6 @@ index be1cfe29651..adf7aad4e51 100644
+AC_SUBST(PICFLAG) +AC_SUBST(PICFLAG)
AC_CONFIG_FILES([Makefile]) AC_CONFIG_FILES([Makefile])
AC_OUTPUT AC_OUTPUT
base-commit: ee50b4383a0dca88172c3a821418344bd7391956
-- --
2.34.1 2.47.0

Loading…
Cancel
Save